当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]ubuntu 8.04下编译安装wine 0.9.6
帖子发表于 : 2008-05-03 21:24 

注册: 2007-04-11 23:01
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
最近安装了8.04
用apt-get安装了wine,不好用,老出问题,于是想编译安装0.9.6
但是无法解决依赖问题,提示如下

代码:
下列的软件包有不能满足的依赖关系:
  libasound2-dev: 依赖: libasound2 (= 1.0.14-1ubuntu8) 但是 1.0.15-3ubuntu4 正要被安装
  libcupsys2-dev: 依赖: libcupsys2 (= 1.3.2-1ubuntu7.6) 但是 1.3.7-1ubuntu3 正要被安装
                  依赖: libkrb5-dev 但是它将不会被安装
  libdbus-1-dev: 依赖: libdbus-1-3 (= 1.1.1-3ubuntu4) 但是 1.1.20-1ubuntu1 正要被安装
  libesd0-dev: 依赖: libesd-alsa0 (= 0.2.38-0ubuntu4.1) 但是 0.2.38-0ubuntu9 正要被安装 或
                       libesd0 (= 0.2.38-0ubuntu4.1)
               依赖: libaudiofile-dev 但是它将不会被安装
  libexif-dev: 依赖: libexif12 (= 0.6.16-1) 但是 0.6.16-2.1 正要被安装
  libexpat1-dev: 依赖: libexpat1 (= 1.95.8-4ubuntu1) 但是 2.0.1-0ubuntu1 正要被安装
  libfontconfig1-dev: 依赖: libfontconfig1 (= 2.4.2-1.2ubuntu4) 但是 2.5.0-2ubuntu3 正要被安装
  libgcrypt11-dev: 依赖: libgcrypt11 (= 1.2.4-2ubuntu2) 但是 1.2.4-2ubuntu7 正要被安装
  libglib2.0-dev: 依赖: libglib2.0-0 (= 2.14.1-1ubuntu1) 但是 2.16.3-1 正要被安装
  libglu1-mesa-dev: 依赖: libglu1-mesa (= 7.0.1-1ubuntu3) 但是 7.0.3~rc2-1ubuntu3 正要被安装
  libgnutls-dev: 依赖: libgnutls13 (= 1.6.3-1build1) 但是 2.0.4-1ubuntu2 正要被安装
                 依赖: libopencdk8-dev 但是它将不会被安装
  libgpg-error-dev: 依赖: libgpg-error0 (= 1.4-2ubuntu1) 但是 1.4-2ubuntu7 正要被安装
  libgphoto2-2-dev: 依赖: libgphoto2-2 (= 2.4.0-2ubuntu2) 但是 2.4.0-8ubuntu6 正要被安装
  libhal-dev: 依赖: libhal1 (= 0.5.9.1-6ubuntu5) 但是 0.5.11~rc2-1ubuntu7 正要被安装
  libice-dev: 依赖: libice6 (= 2:1.0.3-3) 但是 2:1.0.4-1 正要被安装
  libieee1284-3-dev: 依赖: libieee1284-3 (= 0.2.10-8) 但是 0.2.11-3 正要被安装
  liblcms1-dev: 依赖: liblcms1 (= 1.16-5ubuntu3) 但是 1.16-7ubuntu1 正要被安装
  libltdl3-dev: 依赖: libltdl3 (= 1.5.24-1ubuntu1) 但是 1.5.26-1ubuntu1 正要被安装
  libncurses5-dev: 依赖: libncurses5 (= 5.6+20070716-1ubuntu3) 但是 5.6+20071124-1ubuntu2 正要被安装
  libogg-dev: 依赖: libogg0 (= 1.1.3-2ubuntu2) 但是 1.1.3-3ubuntu1 正要被安装
  libopencdk10-dev: 依赖: libopencdk10 (= 0.6.4-1) 但是 0.6.6-1ubuntu1 正要被安装
  libpng12-dev: 依赖: libpng12-0 (= 1.2.15~beta5-2ubuntu0.1) 但是 1.2.15~beta5-3 正要被安装
  libsane-dev: 依赖: libsane (= 1.0.19~cvs20070505-3ubuntu2) 但是 1.0.19-1ubuntu3 正要被安装
  libssl-dev: 依赖: libssl0.9.8 (= 0.9.8e-5ubuntu3.1) 但是 0.9.8g-4ubuntu3 正要被安装
  libtasn1-3-dev: 依赖: libtasn1-3 (= 0.3.9-1) 但是 1.1-1 正要被安装
  libtiff4-dev: 依赖: libtiff4 (= 3.8.2-7ubuntu2) 但是 3.8.2-7ubuntu3 正要被安装
  libusb-dev: 依赖: libusb-0.1-4 (= 2:0.1.12-7) 但是 2:0.1.12-8 正要被安装
  libvorbis-dev: 依赖: libvorbis0a (= 1.2.0.dfsg-1) 但是 1.2.0.dfsg-2 正要被安装
                 依赖: libvorbisenc2 (= 1.2.0.dfsg-1) 但是 1.2.0.dfsg-2 正要被安装
                 依赖: libvorbisfile3 (= 1.2.0.dfsg-1) 但是 1.2.0.dfsg-2 正要被安装
  libx11-dev: 依赖: libx11-6 (= 2:1.1.1-1ubuntu4) 但是 2:1.1.3-1ubuntu2 正要被安装
  libxcomposite-dev: 依赖: libxcomposite1 (= 1:0.4.0-0ubuntu1) 但是 1:0.4.0-1 正要被安装
  libxcursor-dev: 依赖: libxcursor1 (= 1:1.1.8-2) 但是 1:1.1.9-1 正要被安装
  libxft-dev: 依赖: libxft2 (= 2.1.12-2ubuntu4) 但是 2.1.12-2ubuntu5 正要被安装
  libxi-dev: 依赖: libxi6 (= 2:1.1.2-1) 但是 2:1.1.3-1 正要被安装
  libxml2-dev: 依赖: libxml2 (= 2.6.30.dfsg-2ubuntu1.1) 但是 2.6.31.dfsg-2ubuntu1 正要被安装
  libxmu-dev: 依赖: libxmu6 (= 2:1.0.3-1ubuntu1) 但是 2:1.0.4-1 正要被安装
  libxrandr-dev: 依赖: libxrandr2 (= 2:1.2.1-1) 但是 2:1.2.2-1 正要被安装
  libxrender-dev: 依赖: libxrender1 (= 1:0.9.2-1) 但是 1:0.9.4-1 正要被安装
  libxslt1-dev: 依赖: libxslt1.1 (= 1.1.21-2ubuntu2) 但是 1.1.22-1ubuntu1 正要被安装
  zlib1g-dev: 依赖: zlib1g (= 1:1.2.3.3.dfsg-5ubuntu2) 但是 1:1.2.3.3.dfsg-7ubuntu1 正要被安装
E: 无法安装的软件包


请教高人指点

PS:以上提示是在执行那个 "8.04-hardy的依赖解决脚本" 时出来的...


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-05-03 21:58 

注册: 2007-04-11 23:01
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
通报一下最新进展,安装了这个帖子中的包,没有做任何设置,很多游戏都完美运行了
http://forum.ubuntu.com.cn/viewtopic.ph ... 248#733248

难道贴图错误的问题仅仅跟wine版本有关?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译