[问题]麻烦各位看看为什么我用cedega虚拟cs1.5和暗黑2不能玩。

Wine、Cedega、CrossOver 等配置
回复
头像
mystical
帖子: 170
注册时间: 2007-11-19 19:53
送出感谢: 0
接收感谢: 0

[问题]麻烦各位看看为什么我用cedega虚拟cs1.5和暗黑2不能玩。

#1

帖子 mystical » 2008-05-16 10:42

今天没事,就想试试cedega。。于是安装了cedega,并虚拟了cs1.5和暗黑2,可是死活就是无法进入游戏。以下是命令行启动游戏时的提示信息:

暗黑:
xxxx@ubuntu:~/TransGaming_Drive/Program Files/anhei/anhei$ cedega DIABLOII.exe
/usr/lib/transgaming_cedega/gddb.py:24: RuntimeWarning: Python C API version mismatch for module gddb_parser: This Python has API version 1013, module gddb_parser has version 1012.
import gddb_parser
warning: mmap failed on reservation of 00000000 (00110000)
X Error of failed request: BadImplementation (server does not implement operation)
Major opcode of failed request: 146 (MIT-SHM)
Minor opcode of failed request: 5 (X_ShmCreatePixmap)
Serial number of failed request: 28942
Current serial number in output stream: 28944
X Error of failed request: BadDrawable (invalid Pixmap or Window parameter)
Major opcode of failed request: 55 (X_CreateGC)
Resource id in failed request: 0x36003b6
Serial number of failed request: 28949
Current serial number in output stream: 28954



CS1.5:
xxxx@ubuntu:~/Game/CS1.5/CS1.5$ cedega cstrike.exe
/usr/lib/transgaming_cedega/gddb.py:24: RuntimeWarning: Python C API version mismatch for module gddb_parser: This Python has API version 1013, module gddb_parser has version 1012.
import gddb_parser
warning: mmap failed on reservation of 00000000 (00110000)
X Error of failed request: BadImplementation (server does not implement operation)
Major opcode of failed request: 146 (MIT-SHM)
Minor opcode of failed request: 5 (X_ShmCreatePixmap)
Serial number of failed request: 3554
Current serial number in output stream: 3559
X Error of failed request: BadDrawable (invalid Pixmap or Window parameter)
Major opcode of failed request: 55 (X_CreateGC)
Resource id in failed request: 0x360034a
Serial number of failed request: 3557
Current serial number in output stream: 3559


麻烦大家看看是为什么。多谢了。
头像
壹哥
帖子: 199
注册时间: 2008-01-02 17:26
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 壹哥 » 2008-05-16 11:35

Python C API version mismatch for module gddb_parser
你设置好源更新下看看
头像
mystical
帖子: 170
注册时间: 2007-11-19 19:53
送出感谢: 0
接收感谢: 0

#3

帖子 mystical » 2008-05-16 17:16

好的 我试试
回复

回到 “Wine及其分支”