[问题]刚装的wine,但运行不了win程序

Wine、Cedega、CrossOver 等配置
回复
v.ki
帖子: 24
注册时间: 2008-05-23 21:08
送出感谢: 0
接收感谢: 0

[问题]刚装的wine,但运行不了win程序

#1

帖子 v.ki » 2008-05-28 21:28

Application tried to create a window, but no driver could be loaded.
The X11 driver is missing. Check your build!
Application tried to create a window, but no driver could be loaded.
The X11 driver is missing. Check your build!

出现这个错误。是什么没装好吗?帮帮忙,谢谢啦
v.ki
帖子: 24
注册时间: 2008-05-23 21:08
送出感谢: 0
接收感谢: 0

#2

帖子 v.ki » 2008-05-28 21:59

没有人碰到过吗?
yi.codeplayer
帖子: 20
注册时间: 2006-05-11 9:14
来自: 深圳
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 yi.codeplayer » 2008-05-28 23:31

没遇见过,貌似很奇怪的错误,顶一下。
v.ki
帖子: 24
注册时间: 2008-05-23 21:08
送出感谢: 0
接收感谢: 0

#4

帖子 v.ki » 2008-05-29 11:06

谢谢支持。。。。
头像
luojie-dune
帖子: 22033
注册时间: 2007-07-30 18:28
系统: Linux
来自: 空气中
送出感谢: 9 次
接收感谢: 61 次

#5

帖子 luojie-dune » 2008-05-29 11:12

英文已经提示了, 但我不了解X11和wine的关系.
『这个世界都是我的 ,我爱你们』

ENTP ⥂ INTP ⥄ INFP ⇦ INTJ

在此发布的文章使用 Creative Commons Attribution-ShareAlike 4.0 协议
头像
Ur@nus
帖子: 622
注册时间: 2006-12-01 23:02
送出感谢: 0
接收感谢: 0

#6

帖子 Ur@nus » 2008-05-29 13:55

是不是显卡没去动好,或者缺少XGL之类的
安装一下Xlib/Xfree86 和FontForge
看是不是缺这两个包?
头像
Ur@nus
帖子: 622
注册时间: 2006-12-01 23:02
送出感谢: 0
接收感谢: 0

#7

帖子 Ur@nus » 2008-05-29 13:57

如果还不行,先卸载就得wine。装好所有依赖后,再安装wine。
可以参考这篇文章http://forum.ubuntu.com.cn/viewtopic.php?t=76591
v.ki
帖子: 24
注册时间: 2008-05-23 21:08
送出感谢: 0
接收感谢: 0

#8

帖子 v.ki » 2008-05-29 18:38

以上你们说的包我都安装了。。。。。
v.ki
帖子: 24
注册时间: 2008-05-23 21:08
送出感谢: 0
接收感谢: 0

#9

帖子 v.ki » 2008-05-29 18:39

还是一样的提示。。。再想想还有什么包的,呵。
谢谢各位啦。
头像
luojie-dune
帖子: 22033
注册时间: 2007-07-30 18:28
系统: Linux
来自: 空气中
送出感谢: 9 次
接收感谢: 61 次

#10

帖子 luojie-dune » 2008-05-29 18:43

已经编译了吧?那么在怎么弄都不行, 先把原来安装的清理了.
原来编译的目录里
sudo make clean
『这个世界都是我的 ,我爱你们』

ENTP ⥂ INTP ⥄ INFP ⇦ INTJ

在此发布的文章使用 Creative Commons Attribution-ShareAlike 4.0 协议
v.ki
帖子: 24
注册时间: 2008-05-23 21:08
送出感谢: 0
接收感谢: 0

#11

帖子 v.ki » 2008-05-29 18:55

之前是自己编译安装的,
现在在新立得那重新安装了遍,终于可以了。。。
k330769158
帖子: 10
注册时间: 2008-05-30 10:20
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 k330769158 » 2008-05-30 10:36

这个问题我也遇过....

REGEDIT4

[HKEY_CURRENT_USER\Software\Wine\X11 Driver]
"ClientSideAntiAliasWithCore"="N"
"ClientSideAntiAliasWithRender"="N"
"ClientSideWithRender"="N"
"DXGrab"="Y"
"ScreenDepth"="32"
"UseXRandR"="N"
"UseXVidMode"="Y"

我只是将上面的删去就可以了...
poet
帖子: 2841
注册时间: 2006-09-11 22:47
送出感谢: 0
接收感谢: 4 次

#13

帖子 poet » 2008-05-30 10:40

如果自己编译的话,一定要先 sudo apt-get build-dep wine ,然后再编译,编译出来的才能用。
leon68
帖子: 7
注册时间: 2008-04-24 16:30
送出感谢: 0
接收感谢: 0

#14

帖子 leon68 » 2008-05-31 15:47

Ur@nus 写了:是不是显卡没去动好,或者缺少XGL之类的
安装一下Xlib/Xfree86 和FontForge
看是不是缺这两个包?


请问怎么安装这两个包?
头像
Ur@nus
帖子: 622
注册时间: 2006-12-01 23:02
送出感谢: 0
接收感谢: 0

#15

帖子 Ur@nus » 2008-06-01 18:19

apt-cache 一下,然后安装名字最像的,我都是这么干的
回复

回到 “Wine及其分支”