[已解决][问题]创建wine魔兽 启动脚本 问题,请教解决方法

Wine、Cedega、CrossOver 等配置
回复
neilshao
帖子: 60
注册时间: 2008-05-03 14:56
送出感谢: 0
接收感谢: 0

[已解决][问题]创建wine魔兽 启动脚本 问题,请教解决方法

#1

帖子 neilshao » 2008-05-29 17:50

我的wine起动脚本为war3.sh内容如下(我的是nv卡):
#!/bin/sh
#uncomment if launching from console session
#sudo /etc/init.d/gdm stop
#KDE use this instead
#sudo /etc/init.d/kdm stop

# Launches a new X session on display 3. If you don't have an Nvidia card
# take out the "& nvidia-settings --load-config-only" part
X :3 -ac & nvidia-settings --load-config-only

# Goto game dir (modify as needed)
cd "/home/neil/Warcraft III"

# Forces the system to have a break for 2 seconds, X doesn't launch instantly
sleep 2

# Launches game (modify as needed)
DISPLAY=:3 env WINEPREFIX="/home/neil/.wine" WINEDEBUG=-all wine "/home/neil/Warcraft III/Frozen Throne.exe" -opengl


ctrl+alt+f1进入终端输入sh war3.sh
重复出现如下提示:
X: user not authorized to run the X server, aborting.
war3.sh: 9: nvidia-settings: not found
Application tried to create a window, but no driver could be loaded.
Make sure that your X server is running and that $DISPLAY is set correctly.
上次由 neilshao 在 2008-06-01 10:58,总共编辑 1 次。
neilshao
帖子: 60
注册时间: 2008-05-03 14:56
送出感谢: 0
接收感谢: 0

#2

帖子 neilshao » 2008-06-01 10:57

解决方法是
X :3 -ac & nvidia-settings --load-config-only
改样
sudo X :3 -ac & nvidia-settings --load-config-only
回复

回到 “Wine及其分支”