[已解决]virtualbox在8.04下的安装.键盘输入法.内核升级.安全等问题

Wine、Cedega、CrossOver 等配置
回复
头像
bt_one
帖子: 136
注册时间: 2008-04-18 20:58
送出感谢: 0
接收感谢: 0

[已解决]virtualbox在8.04下的安装.键盘输入法.内核升级.安全等问题

#1

帖子 bt_one » 2008-06-07 0:13

1、更新系统到最新:
sudo apt-get upgrade

2、到新立得安装virtualbox-ose(源里是1.56)

3、进入桌面后,安装这个包virtualbox-ose-modules-2.6.24-20-generic(我用的是18的内核),这是把virtualbox-ose加载为2.6.24-20-generic内核动态模块的包
安装命令:
sudo apt-get install virtualbox-ose-modules-2.6.24-20-generic

4、加载内核模块
sudo modprobe vboxdrv
(这里如果警告的话不要紧继续下面的)

5.把你的登录用户加入vboxusers组中:系统管理->用户和组,先unlock解锁,然后点“组管理”,找到vboxusers,右键->属性,在下面组成员里把你的用户名打勾然后确定即可。

6.设置vboxdrv设备权限,让vboxusers组具有对/dev/vboxdrv具有读写权限:
sudo chown username:vboxusers /dev/vboxdrv
(username换成你的用户名)
(这个地方如果显示没有文件夹的话转到下面的补充的方法里继续)

7.输入法;
打开新立得,把scim-bridge-client-qt重装了下,同时把scim-bridge-client-qt4也给装了
命令:
sudo gedit /etc/X11/xinit/xinput.d/default
把其中的内容改成
XIM=scim
XIM_PROGRAM=scim
XIM_ARGS=scim
XIM_PROGRAM_XTRA=scim
GTK_IM_MODULE=scim
QT_IM_MODULE=scim
保存

9.在vbox首选项中取消自动捕获热键

重启,可以调出scim,virtualbox也可以调出键盘

现在就可以畅快使用virtualbox了。。。



补充:
输入命令:
sudo apt-get install virtualbox-ose-source
完成后
代码:
sudo /etc/init.d/vboxdrv start
结果:
* Starting VirtualBox kernel module vboxdrv [ OK ]

这里没有问题了继续第7步



现在添加的是内核更新了以后vbox升级的办法:
终端下直接依次输入以下的命令也就是编译模块的
sudo apt-get install virtualbox-ose-source
sudo m-a update
sudo m-a prepare
sudo m-a a-i virtualbox-ose
sudo /etc/init.d/vboxdrv restart

我试过 很管用 大家可以试试



注意:VBOX只是虚拟机 和单独使用的系统是一样的 (建议安装深度精简的XP) 我装的XP3的 内存设置最好是按默认的来 太大了反而会影响性能 装系统的盘最好不要和UB的盘共用 单独分个出来( 刚开始让你选择安装的时候会提到最好是选择独立分出个盘空间) 小点没有关系 东西多了往共享拖 杀毒没有必要 本来里面也容不下那么多东西 要装就要牺牲性能了 裸奔可以 我安装了360安全卫士(实时监控还是不错不会在启动项乱搞)和保险箱里(面有银行QQ什么的可以利用下)这两个装了不占内存还是比较好 用了一个月 卡巴杀了次 没有毒 然后卸载 不需要装 定期安装查杀就可以了 又不用愁注册 卸载就去下个 ( YourUninstaller2008清理高手) 卸载很干净 系统内一般少开网页 没有必要的就不要开 浏览器随意 我是怕麻烦 直接用了360的 还好 ……


现在说下通用IP
10.0.2.*(2以上)
255.255.255.0
10.0.2.2

10.0.2.2
10.0.2.3
怎么设置我就不说了 大家看了就知道
上次由 bt_one 在 2008-08-19 16:42,总共编辑 4 次。
cvgmt
帖子: 322
注册时间: 2007-02-26 2:29
来自: 广东
送出感谢: 0
接收感谢: 0

#2

帖子 cvgmt » 2008-06-07 4:57

我也出现键盘用不了的问题,先借鉴一下你的做法
cvgmt
帖子: 322
注册时间: 2007-02-26 2:29
来自: 广东
送出感谢: 0
接收感谢: 0

#3

帖子 cvgmt » 2008-06-07 5:17

搞定,谢谢!您的帖为什么不发到虚拟机和虚拟化呢,让更多人找到您的做法啊
cvgmt
帖子: 322
注册时间: 2007-02-26 2:29
来自: 广东
送出感谢: 0
接收感谢: 0

#4

帖子 cvgmt » 2008-06-07 7:10

但声音还是不行
cvgmt
帖子: 322
注册时间: 2007-02-26 2:29
来自: 广东
送出感谢: 0
接收感谢: 0

#5

帖子 cvgmt » 2008-06-07 10:08

声音行了,是我选的 XP 系统问题,选了一个完整的 XP 后没问题了,谢谢!
ClearWind
帖子: 179
注册时间: 2007-06-28 16:45
送出感谢: 0
接收感谢: 0

#6

帖子 ClearWind » 2008-06-07 16:04

为什么linux下装个软件都这么麻烦,为何不能把这些安装包都集成在一起,难道是有版权问题.

而且更让人郁闷的是如果系统更新在进行着,那么别的任何软件也装不了,巨麻烦。系统更新应该让它独立进行更好,不然根本上没法再做别的了,我的系统更新装了一个星期了还在更新.
头像
cnkilior
论坛版主
帖子: 4979
注册时间: 2007-08-05 17:40
送出感谢: 0
接收感谢: 5 次

#7

帖子 cnkilior » 2008-06-07 16:15

楼上:问你个问题:

你在windows中安装.msi的软件包时,你再安一个.msi包看看?(注意一定是.msi打包的软件哦!)

你现在应该这样抱怨了:

妈的,微软那个傻X,都不允许我同时安软件,做的真TMD垃圾!

windows总共有3中软件安装模式:.msi,压缩模式,install wizard。

linux中也有3种模式:.deb(.rpm),压缩模式(直接可运行:例如:奔流),编译安装!
delectate
帖子: 18311
注册时间: 2008-01-09 22:41
送出感谢: 0
接收感谢: 6 次

#8

帖子 delectate » 2008-07-21 20:56

cnkilior 写了:楼上:问你个问题:

你在windows中安装.msi的软件包时,你再安一个.msi包看看?(注意一定是.msi打包的软件哦!)

你现在应该这样抱怨了:

妈的,微软那个傻X,都不允许我同时安软件,做的真TMD垃圾!

windows总共有3中软件安装模式:.msi,压缩模式,install wizard。

linux中也有3种模式:.deb(.rpm),压缩模式(直接可运行:例如:奔流),编译安装!
呵呵,喜欢deb,省事,太省事了

以至于没有一点编译的乐趣了

还是自己编译wine好玩啊!

曾经试过bin,没劲
veushid
帖子: 100
注册时间: 2007-12-25 13:13
送出感谢: 0
接收感谢: 0

#9

帖子 veushid » 2008-07-25 19:14

回去试一下,看看是不是管用
头像
bt_one
帖子: 136
注册时间: 2008-04-18 20:58
送出感谢: 0
接收感谢: 0

#10

帖子 bt_one » 2008-08-12 10:35

全新的更新 呵呵 附加了很多东西 希望大家有用
头像
bt_one
帖子: 136
注册时间: 2008-04-18 20:58
送出感谢: 0
接收感谢: 0

#11

帖子 bt_one » 2008-08-12 11:26

听大家的意见我在虚拟机和虚拟化里发了这帖 这里的帖子怎么删除呢
头像
bt_one
帖子: 136
注册时间: 2008-04-18 20:58
送出感谢: 0
接收感谢: 0

#12

帖子 bt_one » 2008-08-12 11:31

cvgmt 写了:但声音还是不行
声音选择 ALSA 不是默认的 你自己调整
poet
帖子: 2841
注册时间: 2006-09-11 22:47
送出感谢: 0
接收感谢: 4 次

#13

帖子 poet » 2008-08-12 12:54

cnkilior 写了:楼上:问你个问题:
你在windows中安装.msi的软件包时,你再安一个.msi包看看?(注意一定是.msi打包的软件哦!)
你没搞清楚问题的关键所在。
最花时间的操作是下载而不是安装,而在windows update中,漫长的下载过程里,什么事情都可以做,仅仅开始安装了才会封闭其他并行操作。

在 sudo apt-get upgrade 操作中,前一半是下载,后一般是安装,但只要开始运行apt-get了,其他基于 apt-get 的程序都不能运行了。如果你正在做 apt-get upgrade,哪怕是想开一个新立得仅仅“浏览”包都不行。——这倒确实是弊病。
回复

回到 “Wine及其分支”