当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 8.10编译wine出错
帖子发表于 : 2008-06-21 23:10 

注册: 2007-07-18 12:23
帖子: 38
送出感谢: 0 次
接收感谢: 0 次
checking for -lfreetype... not found
configure: error: FreeType development files not found.
Fonts will not be built. Dialog text may be invisible or unaligned.
Use the --without-freetype option if you really want this.


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 8.10编译wine出错
帖子发表于 : 2008-06-21 23:22 
头像

注册: 2007-03-13 11:23
帖子: 1343
送出感谢: 0 次
接收感谢: 0 次
hi001 写道:
checking for -lfreetype... not found
configure: error: FreeType development files not found.
Fonts will not be built. Dialog text may be invisible or unaligned.
Use the --without-freetype option if you really want this.

apt-get build-dep wine


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 8.10编译wine出错
帖子发表于 : 2008-07-12 17:48 

注册: 2008-07-12 17:44
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
hi001 写道:
checking for -lfreetype... not found
configure: error: FreeType development files not found.
Fonts will not be built. Dialog text may be invisible or unaligned.
Use the --without-freetype option if you really want this.

哈哈,楼主我跟你有一样的问题,用apt-get build-dep wine 也是不行的。
找了半天,终于知道是64位的问题,64位的编译麻烦一点点,可以使用下面代码
sudo ./configure --enable-win64
可以看一下这个
http://wiki.winehq.org/Wine64[/code]


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 8.10编译wine出错
帖子发表于 : 2008-09-26 19:53 

注册: 2008-03-30 8:27
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
不好意思 我再编译wine的时候有同样的错误 可是我无法使用 build-dep 出现错误如下

代码:
dan@dan:~/sources/wine-1.1.5$ sudo apt-get build-dep wine
讀取套件清單中... 完成
了解套件依存關係中       
Reading state information... 完成
E: 『sources.list』檔中必須有一些『source』指令。


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 8.10编译wine出错
帖子发表于 : 2008-09-27 0:49 

注册: 2007-09-12 10:30
帖子: 240
送出感谢: 0 次
接收感谢: 0 次
china-willing 写道:
hi001 写道:
checking for -lfreetype... not found
configure: error: FreeType development files not found.
Fonts will not be built. Dialog text may be invisible or unaligned.
Use the --without-freetype option if you really want this.

哈哈,楼主我跟你有一样的问题,用apt-get build-dep wine 也是不行的。
找了半天,终于知道是64位的问题,64位的编译麻烦一点点,可以使用下面代码
sudo ./configure --enable-win64
可以看一下这个
http://wiki.winehq.org/Wine64[/code]


This port is not yet functional, and only people who are planning to fix the code will want to compile Wine like this.
不推荐这种编译方法,编译出来是64位的Wine。最好还是把Wine编译成32位的:http://wiki.winehq.org/WineOn64bit


_________________
Dell Inspiron 1520
Intel Centrino Duo MTL
Intel 965PM Express
Core 2 Duo T7250 2.0GHz
2GB 667MHz DDR2
NVIDIA GeForce Go 8600M GT
120GB SATA
Intel PRO/Wireless 3945
OS:Ubuntu 8.10 64位
Status:一切正常


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 8.10编译wine出错
帖子发表于 : 2008-12-23 20:58 
头像

注册: 2008-05-03 23:05
帖子: 383
送出感谢: 0 次
接收感谢: 0 次
OK,就是楼上的链接,
问题是
代码:
sudo apt-get build-dep wine

的时候
引用:
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Build-dependencies for wine could not be satisfied.



页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译