当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]wine三国志5有音效没有音乐,人物头像也没有
帖子发表于 : 2008-07-06 21:36 

注册: 2007-11-03 14:16
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
音效文件是wav,因此播放没有问题
而音乐文件是mp3的,所以播放出了错
不知道有没有好的解决方法

错误如下:
fixme:mci:MCI_LoadMciDriver Couldn't load driver for type L"MPEGVIDEO".
If you don't have a windows installation accessible from Wine,
you perhaps forgot to create a [mci] section in system.ini
fixme:mountmgr:harddisk_ioctl unsupported ioctl 2402c
fixme:mcicda:MCICDA_GetError Unknown mode 1

system.ini里面的内容如下:
[mci]
MPEGVideo=mciqtz.drv
MPEGVideo2=mciqtz.drv
avivideo=mciavi32.dll
cdaudio=mcicda.dll
sequencer=mciseq.dll
vcr=mcivisca.drv
; videodisc=mcipionr.drv
waveaudio=mciwave.dll

我找了个mciqtz.drv放到system32下也还是没有音乐


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-07-08 12:59 
头像

注册: 2007-03-08 10:47
帖子: 262
送出感谢: 0 次
接收感谢: 0 次
用Dosbox玩Dos版好了


_________________
My blog: hsquared66.blogspot.com


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-08-17 23:23 
头像

注册: 2007-04-28 15:14
帖子: 1143
系统: NixOS+虚拟机各种系统
送出感谢: 0 次
接收感谢: 3
我的wine三国志九也是有音效没背景音乐阿,找方法中……
音效wav的也没问题

音乐文件为wma,视频文件为mpg


感觉应该是解码器问题,我的解码器一直装不上,提示要装wmp6.4以上,我是装了的,但好像认不到,而装的wmp10则装不上,要系统升级,wine里的wmp9也播放不了


_________________
黑色的不是眼睛,而是眼圈
关注和实现科技领域未来3年内有大规模普及潜力、能改善穷人生活品质的技术/应用。
皓龙双路 + NixOS + openbox + qemu/spice 爱编 + 藏噶+蒙文输入法+3d打印管理+激光雕刻


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译