当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]為什麽我裝不了wine?
帖子发表于 : 2008-07-12 12:09 
头像

注册: 2008-01-25 9:55
帖子: 285
地址: 深圳中學高中部
送出感谢: 0 次
接收感谢: 1
RT
鄙人是按照winehq.org上的指引來的
引用:
Wine for Ubuntu, Debian, and Debian-based distributions Debian Linux

Debian and Debian-based distributions such as Ubuntu utilize a special tool for managing packages known as APT. APT is able to automagically install all of the needed dependencies for a software package, as well as keep the package up to date, by scanning what are known as APT repositories. Debian-based distributions have their own repositories of software that include Wine, however we keep our own repository of the latest available packages here for download.

There used to be graphical instructions here, however we have found that the terminal commands are actually simpler to describe and quicker for the user to input. Because the commands below use sudo, you may have to enter your user password after hitting enter.
Adding the WineHQ APT Repository:

First, open a terminal window (Applications->Accessories->Terminal). Then add the repository's key to your system's list of trusted APT keys by copy and pasting the following:

wget -q http://wine.budgetdedicated.com/apt/387EE263.gpg -O- | sudo apt-key add -

Next, add the repository to your system's list of APT sources:

For Ubuntu Hardy (8.04):
sudo wget http://wine.budgetdedicated.com/apt/sou ... hardy.list -O /etc/apt/sources.list.d/winehq.list

For Debian Etch (4.0):
sudo wget http://wine.budgetdedicated.com/apt/sou ... /etch.list -O /etc/apt/sources.list.d/winehq.list

Then update APT's package information by running 'sudo apt-get update'.

Now you can install Wine by clicking this link. Alternatively, you can install by going to Applications->Add/Remove and searching for Wine.

結果最後```RT。。。


_________________
唉,在中國高中苦了三年,本來應該晉升到中國的大學好好耍個四年的...
結果「不知爲了什麼」愣是考去了美帝。現在日子天天如高三:各種考試、各種作業、各種...


最后由 szjuntao 编辑于 2008-07-12 12:13,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-07-12 12:09 
头像

注册: 2008-01-25 9:55
帖子: 285
地址: 深圳中學高中部
送出感谢: 0 次
接收感谢: 1
問題
後來用sudo apt-get install wine裝
顯示: wine: 依赖: winbind 但是它将不会被安装
sudo apt-get install winbind
顯示: winbind: 依赖: samba-common (= 3.0.28a-1ubuntu4.1) 但是 3.0.28a-1ubuntu4.4 正要被安装
無語
我要怎麽辦???? :em19 :em19 :em19 :em21 :em21 :em21


附件:
problem.jpg
problem.jpg [ 80.04 KiB | 被浏览 304 次 ]



_________________
唉,在中國高中苦了三年,本來應該晉升到中國的大學好好耍個四年的...
結果「不知爲了什麼」愣是考去了美帝。現在日子天天如高三:各種考試、各種作業、各種...
页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-07-12 12:17 
头像

注册: 2006-03-12 14:17
帖子: 178
送出感谢: 0 次
接收感谢: 13
sudo apt-get install binfmt-support winbind
http://wine.budgetdedicated.com/archive/ubuntu/hardy/wine_1.1.0~winehq0~ubuntu~8.04-1_i386.deb


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-07-12 12:34 
头像

注册: 2008-01-25 9:55
帖子: 285
地址: 深圳中學高中部
送出感谢: 0 次
接收感谢: 1
代码:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
读取状态信息... 完成             
binfmt-support 已经是最新的版本了。
binfmt-support 设定为手动安装。
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
  winbind: 依赖: samba-common (= 3.0.28a-1ubuntu4.1) 但是 3.0.28a-1ubuntu4.4 正要被安装
E: 无法安装的软件包

還是不行啊


_________________
唉,在中國高中苦了三年,本來應該晉升到中國的大學好好耍個四年的...
結果「不知爲了什麼」愣是考去了美帝。現在日子天天如高三:各種考試、各種作業、各種...


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-07-12 13:03 
头像

注册: 2006-03-12 14:17
帖子: 178
送出感谢: 0 次
接收感谢: 13
卸载 samba-common


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-07-12 13:07 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
sudo aptitude install wine

不行的话检查源版本是否和系统版本对应


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-07-12 14:48 
头像

注册: 2008-01-25 9:55
帖子: 285
地址: 深圳中學高中部
送出感谢: 0 次
接收感谢: 1
沒辦法最後降級裝了 0.9.61
再次過回幸福生活~~~ :D
謝謝各位 ----------Thank You All The Same!! :D


_________________
唉,在中國高中苦了三年,本來應該晉升到中國的大學好好耍個四年的...
結果「不知爲了什麼」愣是考去了美帝。現在日子天天如高三:各種考試、各種作業、各種...


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-07-13 13:29 

注册: 2008-06-25 13:16
帖子: 23
送出感谢: 0 次
接收感谢: 0 次
刚才试了一下,先remove掉samba-common,然后再按指引上的装。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译