真正的解决声卡独占问题

Wine、Cedega、CrossOver 等配置
回复
3959512
帖子: 64
注册时间: 2008-08-21 12:25
来自: 上海
送出感谢: 0
接收感谢: 0
联系:

真正的解决声卡独占问题

#1

帖子 3959512 » 2008-09-26 18:06

google找了很多资料都是一样没有效果的方法,用以下方法成功了

让alsa用它自己的软件混合器一个更好的方法来让esd和不是esd识别的应用程序在一起工作

$ sudo /etc/init.d/alsa-utils stop
$ sudo gedit /var/lib/alsa/asound.state
将下面语句拷到打开的文档语句前面(add the following text verbatim to the start of this file)

# This text should be added to the beginning of
# /var/lib/alsa/asound.state. You only need to add
# it once -- it is saved across reboots.
pcm.asymed {
type asym
playback.pcm dmix
capture.pcm dsnoop
}
pcm.default {
type plug
slave.pcm asymed
}
pcm.dmix {
type dmix
ipc_key 5678293
ipc_key_add_uid yes
slave {
pcm 'hw:0,0'
period_time 0
period_size 128
buffer_size 2048
format S16_LE
rate 48000
}
}
pcm.dsnoop {
type dsnoop
ipc_key 5778293
ipc_key_add_uid yes
slave {
pcm 'hw:0,0'
period_time 0
period_size 128
buffer_size 2048
format S16_LE
rate 48000
}
}

$ sudo /etc/init.d/alsa-utils start

现在,你可以让你想要的软件全部同时使用声卡, 不管是输出还是和麦克风!ESD识别的应用程序可以使用ESD,另外的应用程序也一样可以正常工作.

一个ESD很显着的不好的特性就是在播放视频的时候它会破坏在音频与视频的同步.在设定好软件混合器以後, 你可能会发觉把esd关闭会有些帮助(在音频控制面板里边反选"开启software mixing'). 现在, 特别是在GStreamer 0.10下, 你的电影应该不会有音频和视频不同步发生了. It's a shame that software mixing isn't enabled on Ubuntu by default. software mixing在ubuntu的预设里边不是开启的.

按照这个设置好之后并没有马上生效。。我也忘了之前怎么设置的了。
不过只改了下下面,如图所示...
附件
r_Screenshot-Sound Preferences.png
Sound Preferences设置
unliang
帖子: 82
注册时间: 2006-06-18 16:10
送出感谢: 0
接收感谢: 1 次

Re: 真正的解决声卡独占问题

#2

帖子 unliang » 2008-09-26 23:06

问题解决
头像
catfish
帖子: 41
注册时间: 2008-09-24 8:56
送出感谢: 0
接收感谢: 0

Re: 真正的解决声卡独占问题

#3

帖子 catfish » 2008-09-30 19:42

标记一下,声卡独占
我只看看,我不说话
头像
8139
帖子: 29
注册时间: 2008-01-12 0:27
送出感谢: 0
接收感谢: 0

Re: 真正的解决声卡独占问题

#4

帖子 8139 » 2008-10-03 18:49

首选项-音效里面全部改用ALSA就可以解决声卡独占了
沧浪翻涌剑留影
紫箫空鸣无人聆
delectate
帖子: 18311
注册时间: 2008-01-09 22:41
送出感谢: 0
接收感谢: 6 次

Re: 真正的解决声卡独占问题

#5

帖子 delectate » 2008-10-04 9:23

catfish 写了:标记一下,声卡独占
头像
FEE WANG
帖子: 66
注册时间: 2007-11-23 7:20
来自: 中国湖北省武汉市
送出感谢: 0
接收感谢: 0
联系:

Re: 真正的解决声卡独占问题

#6

帖子 FEE WANG » 2008-10-05 17:28

为什么我按楼主的方法设置了,还是不行。而且前置音频插口声音一直不正常。
We'd better struggle for the future rather than regret for the past.
3959512
帖子: 64
注册时间: 2008-08-21 12:25
来自: 上海
送出感谢: 0
接收感谢: 0
联系:

Re: 真正的解决声卡独占问题

#7

帖子 3959512 » 2008-12-27 12:55

FEE WANG 写了:为什么我按楼主的方法设置了,还是不行。而且前置音频插口声音一直不正常。
后来我因为安装XP双系统,又重装过Ubuntu两遍,每次解决声卡独占问题,都是按照我的上面的方法做的,有时也是一次不成功,再来,系统重启,再试。 最后都成功了。

具体的以上操作为什么对有些人行,对有些人不行,是因为个人的电脑配置声卡不一样。 解决声卡独占问题的方法就是在上图的一些设置选择中。肯定可以。多尝试一下其他的选择。

接触Ubuntu也有小半年,遇到一些问题,在网络上找到一些方法,但多数中都不行。真的是越来越觉得,在某些人电脑上能顺利解决的方法,未必一定在自己的电脑上一样起到效果,也许仅仅就因为别此电脑上的一个很小的差别。
回复

回到 “Wine及其分支”