当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : wine 1.1.9 +MS offfice 2007中文字体有些问题
帖子发表于 : 2008-11-26 13:31 

注册: 2008-09-21 1:01
帖子: 34
送出感谢: 0 次
接收感谢: 0 次
ubuntu8.04英文版,locale如下:
LANG=en_US.UTF-8
LC_CTYPE=zh_CN.UTF-8
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=
主要参考了http://forum.ubuntu.org.cn/viewtopic.php?p=902749&sid=ca4ba3406b00cc044aa0a265ea27daea的配置过程,其中也出现了文中提到的出现的“些人可能在安完 .NET2.0以后会出现一些错误提示”的错误,不过用该文的解决方案重新安装wine后也没去除这个错误,因此我直接忽略了这个错误继续安装,wine office2007也是能安装成功的,过有些出错信息,主要一句为:menubuild can not build menu (大概这个意思,具体没记下来了)。

按照参考文章安装完毕wine ~/.wine/drive_c/Program\ Files/Microsoft\ Office/Office12/WINWORD.EXE /safe可以打开word,但是(标题栏等处)明显不是用的正常中文字体,非常丑。 :em20
于是我就把原来xp下的fonts中的文件全部拷贝到了~/.wine/drive_c/windows/fonts下,这下打开word的字体显示总算正常了,不过很郁闷的是在正文中打字,然后调整中文字体,对应文字完全不会跟据字体变化。。。。即所有中文字体,对应文字都是同一种样子。。。 将文档保存后拿到xp系统下,原先选择不同字体的文字都显示正常,所以问题的关键就是在wine中我那拷贝过去的所有xp下的字体应该没有与wine下word中的字体选项没关联好阿 :em20 ,不知该怎么解决,各位大牛帮帮忙阿!


页首
 用户资料  
 
2 楼 
 文章标题 : Re: wine 1.1.9 +MS offfice 2007中文字体有些问题
帖子发表于 : 2008-11-26 23:18 

注册: 2008-09-21 1:01
帖子: 34
送出感谢: 0 次
接收感谢: 0 次
我顶。。。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:lilydjwg, wynosjud 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译