当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 安装wine1.1.23时出现下列“你需要安装32位开发库”错误,要安装那些库呢 ?
帖子发表于 : 2009-06-07 11:12 

注册: 2008-06-29 12:53
帖子: 59
送出感谢: 0 次
接收感谢: 0 次
提示如下:
Wine Installer v1.0

Running configure...

checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking for cpp... cpp
checking whether gcc -m32 works... no
configure: error: Cannot build a 32-bit program, you need to install 32-bit development libraries.

Configure failed, aborting install.


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 安装wine1.1.23时出现下列“你需要安装32位开发库”错误,要安装那些库呢 ?
帖子发表于 : 2009-06-07 14:04 

注册: 2007-07-08 1:53
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
我刚编译安装完,开始也是这个提示,后来用新立得安装了gcc的32位库,再./configure, 又是缺一堆文件,再用新立得一一装完,安装成功


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 安装wine1.1.23时出现下列“你需要安装32位开发库”错误,要安装那些库呢 ?
帖子发表于 : 2009-06-10 11:25 
头像

注册: 2005-03-30 0:27
帖子: 3294
送出感谢: 0 次
接收感谢: 2
别玩 64 位了,

wine 的所谓 amd64 版本,
仅仅是支持在 64 位下编译出 32 位的 wine。

(因为你跑的 windows 程序是 32 位的)


_________________
跃过无数的时间断层,只为了在


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译