安装了ubuntu10.10,不能联网想安装wine

Wine、Cedega、CrossOver 等配置
回复
模糊信仰
帖子: 7
注册时间: 2010-09-05 14:24
送出感谢: 0
接收感谢: 0

安装了ubuntu10.10,不能联网想安装wine

#1

帖子 模糊信仰 » 2010-11-03 7:52

情况就是:我要上网,得先安装wine,才能用我们学校的客户端;
而我要安装wine,就得先上网~~~~ :em20

我同学那天帮我下了几个版本的wine的deb,1.2和1.3的都有,不过安装的时候,提示说缺乏依赖;

能否给点提示和建议+wine的下载地址【二进制源码】 :em06
头像
sevk
帖子: 2059
注册时间: 2007-05-08 16:26
系统: arch
来自: 火星内核某分子内某原子核内
送出感谢: 20 次
接收感谢: 6 次
联系:

Re: 安装了ubuntu10.10,不能联网想安装wine

#2

帖子 sevk » 2010-11-03 9:21

kk@ubuntu:~$ aw wine1.2
软件包: wine1.2
新: 是
状态: 未安装
版本号: 1.2-0ubuntu6~lucid5
优先级: 可选
部分: universe/otherosfs
维护者: Ubuntu MOTU Developers <ubuntu-motu@lists.ubuntu.com>
未压缩尺寸: 87.1M
依赖于: procps, binfmt-support (>= 1.1.2), libasound2 (> 1.0.22), libaudio2, libc6 (>=
2.11), libesd0 (>= 0.2.35), libgl1-mesa-glx | libgl1, libglu1-mesa | libglu1,
libgphoto2-2 (>= 2.4.3), libgphoto2-port0 (>= 2.4.3), libice6 (>= 1:1.0.0),
liblcms1 (>= 1.15-1), libldap-2.4-2 (>= 2.4.7), libmpg123-0 (>= 1.6.2),
libopenal1, libsm6, libx11-6 (>= 0), libxau6, libxext6 (>= 0), libxml2 (>=
2.7.4), libxt6, zlib1g (>= 1:1.1.4), debconf (>= 0.5) | debconf-2.0
预依赖于: dpkg (>= 1.14.12ubuntu3)
推荐: ttf-symbol-replacement, ttf-liberation, winbind, wine1.2-gecko,
ttf-mscorefonts-installer, gnome-exe-thumbnailer | kdebase-runtime, cups-bsd,
winetricks, wisotool
建议: xdg-utils
冲突: binfmt-support (< 1.1.2), libwine, libwine-alsa, libwine-arts, libwine-capi,
libwine-cms, libwine-esd, libwine-gl, libwine-gphoto2, libwine-jack,
libwine-ldap, libwine-nas, libwine-print, libwine-sane, libwine-twain,
ttf-tahoma-replacement, wine (< 1.1.36-0ubuntu2), wine-doc, wine-utils, wine1.0,
winesetuptk, xwine
代替: libwine-alsa, libwine-arts, libwine-capi, libwine-cms, libwine-esd, libwine-gl,
libwine-gphoto2, libwine-jack, libwine-ldap, libwine-nas, libwine-print,
libwine-sane, libwine-twain, ttf-tahoma-replacement, wine (< 1.1.36-0ubuntu2),
wine-doc, wine-utils, wine1.0, winesetuptk, xwine
提供: wine
描述: Microsoft Windows Compatibility Layer (Binary Emulator and Library)
Wine is a compatibility layer for running Windows applications on Linux. Applications
are run at full speed without the need of cpu emulation. Wine does not require
Microsoft Windows, however it can use native system dll files in place of its own if
they are available.

This package includes a program loader for running unmodified Windows executables as
well as the Wine project's free version of the Windows API for running programs ported
from Windows.

This package is based on a recent Wine beta. While many more applications will work,
there may be some loss of functionality compared with the stable release provided by
the regular wine package.
主页: http://www.winehq.org/





这么多依赖包都要下载。

你们学校是什么 客户端呀? 直接做进路由器里吧,用OPENWRT
笔记本 :
F208S : gentoo
A460P i3G D6 : UBUNTU + WIN7
UN43D1 : UBUNTU + WIN7
1000人超级QQ群 LINUX + WIN : 31465544 或 18210387
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

Re: 安装了ubuntu10.10,不能联网想安装wine

#3

帖子 eexpress » 2010-11-03 9:22

搜索 windows下下载deb的帖子。
有win下下载依赖的方法。
记得有py脚本搞的。

手动的方法,估计你会搞不定。
● 鸣学
xiezhaoping
帖子: 3
注册时间: 2009-11-04 12:39
送出感谢: 0
接收感谢: 0

Re: 安装了ubuntu10.10,不能联网想安装wine

#4

帖子 xiezhaoping » 2010-11-03 11:46

我的也是,用的是视讯宽带,一定要用它的拨号软件才能上网。装不了WINE,最后装了CrossOver,可以安装那个拨号软件了,但一拨号就说有检测到多个IP地址,不能登陆上网。谁能解决呢。
头像
haichang417
帖子: 243
注册时间: 2009-05-03 15:00
来自: 西伺胡同
送出感谢: 0
接收感谢: 0
联系:

Re: 安装了ubuntu10.10,不能联网想安装wine

#5

帖子 haichang417 » 2010-11-20 9:19

在windows下安装一个虚拟机(我用的VirtualBox),设置虚拟机从硬盘启动,这样可以进入ubuntu,设置NAT联网,虚拟机里ubuntu就可以联网了。然后添加wine的源,安装wine就可以了。剩下的大家就都知道怎么做了吧。
编程就像编筐一样
回复

回到 “Wine及其分支”