当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 1 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : wine安装问题
帖子发表于 : 2010-11-15 12:38 

注册: 2010-10-30 15:19
帖子: 26
送出感谢: 0 次
接收感谢: 0 次
安装wine的时候出问题了!
error: X development files not found. Wine will be built without X support, which probably isn't what you want. You will need to install development packages of Xlib/Xfree86 at the very least. Use the --without-x option if you really want this.
上网搜了一下,sudo apt-get install gnome-devel 可以解决
可是运行的时候,它就一直依赖关系不满足,再安装它要依赖那个,又有依赖关系不满足了
请大家看看,有什么能帮帮忙的,谢谢阿

$ sudo apt-get install gnome-devel
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
gnome-devel: 依赖: libgdl-1-dev (>= 2.28) 但是它将不会被安装
推荐: gnome-core-devel 但是它将不会被安装
E: 破损的软件包

$ sudo apt-get install libgdl-1-dev
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
libgdl-1-dev: 依赖: libgtk2.0-dev (>= 2.12.0) 但是它将不会被安装
E: 破损的软件包

$ sudo apt-get install libgtk2.0-dev
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
libgtk2.0-dev: 依赖: libgtk2.0-0 (= 2.20.0-0ubuntu4) 但是 2.20.1-0ubuntu2 正要被安装
依赖: libglib2.0-dev (>= 2.21.3) 但是它将不会被安装
依赖: libpango1.0-dev (>= 1.20) 但是它将不会被安装
依赖: libatk1.0-dev (>= 1.13.0) 但是它将不会被安装
依赖: libcairo2-dev (>= 1.6.4-6.1) 但是它将不会被安装
E: 破损的软件包

$ sudo apt-get install libgtk2.0-0
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
libgtk2.0-0 已经是最新的版本了。
升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件包未被升级。

$ sudo apt-get install libglib2.0-dev
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
libglib2.0-dev: 依赖: libglib2.0-0 (= 2.24.0-0ubuntu4) 但是 2.24.1-0ubuntu1 正要被安装
E: 破损的软件包

请大家帮帮忙阿!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 1 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译