ubuntu610下安装wine,启动wine以及EasyWine执行的问题解决

Wine、Cedega、CrossOver 等配置
回复
oldniu
帖子: 172
注册时间: 2006-08-10 16:01
送出感谢: 0
接收感谢: 0

ubuntu610下安装wine,启动wine以及EasyWine执行的问题解决

#1

帖子 oldniu » 2006-11-29 20:26

我也在网上查寻了一下,得到的结论与
http://forum.ubuntu.org.cn/viewtopic.ph ... 0357ba4a81
一楼一致。即wine0.9.23以上版本与SCIM有冲突,运行环境Ubuntu610
ubuntu 直接apt 安装的wine0.9.25在运行winecfg时会报错无法执行
libGL warning: 3D driver claims to not support visual 0x4b
libGL warning: 3D driver claims to not support visual 0x4b
libGL warning: 3D driver claims to not support visual 0x4b
Failed to open the service control manager.

建议退回wine0.9.22下载地址
http://wine.budgetdedicated.com/archive/

重新安装先把原来的0.9.25去掉
sudo apt-get remove wine
然后用刚才下载到的安装包来安装,这个安装包适合dapper,但edge也行。
dpkg -i wine_0.9.22~winehq0~ubuntu~6.06-1_i386.deb
注意以后也暂时不要升级wine

关于wine启动速度慢的问题,是因为找不到GBK字体,请参考
http://forum.ubuntu.org.cn/viewtopic.php?t=17545
但其中的字体目录在ubutun610中为
/usr/share/fonts/X11/100dpi/fonts.dir
修订以后要重启xwindows, ctrl+alt+backspace


由于在ubuntu610中已经使用dash作为缺省的shell,所以使用EasyWine3.0也有点问题,安装后直接执行EasyWine会报错
/usr/bin/EasyWine: 1821: Syntax error: "}" unexpected (expecting ")")
正确的应该执行
bash EasyWine
螺钉头虽然愚笨但总想在坚实的生活里钻出自己的天地来。
gnugg
帖子: 7
注册时间: 2005-12-12 18:29
送出感谢: 0
接收感谢: 0

#2

帖子 gnugg » 2006-12-01 12:51

顶楼主,这正是这需要的
sonick
帖子: 18
注册时间: 2006-11-09 14:34
送出感谢: 0
接收感谢: 0

#3

帖子 sonick » 2006-12-05 18:23

顶,找了半天,终于有办法了,谢谢!
回复

回到 “Wine及其分支”