新手求助:软件包 wine1.5 没有可供安装的候选者[已解决】

Wine、Cedega、CrossOver 等配置
回复
azuojiao
帖子: 3
注册时间: 2013-03-31 12:05
系统: ubuntu12.04
送出感谢: 0
接收感谢: 0

新手求助:软件包 wine1.5 没有可供安装的候选者[已解决】

#1

帖子 azuojiao » 2013-03-31 12:09

在已经添加软件源,并更新过软件包列表的情况下,出现以下问题,求帮助:

azuojiao@azuojiao-ThinkPad-R61:~$ sudo apt-get install wine1.5
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
现在没有可用的软件包 wine1.5,但是它被其它的软件包引用了。
这可能意味着这个缺失的软件包可能已被废弃,
或者只能在其他发布源中找到

E: 软件包 wine1.5 没有可供安装的候选者
上次由 azuojiao 在 2013-03-31 17:39,总共编辑 1 次。
头像
mraandtux
论坛版主
帖子: 5108
注册时间: 2009-12-12 19:29
系统: Ubuntu + Windows 10
来自: 随便一个地方
送出感谢: 0
接收感谢: 161 次
联系:

Re: 新手求助:软件包 wine1.5 没有可供安装的候选者

#2

帖子 mraandtux » 2013-03-31 12:57

再换一次源。
头像
b33e
论坛版主
帖子: 3862
注册时间: 2011-06-07 14:20
系统: Mint18
送出感谢: 16 次
接收感谢: 62 次

Re: 新手求助:软件包 wine1.5 没有可供安装的候选者

#3

帖子 b33e » 2013-03-31 13:11

系统版本?
源里可能没有wine1.5
添加ppa

代码: 全选

 sudo add-apt-repository ppa:ubuntu-wine/ppa 
sudo apt-get update
然后就可以安装了
azuojiao
帖子: 3
注册时间: 2013-03-31 12:05
系统: ubuntu12.04
送出感谢: 0
接收感谢: 0

Re: 新手求助:软件包 wine1.5 没有可供安装的候选者

#4

帖子 azuojiao » 2013-03-31 16:14

谢谢各位。
但是问题仍然存在,感觉很无力啊。

代码: 全选

sudo add-apt-repository ppa:ubuntu-wine/ppa
sudo apt-get update
sudo apt-get install wine1.5
我完全按照上述步骤操作,之后还是这个问题。
我估计,是不是这个软件源不行了?
如果想换一个,还有其他的软件源吗?
azuojiao
帖子: 3
注册时间: 2013-03-31 12:05
系统: ubuntu12.04
送出感谢: 0
接收感谢: 0

Re: 新手求助:软件包 wine1.5 没有可供安装的候选者

#5

帖子 azuojiao » 2013-03-31 17:38

终于解决问题了,现在来反馈一下,为后来者参考。

运行了 sudo apt-get update
出现了以下问题:
W: GPG 错误:http://mirrors.163.com precise-proposed Release: 下列签名无效: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>
W: 无法下载 bzip2:/var/lib/apt/lists/partial/mirrors.163.com_ubuntu_dists_precise-updates_universe_binary-i386_Packages Hash 校验和不符
解决之后,就一切顺利了。
解决方法是
gpg --keyserver subkeys.pgp.net --recv 40976EAF437D05B5
gpg --export --armor 40976EAF437D05B5 | sudo apt-key add -
更加详细的见下边这个帖子:
viewtopic.php?t=378189
回复

回到 “Wine及其分支”