安装最近版的WINE(旧的ppa已不能用)

Wine、Cedega、CrossOver 等配置
回复
头像
Ping-Wu
帖子: 881
注册时间: 2012-11-14 9:34
系统: Ubuntu 18.04.1
送出感谢: 2 次
接收感谢: 45 次

安装最近版的WINE(旧的ppa已不能用)

#1

帖子 Ping-Wu » 2017-04-21 15:49

最近对WINE有兴趣*,但发现旧的ppa已不能用了。

新的安装方法如下:

代码: 全选

wget https://dl.winehq.org/wine-builds/Release.key
sudo apt-key add Release.key
sudo apt-add-repository 'https://dl.winehq.org/wine-builds/ubuntu/'
sudo apt update && sudo apt install winehq-devel
https://www.winehq.org/pipermail/wine-d ... 17104.html

最新的版本是 WINE 2.7。(印象中,好像 2.0才刚刚出来,怎么一下就跳到 2.7来了???)

《补充》听到一些(未证实)的传言,在WINE下执行旧版的Office及IE,比在xp里要顺。(即有些Windows dll 里的bugs,在转到WINE时被解决了。)

不过,更实际的问题是:有一些Windows专用的程序,在Windows 10里根本不能使用。

《170509补充》如底下所述,我们实际执行的步骤为:

代码: 全选

sudo dpkg --add-architecture i386
wget https://dl.winehq.org/wine-builds/Release.key
sudo apt-key add Release.key
sudo apt-add-repository 'https://dl.winehq.org/wine-builds/ubuntu/'
sudo apt update && sudo apt install --install-recommends winehq-devel
上次由 Ping-Wu 在 2017-05-09 1:56,总共编辑 2 次。
头像
qy117121
论坛版主
帖子: 49889
注册时间: 2007-12-14 13:40
系统: Winbuntu
来自: 志虚国乌由市
送出感谢: 17 次
接收感谢: 333 次
联系:

Re: 安装最近版的WINE(旧的ppa已不能用)

#2

帖子 qy117121 » 2017-04-21 16:59

版本号大跃进。。。
渠月 · QY    https://vz.rs/u
本人只会灌水,不负责回答问题

无聊可以点一下→ http://u.nu/ubuntu
头像
lilydjwg
论坛版主
帖子: 4163
注册时间: 2009-04-11 23:46
系统: Arch Linux
送出感谢: 11 次
接收感谢: 127 次
联系:

Re: 安装最近版的WINE(旧的ppa已不能用)

#3

帖子 lilydjwg » 2017-04-21 17:25

半个月升一下次版本号的样子……
头像
Ping-Wu
帖子: 881
注册时间: 2012-11-14 9:34
系统: Ubuntu 18.04.1
送出感谢: 2 次
接收感谢: 45 次

Re: 安装最近版的WINE(旧的ppa已不能用)

#4

帖子 Ping-Wu » 2017-04-22 1:24

lilydjwg 写了:半个月升一下次版本号的样子……
听到一些(未证实)的传言,在WINE下执行旧版的Office及IE,比在xp里要顺。(即有些Windows dll 里的bugs没有人管,但在转到WINE时被解决了。)

不过,更实际的问题是:有一些Windows专用的程序,在Windows 10里根本不能使用。

WINE的发展,好像已经快达到了“临界点”! 幕后最大的推力,我觉得跟 WINE for Macs 及 WINE for Chromebooks* 的开发有关。我们看到的使用Linux桌面的人,大多数都是一毛不拔的 :oops: 苹果跟Chromebook的使用者,则比较有花钱买软件(或apps)的习惯。

* 如我在其他的帖子里提到,这几年内,Chromebook在美国中小学里,势如破竹,已占有超过50%的市场。
头像
lilydjwg
论坛版主
帖子: 4163
注册时间: 2009-04-11 23:46
系统: Arch Linux
送出感谢: 11 次
接收感谢: 127 次
联系:

Re: 安装最近版的WINE(旧的ppa已不能用)

#5

帖子 lilydjwg » 2017-04-22 11:39

Ping-Wu 写了: WINE的发展,好像已经快达到了“临界点”! 幕后最大的推力,我觉得跟 WINE for Macs 及 WINE for Chromebooks* 的开发有关。我们看到的使用Linux桌面的人,大多数都是一毛不拔的 :oops: 苹果跟Chromebook的使用者,则比较有花钱买软件(或apps)的习惯。
我想花钱买 app 也没有可用的支付渠道……
jixlei
帖子: 5
注册时间: 2017-04-04 18:58
系统: ubuntu
送出感谢: 0
接收感谢: 0

Re: 安装最近版的WINE(旧的ppa已不能用)

#6

帖子 jixlei » 2017-05-04 21:17

按着你的方法安装了,但没有成功,具体信息如下:
2017-05-04 21-09-34屏幕截图.png
头像
Ping-Wu
帖子: 881
注册时间: 2012-11-14 9:34
系统: Ubuntu 18.04.1
送出感谢: 2 次
接收感谢: 45 次

Re: 安装最近版的WINE(旧的ppa已不能用)

#7

帖子 Ping-Wu » 2017-05-08 18:40

jixlei 写了:按着你的方法安装了,但没有成功,具体信息如下:

图片
很抱歉,我们的习惯,都是再加上 “ --install-recommends ” 这个option; 在第一次发稿时,我以为Ubuntu已经解决了这个问题,因此把它省略掉。看起来还是需要。

请试试下面这个命令:

代码: 全选

sudo apt install --install-recommends winehq-devel
另外,我们在下载wine之前,用下面的命令进行32-元的兼容性:

代码: 全选

sudo dpkg --add-architecture i386
我们的作业系统: Ubuntu Mate 16.04.2。

因此,我们实际执行的步骤为:

代码: 全选

sudo dpkg --add-architecture i386
wget https://dl.winehq.org/wine-builds/Release.key
sudo apt-key add Release.key
sudo apt-add-repository 'https://dl.winehq.org/wine-builds/ubuntu/'
sudo apt update && sudo apt install --install-recommends winehq-devel
《170509补充》 因为考虑到安全性的问题,我们把WINE装在LXD container里执行。以后有时间,再跟大家分享这个经验。
cheerland
帖子: 26
注册时间: 2017-02-13 16:00
系统: win10+ubuntu
送出感谢: 0
接收感谢: 0

Re: 安装最近版的WINE(旧的ppa已不能用)

#8

帖子 cheerland » 2017-05-16 9:43

it's still wrong,got the message below:
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
winehq-devel : 依赖: wine-devel (= 2.8.0~yakkety)
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系

my system version:ubuntu 16.10

what should I do?

and my soruces.list:
# deb cdrom:[Ubuntu 16.10 _Yakkety Yak_ - Release amd64 (20161012.2)]/ yakkety main restricted
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://cn.archive.ubuntu.com/ubuntu/ yakkety main restricted

#aliyun
deb http://mirrors.aliyun.com/ubuntu/ xenial main restricted universe multiverse
deb http://mirrors.aliyun.com/ubuntu/ xenial-security main restricted universe multiverse
deb http://mirrors.aliyun.com/ubuntu/ xenial-updates main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ yakkety-security restricted main
deb http://cn.archive.ubuntu.com/ubuntu/ yakkety-updates restricted main
deb https://dl.winehq.org/wine-builds/ubuntu/ yakkety main
# deb-src https://dl.winehq.org/wine-builds/ubuntu/ yakkety main
deb http://mirrors.aliyun.com/ubuntu/ xenial-backports main restricted universe multiverse
jixlei
帖子: 5
注册时间: 2017-04-04 18:58
系统: ubuntu
送出感谢: 0
接收感谢: 0

Re: 安装最近版的WINE(旧的ppa已不能用)

#9

帖子 jixlei » 2017-06-11 8:59

Ping-Wu 写了:
jixlei 写了:按着你的方法安装了,但没有成功,具体信息如下:

图片
很抱歉,我们的习惯,都是再加上 “ --install-recommends ” 这个option; 在第一次发稿时,我以为Ubuntu已经解决了这个问题,因此把它省略掉。看起来还是需要。

请试试下面这个命令:

代码: 全选

sudo apt install --install-recommends winehq-devel
另外,我们在下载wine之前,用下面的命令进行32-元的兼容性:

代码: 全选

sudo dpkg --add-architecture i386
我们的作业系统: Ubuntu Mate 16.04.2。

因此,我们实际执行的步骤为:

代码: 全选

sudo dpkg --add-architecture i386
wget https://dl.winehq.org/wine-builds/Release.key
sudo apt-key add Release.key
sudo apt-add-repository 'https://dl.winehq.org/wine-builds/ubuntu/'
sudo apt update && sudo apt install --install-recommends winehq-devel
《170509补充》 因为考虑到安全性的问题,我们把WINE装在LXD container里执行。以后有时间,再跟大家分享这个经验。

按照你的方法做了,结果还是不可以,错误信息仍然是未满足的依赖关系
poloshiao
论坛版主
帖子: 18220
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1946 次

Re: 安装最近版的WINE(旧的ppa已不能用)

#10

帖子 poloshiao » 2017-06-11 10:05

my system version:ubuntu 16.10
http://releases.ubuntu.com/16.10/
Ubuntu 16.10 (Yakkety Yak)
deb http://cn.archive.ubuntu.com/ubuntu/ yakkety main restricted
deb http://mirrors.aliyun.com/ubuntu/ xenial main restricted universe multiverse
檢查 /etc/apt/sources.list 及 /etc/apt/sources.list.d/*.list
是否混淆 yakkety 以外的版本號 ?
將會混淆 版本 及 相依套件 引起系統不穩定
winsons
帖子: 9
注册时间: 2017-06-14 20:46
系统: Ubuntu 17.04
送出感谢: 1 次
接收感谢: 0

Re: 安装最近版的WINE(旧的ppa已不能用)

#11

帖子 winsons » 2017-06-14 20:50

楼主,我想问下apt install 后面的 --install-recommends有什么用,我用man apt找不到这个选项,应该在哪看?
poloshiao
论坛版主
帖子: 18220
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1946 次

Re: 安装最近版的WINE(旧的ppa已不能用)

#12

帖子 poloshiao » 2017-06-15 7:38

sudo apt install --install-recommends winehq-devel
1. Ubuntu 預設 apt / apt-get install 指令 就會安裝 recommends 套件
1-1. 意思是 把 --install-recommends 取消看看
1-2. 反而 不安裝 recommends 套件 需要特別明白列出 --no-install-recommend
楼主,我想问下apt install 后面的 --install-recommends有什么用,我用man apt找不到这个选项,应该在哪看?
2. apt / apt-get 參數 稍有差異
2-1. man apt 參數 還不完備 如果找不到合適的參數 找 man apt-get (使用 apt-get 指令安裝)
2-2. 參閱 (使用 recommends 搜尋)
2-2-1. http://manpages.ubuntu.com/manpages/zes ... apt.8.html
apt - command-line interface
2-2-2. http://manpages.ubuntu.com/manpages/zes ... get.8.html
apt-get - APT package handling utility -- command-line interface
OPTIONS
--no-install-recommends
Do not consider recommended packages as a dependency for installing. Configuration Item: APT::Install-Recommends.
winsons
帖子: 9
注册时间: 2017-06-14 20:46
系统: Ubuntu 17.04
送出感谢: 1 次
接收感谢: 0

Re: 安装最近版的WINE(旧的ppa已不能用)

#13

帖子 winsons » 2017-06-15 9:22

poloshiao 写了:
sudo apt install --install-recommends winehq-devel
1. Ubuntu 預設 apt / apt-get install 指令 就會安裝 recommends 套件
1-1. 意思是 把 --install-recommends 取消看看
1-2. 反而 不安裝 recommends 套件 需要特別明白列出 --no-install-recommend
楼主,我想问下apt install 后面的 --install-recommends有什么用,我用man apt找不到这个选项,应该在哪看?
2. apt / apt-get 參數 稍有差異
2-1. man apt 參數 還不完備 如果找不到合適的參數 找 man apt-get (使用 apt-get 指令安裝)
2-2. 參閱 (使用 recommends 搜尋)
2-2-1. http://manpages.ubuntu.com/manpages/zes ... apt.8.html
apt - command-line interface
2-2-2. http://manpages.ubuntu.com/manpages/zes ... get.8.html
apt-get - APT package handling utility -- command-line interface
OPTIONS
--no-install-recommends
Do not consider recommended packages as a dependency for installing. Configuration Item: APT::Install-Recommends.
明白了谢谢!
头像
Ping-Wu
帖子: 881
注册时间: 2012-11-14 9:34
系统: Ubuntu 18.04.1
送出感谢: 2 次
接收感谢: 45 次

Re: 安装最近版的WINE(旧的ppa已不能用)

#14

帖子 Ping-Wu » 2017-06-15 9:38

poloshiao 写了:
sudo apt install --install-recommends winehq-devel
1. Ubuntu 預設 apt / apt-get install 指令 就會安裝 recommends 套件
1-1. 意思是 把 --install-recommends 取消看看
1-2. 反而 不安裝 recommends 套件 需要特別明白列出 --no-install-recommend
楼主,我想问下apt install 后面的 --install-recommends有什么用,我用man apt找不到这个选项,应该在哪看?
2. apt / apt-get 參數 稍有差異
2-1. man apt 參數 還不完備 如果找不到合適的參數 找 man apt-get (使用 apt-get 指令安裝)
2-2. 參閱 (使用 recommends 搜尋)
2-2-1. http://manpages.ubuntu.com/manpages/zes ... apt.8.html
apt - command-line interface
2-2-2. http://manpages.ubuntu.com/manpages/zes ... get.8.html
apt-get - APT package handling utility -- command-line interface
OPTIONS
--no-install-recommends
Do not consider recommended packages as a dependency for installing. Configuration Item: APT::Install-Recommends.
1. Ubuntu apt 指令 的预设值也是(包括了) --install-recommends。这个参数应该不需要,不过因为用习惯了,就等于是多一層保证吧。

2. 装了 winehq-devel以后,建议再装 playonlinux:

代码: 全选

sudo apt install --install-recommends playonlinux
(有了 winehq-devel 后,再装 playonlinux 只需要约 30MB的硬盘空间。)

在Ubuntu Mate里,要执行Windows程式时,点 Applications -> games -> playonlinux 即可,非常方便!

3. 楼上有人装 winehq-devel 有问题,乃是因为混合了不同版本的Ubuntu repositories。

我们在 Ubuntu Mate 16.04.2 跟 17.04 下,“分别”装了 winehq-develp/playonlinux, 都没有问题。

4. 希望大家多多提供在WINE下,执行中文版Windows程序的经验。谢谢!
这些用户感谢了作者 Ping-Wu 于这个帖子:
winsons (2017-06-15 11:13)
评价: 3.7%
头像
Ping-Wu
帖子: 881
注册时间: 2012-11-14 9:34
系统: Ubuntu 18.04.1
送出感谢: 2 次
接收感谢: 45 次

Re: 安装最近版的WINE(旧的ppa已不能用)

#15

帖子 Ping-Wu » 2017-06-19 14:42

Selection_064.jpg
突然发现(如上图),楼主的旧的 WINE ppa 还存在,当然会有问题了。

(一般ppa的套件库,不会显示在 /etc/apt/source.list 这个档案里面,而是以另一个独立档案放在 /etc/apt/source.list.d/这个档案夹里。)

Linux桌面逐渐要走上企业化,对套件库的要求,也越来越严格。

最近我装VirtualBox时,也因为稍微疏忽,套件库有问题,无法安装(已解决)。

必须把原来的WINE及所牵涉到的 ppa 卸掉,才能装新版的WINE,
回复

回到 “Wine及其分支”