当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [已解决]使用最新的winehq,编译wineasio出现了问题。
帖子发表于 : 2017-04-26 21:43 

注册: 2017-04-26 21:39
帖子: 7
系统: Arch Linux
送出感谢: 3
接收感谢: 0 次
我在编译wineasio的时候出现了问题,提示找不到"/usr/include/wine/debug.h"。
我使用的是winehq,但/opt/wine-devel/ 里并没有debug.h的文件,也没有/usr/include/wine。而在apt安装的wine里,/usr/include/wine 有这个文件。
请问我需要最新版的wine,但又需要wineasio怎么办呢?

谢谢!


最后由 eTee 编辑于 2017-04-27 0:15,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: 使用最新的winehq,编译wineasio出现了问题。
帖子发表于 : 2017-04-26 22:05 
头像

注册: 2011-03-20 13:12
帖子: 4552
地址: 山东省寿光县
系统: Debian
送出感谢: 106
接收感谢: 1009
eTee 写道:
我使用的是winehq问我需要最新版的wine,但又需要wineasio怎么办呢?

您可能需要安装对应的开发包,包名可能为 wine-staging-dev 或 wine-devel-dev,取决于您使用的是 wine-staging 还是 wine-devel


_________________
Debian 中文论坛 - forums.debiancn.org
欢迎所有 Debian GNU/Linux 用户



_________________
评价: 3.7% eTee
 
页首
 用户资料  
 
3 楼 
 文章标题 : Re: 使用最新的winehq,编译wineasio出现了问题。
帖子发表于 : 2017-04-26 22:12 

注册: 2017-04-26 21:39
帖子: 7
系统: Arch Linux
送出感谢: 3
接收感谢: 0 次
vickycq 写道:
eTee 写道:
我使用的是winehq问我需要最新版的wine,但又需要wineasio怎么办呢?

您可能需要安装对应的开发包,包名可能为 wine-staging-dev 或 wine-devel-dev,取决于您使用的是 wine-staging 还是 wine-devel

谢谢你的提醒。我添加了winehq的源,搜索的wine字样的包,只有
引用:
winehq-devel/xenial,now 2.6.0~xenial amd64 [已安装]
WINE Is Not An Emulator - runs MS Windows programs

winehq-stable/xenial 2.0.1~xenial amd64
WINE Is Not An Emulator - runs MS Windows programs

winehq-staging/xenial 2.6.0~xenial amd64
WINE Is Not An Emulator - runs MS Windows programs

并无dev字样的开发包。

请问您知道对应的开发包应该怎么安装呢?谢谢!


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 使用最新的winehq,编译wineasio出现了问题。
帖子发表于 : 2017-04-26 23:12 
头像

注册: 2011-03-20 13:12
帖子: 4552
地址: 山东省寿光县
系统: Debian
送出感谢: 106
接收感谢: 1009
不知道您添加的是哪个源。搜不到可能是因为未添加软件源的某个分区,我一时也没搞明白。您可以到 https://dl.winehq.org/wine-builds/ubuntu/pool/main/ 手动下载安装。在此页面中搜索 'devel-dev' 或 'staging-dev',取决于您使用的是 wine-staging 还是 wine-devel。 选择正确的架构/Ubuntu版本下载安装。这样应该会在 /opt 中安装相应的头文件
例如,若使用 wine-devel 分支,版本 2.6,Ubuntu 16.04(xenial),64位系统 可能需要下载 https://dl.winehq.org/wine-builds/ubuntu/pool/main/wine-devel-dev_2.6.0~xenial_amd64.deb


_________________
Debian 中文论坛 - forums.debiancn.org
欢迎所有 Debian GNU/Linux 用户



_________________
评价: 3.7% eTee
 
页首
 用户资料  
 
5 楼 
 文章标题 : Re: 使用最新的winehq,编译wineasio出现了问题。
帖子发表于 : 2017-04-26 23:56 

注册: 2017-04-26 21:39
帖子: 7
系统: Arch Linux
送出感谢: 3
接收感谢: 0 次
vickycq 写道:
不知道您添加的是哪个源。搜不到可能是因为未添加软件源的某个分区,我一时也没搞明白。您可以到 https://dl.winehq.org/wine-builds/ubuntu/pool/main/ 手动下载安装。在此页面中搜索 'devel-dev' 或 'staging-dev',取决于您使用的是 wine-staging 还是 wine-devel。 选择正确的架构/Ubuntu版本下载安装。这样应该会在 /opt 中安装相应的头文件
例如,若使用 wine-devel 分支,版本 2.6,Ubuntu 16.04(xenial),64位系统 可能需要下载 https://dl.winehq.org/wine-builds/ubuntu/pool/main/wine-devel-dev_2.6.0~xenial_amd64.deb

谢谢!我是安装官方说明添加的源,https://wiki.winehq.org/Ubuntu。看来源里没有添加dev包。我安装了dev包后在opt里找到了对应的文件。现在尝试编译。感谢!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译