[已解决]使用最新的winehq,编译wineasio出现了问题。

Wine、Cedega、CrossOver 等配置
回复
eTee
帖子: 7
注册时间: 2017-04-26 21:39
系统: Arch Linux
送出感谢: 3 次
接收感谢: 0

[已解决]使用最新的winehq,编译wineasio出现了问题。

#1

帖子 eTee » 2017-04-26 21:43

我在编译wineasio的时候出现了问题,提示找不到"/usr/include/wine/debug.h"。
我使用的是winehq,但/opt/wine-devel/ 里并没有debug.h的文件,也没有/usr/include/wine。而在apt安装的wine里,/usr/include/wine 有这个文件。
请问我需要最新版的wine,但又需要wineasio怎么办呢?

谢谢!
上次由 eTee 在 2017-04-27 0:15,总共编辑 1 次。
头像
vickycq
论坛版主
帖子: 4507
注册时间: 2011-03-20 13:12
系统: Debian
来自: 山东省寿光县
送出感谢: 100 次
接收感谢: 994 次
联系:

Re: 使用最新的winehq,编译wineasio出现了问题。

#2

帖子 vickycq » 2017-04-26 22:05

eTee 写了:我使用的是winehq问我需要最新版的wine,但又需要wineasio怎么办呢?
您可能需要安装对应的开发包,包名可能为 wine-staging-dev 或 wine-devel-dev,取决于您使用的是 wine-staging 还是 wine-devel
这些用户感谢了作者 vickycq 于这个帖子:
eTee (2017-04-26 22:11)
评价: 3.7%
Debian 中文论坛 - forums.debiancn.org
欢迎所有 Debian GNU/Linux 用户
eTee
帖子: 7
注册时间: 2017-04-26 21:39
系统: Arch Linux
送出感谢: 3 次
接收感谢: 0

Re: 使用最新的winehq,编译wineasio出现了问题。

#3

帖子 eTee » 2017-04-26 22:12

vickycq 写了:
eTee 写了:我使用的是winehq问我需要最新版的wine,但又需要wineasio怎么办呢?
您可能需要安装对应的开发包,包名可能为 wine-staging-dev 或 wine-devel-dev,取决于您使用的是 wine-staging 还是 wine-devel
谢谢你的提醒。我添加了winehq的源,搜索的wine字样的包,只有
winehq-devel/xenial,now 2.6.0~xenial amd64 [已安装]
WINE Is Not An Emulator - runs MS Windows programs

winehq-stable/xenial 2.0.1~xenial amd64
WINE Is Not An Emulator - runs MS Windows programs

winehq-staging/xenial 2.6.0~xenial amd64
WINE Is Not An Emulator - runs MS Windows programs
并无dev字样的开发包。

请问您知道对应的开发包应该怎么安装呢?谢谢!
头像
vickycq
论坛版主
帖子: 4507
注册时间: 2011-03-20 13:12
系统: Debian
来自: 山东省寿光县
送出感谢: 100 次
接收感谢: 994 次
联系:

Re: 使用最新的winehq,编译wineasio出现了问题。

#4

帖子 vickycq » 2017-04-26 23:12

不知道您添加的是哪个源。搜不到可能是因为未添加软件源的某个分区,我一时也没搞明白。您可以到 https://dl.winehq.org/wine-builds/ubuntu/pool/main/ 手动下载安装。在此页面中搜索 'devel-dev' 或 'staging-dev',取决于您使用的是 wine-staging 还是 wine-devel。 选择正确的架构/Ubuntu版本下载安装。这样应该会在 /opt 中安装相应的头文件
例如,若使用 wine-devel 分支,版本 2.6,Ubuntu 16.04(xenial),64位系统 可能需要下载 https://dl.winehq.org/wine-builds/ubunt ... _amd64.deb
这些用户感谢了作者 vickycq 于这个帖子:
eTee (2017-04-26 23:55)
评价: 3.7%
Debian 中文论坛 - forums.debiancn.org
欢迎所有 Debian GNU/Linux 用户
eTee
帖子: 7
注册时间: 2017-04-26 21:39
系统: Arch Linux
送出感谢: 3 次
接收感谢: 0

Re: 使用最新的winehq,编译wineasio出现了问题。

#5

帖子 eTee » 2017-04-26 23:56

vickycq 写了:不知道您添加的是哪个源。搜不到可能是因为未添加软件源的某个分区,我一时也没搞明白。您可以到 https://dl.winehq.org/wine-builds/ubuntu/pool/main/ 手动下载安装。在此页面中搜索 'devel-dev' 或 'staging-dev',取决于您使用的是 wine-staging 还是 wine-devel。 选择正确的架构/Ubuntu版本下载安装。这样应该会在 /opt 中安装相应的头文件
例如,若使用 wine-devel 分支,版本 2.6,Ubuntu 16.04(xenial),64位系统 可能需要下载 https://dl.winehq.org/wine-builds/ubunt ... _amd64.deb
谢谢!我是安装官方说明添加的源,https://wiki.winehq.org/Ubuntu。看来源里没有添加 ... 。现在尝试编译。感谢
回复

回到 “Wine及其分支”