[问题]wine玩暗黑2很卡,要怎么设置才行?

Wine、Cedega、CrossOver 等配置
回复
linyjfei
帖子: 127
注册时间: 2007-06-05 0:05
送出感谢: 0
接收感谢: 0

[问题]wine玩暗黑2很卡,要怎么设置才行?

#1

帖子 linyjfei » 2007-09-06 0:49

在游戏里用/fps,在act1时城里有26帧以上,出城打怪经常掉到10帧左右,在win下玩可以达到100帧以上(没用D3D),要怎么设置才能让游戏运行更快些?在winecfg里就设了声音选项其它都没动。
头像
windowssux
帖子: 618
注册时间: 2006-08-06 16:58
来自: 北海
送出感谢: 0
接收感谢: 1 次

#2

帖子 windowssux » 2007-09-06 23:41

REGEDIT4

[HKEY_CURRENT_USER\Software\Wine\Direct3D]
"DirectDrawRenderer"="opengl"
"OffscreenRenderingMode"="fbo"
"PixelShaderMode"="disabled"
"RenderTargetLockMode"="readtex"
"UseGLSL"="enabled"
"VideoMemorySize"="128"(这个根据你的显卡的显存调整)

[HKEY_CURRENT_USER\Software\Wine\X11 Driver]
"ClientSideAntiAliasWithCore"="N"
"ClientSideAntiAliasWithRender"="N"
"ClientSideWithRender"="N"
"DXGrab"="Y"
"ScreenDepth"="32"(wine程序的色深,也可以设置成16,取决你的显卡能力)
"UseXRandR"="N"
"UseXVidMode"="Y"

保存为注册表,不要中文的部分和括号,比如diablo.reg,然后regedit diablo.reg。

运行游戏的时候加上-opengl参数,比如wine diablo2.exe -opengl
回复

回到 “Wine及其分支”