当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 12 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : wine-0.9.45 源代码make install时出错 !
帖子发表于 : 2007-09-18 23:24 

注册: 2006-12-09 15:55
帖子: 46
送出感谢: 0 次
接收感谢: 0 次
/usr/bin/ld: skipping incompatible /usr/lib/libXext.so when searching for -lXext
/usr/bin/ld: skipping incompatible /usr/lib/libXext.a when searching for -lXext
/usr/bin/ld: cannot find -lXext
collect2: ld 返回 1
winegcc: gcc failed.
make[2]: *** [winex11.drv.so] 错误 2
make[2]: Leaving directory `/home/amina/wine-0.9.45/dlls/winex11.drv'
make[1]: *** [winex11.drv/__install-lib__] 错误 2
make[1]: Leaving directory `/home/amina/wine-0.9.45/dlls'
make: *** [dlls/__install-lib__] 错误 2

我用了sudo 了啊...
怎么回事 ?


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-09-19 12:41 
头像

注册: 2005-04-06 21:15
帖子: 2200
地址: 安徽黄山
送出感谢: 0 次
接收感谢: 0 次
cannot find -lXext
libxext-dev?


_________________
生命不息,灌水不止,我师父是白娘子.另热烈庆祝本人blog访问量突破2w大关.
被高手bs,向小白显摆.


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-09-20 22:35 

注册: 2006-12-09 15:55
帖子: 46
送出感谢: 0 次
接收感谢: 0 次
libxext-dev我已经装了..
libxext6
libxext-dbg 也装了

还是出这个错误


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-09-20 23:34 
头像

注册: 2005-04-06 21:15
帖子: 2200
地址: 安徽黄山
送出感谢: 0 次
接收感谢: 0 次
提示是/usr/lib/libXext.so有问题,版本不相容
貌似有些麻烦,可能系统里的旧了吧.


_________________
生命不息,灌水不止,我师父是白娘子.另热烈庆祝本人blog访问量突破2w大关.
被高手bs,向小白显摆.


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-09-21 21:47 

注册: 2006-12-09 15:55
帖子: 46
送出感谢: 0 次
接收感谢: 0 次
... 那我全删了再装可以么 ?


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-09-21 22:09 

注册: 2007-09-18 8:45
帖子: 734
送出感谢: 1
接收感谢: 1
不能覆盖的,只能卸掉以前的来装


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-09-21 22:56 

注册: 2006-12-09 15:55
帖子: 46
送出感谢: 0 次
接收感谢: 0 次
一删除 删除很到堆东西啊..
能 备份一下那些文件么 ..?

到时候要装也容易点..


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-09-21 23:29 

注册: 2006-12-09 15:55
帖子: 46
送出感谢: 0 次
接收感谢: 0 次
compiz-dev
libxi-dev
libxinerama-dev
libmu-dev
libxrandr-dev
libxtst-dev
libxv-dev
xlibs-dev

这些都要删掉哇... compiz-dev 我好辛苦才装上的...


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-09-21 23:29 

注册: 2006-12-09 15:55
帖子: 46
送出感谢: 0 次
接收感谢: 0 次
.. 能保存 备份下再删除么 ??


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-09-22 8:23 
头像

注册: 2006-10-21 12:03
帖子: 1746
地址: Shanghai
送出感谢: 0 次
接收感谢: 0 次
不懂为何要删除 Xext~
/usr/bin/ld: skipping incompatible /usr/lib/libXext.so when searching for -lXext
版本不兼容 :(
看看能不能在 configure 的时候关闭 libXext 的支持 :roll:

最后提示一句,最简单的办法就是直接去下 deb 包安装~ winehq.org 就有~


_________________
.

私人空间
附有 Magic Linux 2.1 最新开发日志~
引用:


미안하다, 사랑한다




欢迎来 #xfce-cn 中文频道~~


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-09-22 9:45 
头像

注册: 2005-04-06 21:15
帖子: 2200
地址: 安徽黄山
送出感谢: 0 次
接收感谢: 0 次
下deb-src,剽窃别人的rules


_________________
生命不息,灌水不止,我师父是白娘子.另热烈庆祝本人blog访问量突破2w大关.
被高手bs,向小白显摆.


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-09-22 9:52 

注册: 2006-12-09 15:55
帖子: 46
送出感谢: 0 次
接收感谢: 0 次
厄 ~
在下载了 ...

看看装完以后能搞好我的字体问题不...


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 12 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:thmxb 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译