当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 18 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : ubuntu server 7.10+wine+冰封王座
帖子发表于 : 2007-12-24 20:39 

注册: 2007-12-24 20:25
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
我装了ubuntu server然后,安装了X服务器,并没有安装桌面环境,然后成功安装好了ATI显卡,经过齿轮测试OPENGL运行正常。;
接着就安装了scim 输入平台及相关中文支持,
下一步安装wine,我是用apt-get 进行安装的。装好了之后,
经过测试,千千静听已经可以用了,QQ可以登录上,但刚登录上就掉线,窗口都是乱码,所以不知道具体是什么原因。
更要命的是我一直想模拟的冰封王座,这次仍然出问题:刚启动进入全屏就退出来了,弹出一个乱码窗口,不知道是什么原因。
其中一个比较显目的出错信息是:
err:ole:CoCreateInstance apartment not initialised
似乎和WINDOS中“COM”未初始化有关系
请高手们帮帮忙,这可能是什么问题引起的?提供点思路!
很想在ubuntu server下玩玩魔兽呀!都试了几天了还是不行。

就两个问题:
1。乱码怎么解决,我的X环境下(不是桌面环境)正常的,WINE启动的程序怎么都乱码(除了它自己的配置程序winecgf)
2.这魔兽问题出在哪里?


最后由 felixlzq 编辑于 2007-12-24 20:57,总共编辑了 2 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-12-24 20:39 

注册: 2007-12-24 20:25
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
我在线等大家啦!


页首
 用户资料  
 
3 楼 
 文章标题 : 补充:我是按这里安装wine和模拟魔兽的:http://www.linuxidc.com/Linux/2007-11/9
帖子发表于 : 2007-12-24 20:44 

注册: 2007-12-24 20:25
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
补充:我是按这里配置wine:http://www.linuxidc.com/Linux/2007-11/9


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-12-24 22:55 

注册: 2007-12-24 20:25
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
怎么没有反应啊。
刚才下了最新的版的WINE。0。9。51
结果有这个错误,以前也遇到过,可是我显卡驱动明明已经装好了。怎么回事?
configure: WARNING: No OpenGL development headers were found


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-12-25 11:00 

注册: 2007-12-25 10:59
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
刚找到,是这里吧http://www.linuxidc.com/Linux/2007-11/9311.htm
正在学!不过不太会


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-12-25 11:08 
头像

注册: 2007-04-09 15:19
帖子: 353
送出感谢: 0 次
接收感谢: 0 次
http://www.ubfchina.cn/down/view.asp?id=18
先下一个wine的设置包安装好看看还有乱码吗
我的魔兽争霸是没有乱码出现


页首
 用户资料  
 
7 楼 
 文章标题 : 可能会是版本问题吗?我看了一下这里,有许多人的测试,楼上用什么版本的。我的是 warca
帖子发表于 : 2007-12-25 16:15 

注册: 2007-12-24 20:25
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
http://appdb.winehq.org/commentview.php ... adId=15262
可能会是版本问题吗?我看了一下这里,有许多人的测试,楼上用什么版本的。我的是 warcaft 1.21 wine 0.9.50/0.9.51


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-12-25 16:20 
头像

注册: 2007-04-09 15:19
帖子: 353
送出感谢: 0 次
接收感谢: 0 次
WAR3:1.21
Wine:0.9.50
不过我的ubuntu版本和你的不一样
我的是ubuntu7.04桌面版本的
我第一个wine的游戏就是WAR3
当时连那个中文设置包都没装
直接进去到WAR3目录wine就成功了
那时是没发现有乱码
只是输入不了中文和同学交流


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-12-25 16:22 
头像

注册: 2007-03-28 12:39
帖子: 505
送出感谢: 0 次
接收感谢: 0 次
是不是LZ的 war3根目录是原先 windows文件格式化的分区下面呀?(NTFS or FAT)如果是的话,请把war3 copy到linux文件格式的分区下面再试。而且要检查你的显卡驱动是否安装正确了。


_________________
目前研究自编译内核,有兴趣的朋友一起来吧~


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-12-25 16:33 

注册: 2007-12-24 20:25
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
我都试了呀。
war3我已经考到 ~/.wine/drive_c/Program*/下了
不应该是少装了什么东西吧?
对wine configure的时候,提示缺少x development和字体 于是我尝试
apt-get install fglrx-driver-dev
可发现这是一个virtual package,于是尝试
apt-get install xorg-driver-fglrx-dev
但还是不行,
于是用 apt-get -b source wine找到了所依赖的包,我猜想着这样安装:
apt-get install fontforge
apt-get install *-mesa-*
第二个我忘了名字了,是mesa的
然后配置编译安装wine没出现什么警告和错误


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-12-25 16:40 

注册: 2007-12-24 20:25
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
xhylyx 写道:
WAR3:1.21
Wine:0.9.50
不过我的ubuntu版本和你的不一样
我的是ubuntu7.04桌面版本的
我第一个wine的游戏就是WAR3
当时连那个中文设置包都没装
直接进去到WAR3目录wine就成功了
那时是没发现有乱码
只是输入不了中文和同学交流

你配置安装过程是怎么样的?


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-12-25 18:51 
头像

注册: 2007-04-09 15:19
帖子: 353
送出感谢: 0 次
接收感谢: 0 次
我在怀疑是不是你的系统版本有问题啊
我一开始就先下好wine啊
还是直接从CN99直接下的
都没自己编译到wine
就一个命令:sudo apt-get install wine
然后下好了就按照论坛上的一个介绍wine的配置帖子配置好
然后就去到我的windows下的C盘那把WAR3复制了一份到我的用户目录下
接着就进到目录底下执行:wine bingfeng.exe(这个我改过名了的)
然后就能顺利进入了游戏
第一次进去那会提示一个声音初始化失败了
可是并不影响到游戏的运行啊
我还特意叫我同学建了一个游戏看看我能不能进了
声音的问题后来在wine的配置标签里改了下就好了
好像记得是把OSS改为什么ALSA就好了
我的过程就是这样了
之后才在论坛上看到wine的配置包然后就下下来安装了
不过我的CS1.5还是有些乱码
但也没影响到游戏的运行
我也懒得弄了


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2007-12-25 18:55 
头像

注册: 2007-12-19 21:42
帖子: 1163
送出感谢: 0 次
接收感谢: 0 次
Cedega 6安装简单,设置方便,游戏兼容性好!为什么不用?我就用Cedega玩War3!很流畅,还不乱码!


_________________
北極熊都是左撇子…………


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2007-12-25 19:02 
头像

注册: 2007-04-09 15:19
帖子: 353
送出感谢: 0 次
接收感谢: 0 次
我用wine玩WAR3也很流畅的啊也没乱码
设置也不麻烦也挺简单的
对了,LZ你看下这个看看
我就是按照这个配置wine的
1.http://forum.ubuntu.org.cn/viewtopic.php?t=72933
2.http://forum.ubuntu.org.cn/viewtopic.php?t=76591


页首
 用户资料  
 
15 楼 
 文章标题 : 安装
帖子发表于 : 2007-12-25 19:25 

注册: 2007-12-24 20:25
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
xhylyx 写道:
我用wine玩WAR3也很流畅的啊也没乱码
设置也不麻烦也挺简单的
对了,LZ你看下这个看看
我就是按照这个配置wine的
1.http://forum.ubuntu.org.cn/viewtopic.php?t=72933
2.http://forum.ubuntu.org.cn/viewtopic.php?t=76591

好的。我则才重编译一下,居然连winecfg都打不开了,奇怪。
再试一下,我看行不行。
不过刚开始我用apt-get install wine安装的版本比较低啊,好像是0.9.46的,你用的源是哪里的?
而且那样装的话,会有很多deb包都没装。
有点事要出去一下,回来再请教你


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 18 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译