fastboot 安装不上了

其它类软件,非上述版软件
回复
wqk317226700
帖子: 8
注册时间: 2015-09-15 19:37
系统: windows 10,linux
送出感谢: 1 次
接收感谢: 1 次

fastboot 安装不上了

#1

帖子 wqk317226700 » 2018-10-16 17:37

之前还好好的, 突然就不行了

代码: 全选

# apt install fastboot
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
 fastboot : 依赖: android-libadb (= 1:7.0.0+r33-2) 但是 1:8.1.0+r23-1~stage1.2ubuntu1 正要被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。
poloshiao
论坛版主
帖子: 18274
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1948 次

Re: fastboot 安装不上了

#2

帖子 poloshiao » 2018-10-16 17:49

1. 養成習慣 安裝/更新 任何套件前 先
sudo apt update
sudo apt upgrade

2. 先安裝 android-libadb
sudo apt install android-libadb
再安裝 fastboot
sudo apt install fastboot

3. 如果還有錯誤訊息 全部複製貼上來
wqk317226700
帖子: 8
注册时间: 2015-09-15 19:37
系统: windows 10,linux
送出感谢: 1 次
接收感谢: 1 次

Re: fastboot 安装不上了

#3

帖子 wqk317226700 » 2018-10-16 18:17

poloshiao 写了:
2018-10-16 17:49
1. 養成習慣 安裝/更新 任何套件前 先
sudo apt update
sudo apt upgrade

2. 先安裝 android-libadb
sudo apt install android-libadb
再安裝 fastboot
sudo apt install fastboot

3. 如果還有錯誤訊息 全部複製貼上來
感谢提醒与指教, 但是还是不行,

代码: 全选

# apt update
忽略:1 http://dl.google.com/linux/chrome/deb stable InRelease
命中:2 http://dl.google.com/linux/chrome/deb stable Release
命中:4 http://mirrors.yun-idc.com/ubuntu cosmic InRelease           
命中:5 http://mirrors.yun-idc.com/ubuntu cosmic-updates InRelease     
命中:6 http://mirrors.yun-idc.com/ubuntu cosmic-backports InRelease   
命中:7 http://mirrors.yun-idc.com/ubuntu cosmic-security InRelease
命中:8 http://mirrors.yun-idc.com/ubuntu cosmic-proposed InRelease
命中:9 http://archive.ubuntukylin.com:10006/ubuntukylin xenial InRelease
正在读取软件包列表... 完成                       
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
所有软件包均为最新。
# apt upgrade
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
正在计算更新... 完成
升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件包未被升级。
# apt install android-libadb
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
android-libadb 已经是最新版 (1:8.1.0+r23-1~stage1.2ubuntu1)。
android-libadb 已设置为手动安装。
升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件包未被升级。
# apt install fastboot
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
 fastboot : 依赖: android-libadb (= 1:7.0.0+r33-2) 但是 1:8.1.0+r23-1~stage1.2ubuntu1 正要被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

poloshiao
论坛版主
帖子: 18274
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1948 次

Re: fastboot 安装不上了

#4

帖子 poloshiao » 2018-10-16 18:22

把下面指令 複製 貼進終端機 執行
1. whoami
2. pwd
把指令及結果直接 選取/複製 貼上來
wqk317226700
帖子: 8
注册时间: 2015-09-15 19:37
系统: windows 10,linux
送出感谢: 1 次
接收感谢: 1 次

Re: fastboot 安装不上了

#5

帖子 wqk317226700 » 2018-10-16 18:26

root@mibook:/home/wang# whoami
root
root@mibook:/home/wang# pwd
/home/wang
poloshiao
论坛版主
帖子: 18274
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1948 次

Re: fastboot 安装不上了

#6

帖子 poloshiao » 2018-10-16 20:08

root@mibook:/home/wang# whoami
root
root@mibook:/home/wang# pwd
/home/wang
1. 登出
1-1. 使用 安裝時 創建的使用者登入
1-2. 需要 root 權限時 加 sudo
下列软件包有未满足的依赖关系:
fastboot : 依赖: android-libadb (= 1:7.0.0+r33-2) 但是 1:8.1.0+r23-1~stage1.2ubuntu1 正要被安装
2. https://packages.ubuntu.com/search?suit ... chon=names
套件 fastboot
2-1. bionic (18.04LTS) (devel): Android fastboot tool [universe]
1:7.0.0+r33-2: amd64 arm64 armhf i386
2-2. cosmic (devel): Android fastboot tool [universe]
1:8.1.0+r23-1~stage1.2ubuntu2: amd64 arm64 armhf i386
2-3. 你是否在你的系統混雜了 18.04 與 18.10 ?
2-4. 不確定 ?
把下面指令 複製 貼進終端機 執行
2-4-1. sudo cat /etc/apt/sources.list
2-4-2. sudo cat /etc/apt/sources.list.d/*
把指令及回應結果全部直接 選取/複製/貼上來
wqk317226700
帖子: 8
注册时间: 2015-09-15 19:37
系统: windows 10,linux
送出感谢: 1 次
接收感谢: 1 次

Re: fastboot 安装不上了

#7

帖子 wqk317226700 » 2018-10-17 8:24

有可能是1804与1810混了, 因为我是从1804升级上来的, 除了切换过下载源以外, 没动过sources.list了

代码: 全选

~$ sudo cat /etc/apt/sources.list
[sudo] wang 的密码: 
# deb cdrom:[Ubuntu 16.04.4 LTS _Xenial Xerus_ - Release amd64 (20180228)]/ xenial main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://mirrors.yun-idc.com/ubuntu/ cosmic main restricted
deb-src http://mirrors.yun-idc.com/ubuntu/ cosmic multiverse main universe restricted #Added by software-properties
# deb-src http://cn.archive.ubuntu.com/ubuntu/ xenial main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://mirrors.yun-idc.com/ubuntu/ cosmic-updates main restricted
deb-src http://mirrors.yun-idc.com/ubuntu/ cosmic-updates multiverse main universe restricted #Added by software-properties
# deb-src http://cn.archive.ubuntu.com/ubuntu/ xenial-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://mirrors.yun-idc.com/ubuntu/ cosmic universe
# deb-src http://cn.archive.ubuntu.com/ubuntu/ xenial universe
deb http://mirrors.yun-idc.com/ubuntu/ cosmic-updates universe
# deb-src http://cn.archive.ubuntu.com/ubuntu/ xenial-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://mirrors.yun-idc.com/ubuntu/ cosmic multiverse
# deb-src http://cn.archive.ubuntu.com/ubuntu/ xenial multiverse
deb http://mirrors.yun-idc.com/ubuntu/ cosmic-updates multiverse
# deb-src http://cn.archive.ubuntu.com/ubuntu/ xenial-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://mirrors.yun-idc.com/ubuntu/ cosmic-backports main restricted universe multiverse
deb-src http://mirrors.yun-idc.com/ubuntu/ cosmic-backports main restricted universe multiverse #Added by software-properties
# deb-src http://cn.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu xenial partner
# deb-src http://archive.canonical.com/ubuntu xenial partner

deb http://mirrors.yun-idc.com/ubuntu/ cosmic-security main restricted
deb-src http://mirrors.yun-idc.com/ubuntu/ cosmic-security multiverse main universe restricted #Added by software-properties
# deb-src http://security.ubuntu.com/ubuntu xenial-security main restricted
deb http://mirrors.yun-idc.com/ubuntu/ cosmic-security universe
# deb-src http://security.ubuntu.com/ubuntu xenial-security universe
deb http://mirrors.yun-idc.com/ubuntu/ cosmic-security multiverse
# deb-src http://security.ubuntu.com/ubuntu xenial-security multiverse
deb http://mirrors.yun-idc.com/ubuntu/ cosmic-proposed main universe multiverse restricted
deb-src http://mirrors.yun-idc.com/ubuntu/ cosmic-proposed main universe multiverse restricted #Added by software-properties
wang@mibook:~$ sudo cat /etc/apt/sources.list.d/*
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
deb http://archive.ubuntukylin.com:10006/ubuntukylin xenial main
deb http://archive.ubuntukylin.com:10006/ubuntukylin xenial main
poloshiao
论坛版主
帖子: 18274
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1948 次

Re: fastboot 安装不上了

#8

帖子 poloshiao » 2018-10-17 9:15

有可能是1804与1810混了, 因为我是从1804升级上来的
1. /etc/apt/sources.list 或 /etc/apt/sources.list.d/*.list 中 含有 xenial 的那些行
最前面加 # (加了 # 以後 只是留著備忘 實際上無作用)
1-1. 例如
deb http://archive.ubuntukylin.com:10006/ubuntukylin xenial main
deb http://archive.ubuntukylin.com:10006/ubuntukylin xenial main
1-2. 上面兩行 完全重複 刪去一行
1-3. 然後
1-3-1. sudo apt update
1-3-2. sudo apt upgrade
1-3-3. sudo apt full-upgrade
1-3-4. sudo apt autoremove
1-3-5. 參見
http://manpages.ubuntu.com/manpages/cos ... apt.8.html
apt - command-line interface

5. 如果還有錯誤訊息 複製貼上來
这些用户感谢了作者 poloshiao 于这个帖子:
wqk317226700 (2018-10-17 9:39)
评价: 3.7%
wqk317226700
帖子: 8
注册时间: 2015-09-15 19:37
系统: windows 10,linux
送出感谢: 1 次
接收感谢: 1 次

Re: fastboot 安装不上了

#9

帖子 wqk317226700 » 2018-10-17 9:39

好了, 现在问题解决了, fastboot命令识别了, 但是在检测的时候发现android-libadb这个包升级了, 所以我还是不清楚出现这个情况的主要原因是什么

无论如何, 非常感谢你的耐心指导与解答, 谢谢! :Haha

代码: 全选

wang@mibook:~$ sudo apt update
忽略:1 http://dl.google.com/linux/chrome/deb stable InRelease
命中:2 http://dl.google.com/linux/chrome/deb stable Release
获取:3 http://archive.ubuntukylin.com:10006/ubuntukylin xenial InRelease [18.1 kB]                                      
命中:5 http://mirrors.yun-idc.com/ubuntu cosmic InRelease                                                               
命中:6 http://mirrors.yun-idc.com/ubuntu cosmic-updates InRelease
命中:7 http://mirrors.yun-idc.com/ubuntu cosmic-backports InRelease
命中:8 http://mirrors.yun-idc.com/ubuntu cosmic-security InRelease
命中:9 http://mirrors.yun-idc.com/ubuntu cosmic-proposed InRelease
已下载 18.1 kB,耗时 1秒 (23.3 kB/s)
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
有 22 个软件包可以升级。请执行 ‘apt list --upgradable’ 来查看它们。
wang@mibook:~$ sudo apt upgrade
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
正在计算更新... 完成
下列软件包是自动安装的并且现在不需要了:
  python-cairo
使用'sudo apt autoremove'来卸载它(它们)。
下列软件包将被升级:
  adb android-libadb android-libbase android-libboringssl android-libcrypto-utils android-libcutils android-liblog
  base-files gnome-software gnome-software-common gnome-software-plugin-snap google-chrome-stable initramfs-tools
  initramfs-tools-bin initramfs-tools-core python-gi python3-gi python3-gi-cairo snapd ubuntu-core-launcher ubuntu-software
  xserver-xorg-input-libinput
升级了 22 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件包未被升级。
需要下载 73.2 MB 的归档。
解压缩后会消耗 3,260 kB 的额外空间。
您希望继续执行吗? [Y/n] y
获取:1 http://mirrors.yun-idc.com/ubuntu cosmic/main amd64 base-files amd64 10.1ubuntu7 [60.2 kB]
获取:2 http://mirrors.yun-idc.com/ubuntu cosmic/universe amd64 ubuntu-core-launcher amd64 2.35.5+18.10 [1,640 B]
获取:3 http://mirrors.yun-idc.com/ubuntu cosmic/main amd64 snapd amd64 2.35.5+18.10 [12.7 MB]
获取:4 http://dl.google.com/linux/chrome/deb stable/main amd64 google-chrome-stable amd64 70.0.3538.67-1 [56.1 MB]
获取:5 http://mirrors.yun-idc.com/ubuntu cosmic/main amd64 initramfs-tools all 0.131ubuntu15 [9,692 B]                       
获取:6 http://mirrors.yun-idc.com/ubuntu cosmic/main amd64 initramfs-tools-core all 0.131ubuntu15 [45.5 kB]                  
获取:7 http://mirrors.yun-idc.com/ubuntu cosmic/main amd64 initramfs-tools-bin amd64 0.131ubuntu15 [10.0 kB]                 
获取:8 http://mirrors.yun-idc.com/ubuntu cosmic/main amd64 python3-gi-cairo amd64 3.30.1-1ubuntu1 [7,348 B]                  
获取:9 http://mirrors.yun-idc.com/ubuntu cosmic/main amd64 python3-gi amd64 3.30.1-1ubuntu1 [163 kB]                         
获取:10 http://mirrors.yun-idc.com/ubuntu cosmic/universe amd64 android-libcutils amd64 1:8.1.0+r23-1~stage1.2ubuntu2 [22.4 kB]
获取:11 http://mirrors.yun-idc.com/ubuntu cosmic/universe amd64 adb amd64 1:8.1.0+r23-1~stage1.2ubuntu2 [87.4 kB]            
获取:12 http://mirrors.yun-idc.com/ubuntu cosmic/universe amd64 android-libadb amd64 1:8.1.0+r23-1~stage1.2ubuntu2 [121 kB]  
获取:13 http://mirrors.yun-idc.com/ubuntu cosmic/universe amd64 android-libbase amd64 1:8.1.0+r23-1~stage1.2ubuntu2 [21.9 kB]
获取:14 http://mirrors.yun-idc.com/ubuntu cosmic/universe amd64 android-liblog amd64 1:8.1.0+r23-1~stage1.2ubuntu2 [41.5 kB] 
获取:15 http://mirrors.yun-idc.com/ubuntu cosmic/universe amd64 android-libboringssl amd64 8.1.0+r23-2 [535 kB]              
获取:16 http://mirrors.yun-idc.com/ubuntu cosmic/universe amd64 android-libcrypto-utils amd64 1:8.1.0+r23-1~stage1.2ubuntu2 [8,140 B]
获取:17 http://mirrors.yun-idc.com/ubuntu cosmic/main amd64 gnome-software-plugin-snap amd64 3.30.2-0ubuntu4 [28.7 kB]       
获取:18 http://mirrors.yun-idc.com/ubuntu cosmic/main amd64 gnome-software amd64 3.30.2-0ubuntu4 [499 kB]                    
获取:19 http://mirrors.yun-idc.com/ubuntu cosmic/main amd64 gnome-software-common all 3.30.2-0ubuntu4 [2,481 kB]             
获取:20 http://mirrors.yun-idc.com/ubuntu cosmic/main amd64 python-gi amd64 3.30.1-1ubuntu1 [210 kB]                                             
获取:21 http://mirrors.yun-idc.com/ubuntu cosmic/main amd64 ubuntu-software all 3.30.2-0ubuntu4 [25.3 kB]                                        
获取:22 http://mirrors.yun-idc.com/ubuntu cosmic/main amd64 xserver-xorg-input-libinput amd64 0.28.1-1 [33.2 kB]                                 
已下载 73.2 MB,耗时 29秒 (2,533 kB/s)                                                                                                           
(正在读取数据库 ... 系统当前共安装有 203786 个文件和目录。)
正准备解包 .../base-files_10.1ubuntu7_amd64.deb  ...
Warning: Stopping motd-news.service, but it can still be activated by:
  motd-news.timer
正在将 base-files (10.1ubuntu7) 解包到 (10.1ubuntu6) 上 ...
正在设置 base-files (10.1ubuntu7) ...
正在安装新版本配置文件 /etc/issue ...
正在安装新版本配置文件 /etc/issue.net ...
正在安装新版本配置文件 /etc/lsb-release ...
motd-news.service is a disabled or a static unit, not starting it.
(正在读取数据库 ... 系统当前共安装有 203786 个文件和目录。)
正准备解包 .../00-google-chrome-stable_70.0.3538.67-1_amd64.deb  ...
正在将 google-chrome-stable (70.0.3538.67-1) 解包到 (69.0.3497.100-1) 上 ...
正准备解包 .../01-ubuntu-core-launcher_2.35.5+18.10_amd64.deb  ...
正在将 ubuntu-core-launcher (2.35.5+18.10) 解包到 (2.35.4+18.10) 上 ...
正准备解包 .../02-snapd_2.35.5+18.10_amd64.deb  ...
正在将 snapd (2.35.5+18.10) 解包到 (2.35.4+18.10) 上 ...
正准备解包 .../03-initramfs-tools_0.131ubuntu15_all.deb  ...
正在将 initramfs-tools (0.131ubuntu15) 解包到 (0.131ubuntu14) 上 ...
正准备解包 .../04-initramfs-tools-core_0.131ubuntu15_all.deb  ...
正在将 initramfs-tools-core (0.131ubuntu15) 解包到 (0.131ubuntu14) 上 ...
正准备解包 .../05-initramfs-tools-bin_0.131ubuntu15_amd64.deb  ...
正在将 initramfs-tools-bin (0.131ubuntu15) 解包到 (0.131ubuntu14) 上 ...
正准备解包 .../06-python3-gi-cairo_3.30.1-1ubuntu1_amd64.deb  ...
正在将 python3-gi-cairo (3.30.1-1ubuntu1) 解包到 (3.30.1-1) 上 ...
正准备解包 .../07-python3-gi_3.30.1-1ubuntu1_amd64.deb  ...
正在将 python3-gi (3.30.1-1ubuntu1) 解包到 (3.30.1-1) 上 ...
正准备解包 .../08-android-libcutils_1%3a8.1.0+r23-1~stage1.2ubuntu2_amd64.deb  ...
正在将 android-libcutils (1:8.1.0+r23-1~stage1.2ubuntu2) 解包到 (1:8.1.0+r23-1~stage1.2ubuntu1) 上 ...
正准备解包 .../09-adb_1%3a8.1.0+r23-1~stage1.2ubuntu2_amd64.deb  ...
正在将 adb (1:8.1.0+r23-1~stage1.2ubuntu2) 解包到 (1:8.1.0+r23-1~stage1.2ubuntu1) 上 ...
正准备解包 .../10-android-libadb_1%3a8.1.0+r23-1~stage1.2ubuntu2_amd64.deb  ...
正在将 android-libadb (1:8.1.0+r23-1~stage1.2ubuntu2) 解包到 (1:8.1.0+r23-1~stage1.2ubuntu1) 上 ...
正准备解包 .../11-android-libbase_1%3a8.1.0+r23-1~stage1.2ubuntu2_amd64.deb  ...
正在将 android-libbase (1:8.1.0+r23-1~stage1.2ubuntu2) 解包到 (1:8.1.0+r23-1~stage1.2ubuntu1) 上 ...
正准备解包 .../12-android-liblog_1%3a8.1.0+r23-1~stage1.2ubuntu2_amd64.deb  ...
正在将 android-liblog (1:8.1.0+r23-1~stage1.2ubuntu2) 解包到 (1:8.1.0+r23-1~stage1.2ubuntu1) 上 ...
正准备解包 .../13-android-libboringssl_8.1.0+r23-2_amd64.deb  ...
正在将 android-libboringssl (8.1.0+r23-2) 解包到 (8.1.0+r23-1) 上 ...
正准备解包 .../14-android-libcrypto-utils_1%3a8.1.0+r23-1~stage1.2ubuntu2_amd64.deb  ...
正在将 android-libcrypto-utils (1:8.1.0+r23-1~stage1.2ubuntu2) 解包到 (1:8.1.0+r23-1~stage1.2ubuntu1) 上 ...
正准备解包 .../15-gnome-software-plugin-snap_3.30.2-0ubuntu4_amd64.deb  ...
正在将 gnome-software-plugin-snap (3.30.2-0ubuntu4) 解包到 (3.30.2-0ubuntu3) 上 ...
正准备解包 .../16-gnome-software_3.30.2-0ubuntu4_amd64.deb  ...
正在将 gnome-software (3.30.2-0ubuntu4) 解包到 (3.30.2-0ubuntu3) 上 ...
正准备解包 .../17-gnome-software-common_3.30.2-0ubuntu4_all.deb  ...
正在将 gnome-software-common (3.30.2-0ubuntu4) 解包到 (3.30.2-0ubuntu3) 上 ...
正准备解包 .../18-python-gi_3.30.1-1ubuntu1_amd64.deb  ...
正在将 python-gi (3.30.1-1ubuntu1) 解包到 (3.30.1-1) 上 ...
正准备解包 .../19-ubuntu-software_3.30.2-0ubuntu4_all.deb  ...
正在将 ubuntu-software (3.30.2-0ubuntu4) 解包到 (3.30.2-0ubuntu3) 上 ...
正准备解包 .../20-xserver-xorg-input-libinput_0.28.1-1_amd64.deb  ...
正在将 xserver-xorg-input-libinput (0.28.1-1) 解包到 (0.28.0-1) 上 ...
正在设置 gnome-software-common (3.30.2-0ubuntu4) ...
正在处理用于 mime-support (3.60ubuntu1) 的触发器 ...
正在处理用于 desktop-file-utils (0.23-3ubuntu2) 的触发器 ...
正在处理用于 install-info (6.5.0.dfsg.1-4) 的触发器 ...
正在处理用于 plymouth-theme-ubuntu-text (0.9.3-1ubuntu10) 的触发器 ...
update-initramfs: deferring update (trigger activated)
正在处理用于 cracklib-runtime (2.9.2-5.2build1) 的触发器 ...
正在处理用于 libglib2.0-0:amd64 (2.58.1-2) 的触发器 ...
No such key “Gtk/IMModule” in schema “org.gnome.settings-daemon.plugins.xsettings” as specified in override file “/usr/share/glib-2.0/schemas/50_sogoupinyin.gschema.override”;忽略对此键的覆盖。
正在设置 xserver-xorg-input-libinput (0.28.1-1) ...
正在设置 android-liblog (1:8.1.0+r23-1~stage1.2ubuntu2) ...
正在设置 python3-gi (3.30.1-1ubuntu1) ...
正在处理用于 bamfdaemon (0.5.3+18.04.20180207.2-0ubuntu1) 的触发器 ...
Rebuilding /usr/share/applications/bamf-2.index...
正在设置 snapd (2.35.5+18.10) ...
snapd.failure.service is a disabled or a static unit, not starting it.
snapd.snap-repair.service is a disabled or a static unit, not starting it.
正在设置 python-gi (3.30.1-1ubuntu1) ...
正在处理用于 libc-bin (2.28-0ubuntu1) 的触发器 ...
正在设置 android-libboringssl (8.1.0+r23-2) ...
正在设置 gnome-software (3.30.2-0ubuntu4) ...
正在处理用于 man-db (2.8.4-2) 的触发器 ...
正在设置 ubuntu-core-launcher (2.35.5+18.10) ...
正在处理用于 gnome-menus (3.13.3-11ubuntu2) 的触发器 ...
正在设置 initramfs-tools-bin (0.131ubuntu15) ...
正在设置 google-chrome-stable (70.0.3538.67-1) ...
正在处理用于 hicolor-icon-theme (0.17-2) 的触发器 ...
正在设置 ubuntu-software (3.30.2-0ubuntu4) ...
正在设置 android-libcrypto-utils (1:8.1.0+r23-1~stage1.2ubuntu2) ...
正在设置 android-libbase (1:8.1.0+r23-1~stage1.2ubuntu2) ...
正在设置 initramfs-tools-core (0.131ubuntu15) ...
正在设置 gnome-software-plugin-snap (3.30.2-0ubuntu4) ...
正在设置 android-libcutils (1:8.1.0+r23-1~stage1.2ubuntu2) ...
正在设置 initramfs-tools (0.131ubuntu15) ...
update-initramfs: deferring update (trigger activated)
正在设置 python3-gi-cairo (3.30.1-1ubuntu1) ...
正在设置 android-libadb (1:8.1.0+r23-1~stage1.2ubuntu2) ...
正在设置 adb (1:8.1.0+r23-1~stage1.2ubuntu2) ...
正在处理用于 libc-bin (2.28-0ubuntu1) 的触发器 ...
正在处理用于 initramfs-tools (0.131ubuntu15) 的触发器 ...
update-initramfs: Generating /boot/initrd.img-4.18.0-10-generic
wang@mibook:~$ sudo apt full-upgrade
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
正在计算更新... 完成
下列软件包是自动安装的并且现在不需要了:
  python-cairo
使用'sudo apt autoremove'来卸载它(它们)。
升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件包未被升级。
wang@mibook:~$ sudo apt autoremove
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
下列软件包将被【卸载】:
  python-cairo
升级了 0 个软件包,新安装了 0 个软件包,要卸载 1 个软件包,有 0 个软件包未被升级。
解压缩后将会空出 257 kB 的空间。
您希望继续执行吗? [Y/n] y
(正在读取数据库 ... 系统当前共安装有 203785 个文件和目录。)
正在卸载 python-cairo:amd64 (1.16.2-1build1) ...
wang@mibook:~$ sudo apt install fastboot
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
将会同时安装下列软件:
  android-libbacktrace android-libf2fs-utils android-libsparse android-libunwind android-libutils android-libziparchive libf2fs-format4 libf2fs5
下列【新】软件包将被安装:
  android-libbacktrace android-libf2fs-utils android-libsparse android-libunwind android-libutils android-libziparchive fastboot libf2fs-format4
  libf2fs5
升级了 0 个软件包,新安装了 9 个软件包,要卸载 0 个软件包,有 0 个软件包未被升级。
需要下载 224 kB/275 kB 的归档。
解压缩后会消耗 948 kB 的额外空间。
您希望继续执行吗? [Y/n] y
获取:1 http://mirrors.yun-idc.com/ubuntu cosmic/universe amd64 android-libbacktrace amd64 1:8.1.0+r23-1~stage1.2ubuntu2 [43.7 kB]
获取:2 http://mirrors.yun-idc.com/ubuntu cosmic/universe amd64 libf2fs5 amd64 1.11.0-1 [13.7 kB]
获取:3 http://mirrors.yun-idc.com/ubuntu cosmic/universe amd64 libf2fs-format4 amd64 1.11.0-1 [16.6 kB]
获取:4 http://mirrors.yun-idc.com/ubuntu cosmic/universe amd64 android-libsparse amd64 1:8.1.0+r23-1~stage1.2ubuntu2 [15.9 kB]
获取:5 http://mirrors.yun-idc.com/ubuntu cosmic/universe amd64 android-libf2fs-utils amd64 8.1.0+r23-1 [10.9 kB]
获取:6 http://mirrors.yun-idc.com/ubuntu cosmic/universe amd64 android-libutils amd64 1:8.1.0+r23-1~stage1.2ubuntu2 [47.9 kB]
获取:7 http://mirrors.yun-idc.com/ubuntu cosmic/universe amd64 android-libziparchive amd64 1:8.1.0+r23-1~stage1.2ubuntu2 [23.4 kB]
获取:8 http://mirrors.yun-idc.com/ubuntu cosmic/universe amd64 fastboot amd64 1:8.1.0+r23-1~stage1.2ubuntu2 [51.9 kB]
已下载 224 kB,耗时 0秒 (531 kB/s)
正在选中未选择的软件包 android-libunwind。
(正在读取数据库 ... 系统当前共安装有 203779 个文件和目录。)
正准备解包 .../0-android-libunwind_8.1.0+r23-2_amd64.deb  ...
正在解包 android-libunwind (8.1.0+r23-2) ...
正在选中未选择的软件包 android-libbacktrace。
正准备解包 .../1-android-libbacktrace_1%3a8.1.0+r23-1~stage1.2ubuntu2_amd64.deb  ...
正在解包 android-libbacktrace (1:8.1.0+r23-1~stage1.2ubuntu2) ...
正在选中未选择的软件包 libf2fs5:amd64。
正准备解包 .../2-libf2fs5_1.11.0-1_amd64.deb  ...
正在解包 libf2fs5:amd64 (1.11.0-1) ...
正在选中未选择的软件包 libf2fs-format4:amd64。
正准备解包 .../3-libf2fs-format4_1.11.0-1_amd64.deb  ...
正在解包 libf2fs-format4:amd64 (1.11.0-1) ...
正在选中未选择的软件包 android-libsparse。
正准备解包 .../4-android-libsparse_1%3a8.1.0+r23-1~stage1.2ubuntu2_amd64.deb  ...
正在解包 android-libsparse (1:8.1.0+r23-1~stage1.2ubuntu2) ...
正在选中未选择的软件包 android-libf2fs-utils。
正准备解包 .../5-android-libf2fs-utils_8.1.0+r23-1_amd64.deb  ...
正在解包 android-libf2fs-utils (8.1.0+r23-1) ...
正在选中未选择的软件包 android-libutils。
正准备解包 .../6-android-libutils_1%3a8.1.0+r23-1~stage1.2ubuntu2_amd64.deb  ...
正在解包 android-libutils (1:8.1.0+r23-1~stage1.2ubuntu2) ...
正在选中未选择的软件包 android-libziparchive。
正准备解包 .../7-android-libziparchive_1%3a8.1.0+r23-1~stage1.2ubuntu2_amd64.deb  ...
正在解包 android-libziparchive (1:8.1.0+r23-1~stage1.2ubuntu2) ...
正在选中未选择的软件包 fastboot。
正准备解包 .../8-fastboot_1%3a8.1.0+r23-1~stage1.2ubuntu2_amd64.deb  ...
正在解包 fastboot (1:8.1.0+r23-1~stage1.2ubuntu2) ...
正在设置 android-libunwind (8.1.0+r23-2) ...
正在设置 android-libsparse (1:8.1.0+r23-1~stage1.2ubuntu2) ...
正在处理用于 libc-bin (2.28-0ubuntu1) 的触发器 ...
正在设置 android-libbacktrace (1:8.1.0+r23-1~stage1.2ubuntu2) ...
正在处理用于 man-db (2.8.4-2) 的触发器 ...
正在设置 libf2fs5:amd64 (1.11.0-1) ...
正在设置 libf2fs-format4:amd64 (1.11.0-1) ...
正在设置 android-libutils (1:8.1.0+r23-1~stage1.2ubuntu2) ...
正在设置 android-libf2fs-utils (8.1.0+r23-1) ...
正在设置 android-libziparchive (1:8.1.0+r23-1~stage1.2ubuntu2) ...
正在设置 fastboot (1:8.1.0+r23-1~stage1.2ubuntu2) ...
正在处理用于 libc-bin (2.28-0ubuntu1) 的触发器 ...
wang@mibook:~$ fastboot
fastboot: usage: no command
poloshiao
论坛版主
帖子: 18274
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1948 次

Re: fastboot 安装不上了

#10

帖子 poloshiao » 2018-10-17 9:48

我还是不清楚出现这个情况的主要原因是什么
1-3-1. sudo apt update
1-3-2. sudo apt upgrade
1-3-3. sudo apt full-upgrade
1-3-4. sudo apt autoremove
1. 這四個指令 把套件及相依關係都 升級到最新版 把舊版本及舊的相依關係及已經用不到的套件(指因滿足相依關係而自動安裝的套件) 全部移除

2. 詳細參閱
http://manpages.ubuntu.com/manpages/cos ... apt.8.html
apt - command-line interface
相關的 Option 參數
wqk317226700
帖子: 8
注册时间: 2015-09-15 19:37
系统: windows 10,linux
送出感谢: 1 次
接收感谢: 1 次

Re: fastboot 安装不上了

#11

帖子 wqk317226700 » 2018-10-17 9:58

好的, 受教了, 非常感谢
回复

回到 “其它类软件”