当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 19 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : SAPGUI for linux怎么安装啊,JAVA版的
帖子发表于 : 2008-05-13 11:58 

注册: 2007-06-08 13:22
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
这是下载地址(41M)

ftp://ftp.sap.com/pub/sapgui/java/710r3 ... -710r3.jar

对应Win下的JAVA版装好JRE就可以用了。

不知道UBUNTU下要怎么设置。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-05-13 12:02 

注册: 2007-06-08 13:22
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
帮助文件里的东东:

Hardware
IBM x86 compatible PC
CPU: Intel PentiumIII with 800 MHz
RAM: 512MB
Software
Sun Java Runtime Environment 5.0 (32-bit) or 6.0 (32-bit) including Java Plugin.
Make sure that the Java Plugin is properly installed.
C++ runtime: libstdc++.so.6
This library is generally included with current distributions, at least they all have packages with gcc 4.1 which include this library. For information where to find the packages required to install, please refer to SAP Note 909250.
Supported Linux distributions:

SUSE Linux Enterprise Desktop 10
SUSE Linux Enterprise Server 10
Red Hat Enterprise Linux 4
Red Hat Enterprise Linux 5
These Distributions are tested and officially supported.

We expect that SAP GUI runs with other distributions as well and appreciate any feedback about potential problems.

Make sure the distribution you want to use is supported by your Java vendor!

You can find Sun's support statements at http://java.sun.com/j2se/1.5.0/install-linux.html and http://java.sun.com/javase/6/webnotes/i ... linux.html

For supported locales and writing systems, please refer to http://java.sun.com/j2se/1.5.0/docs/gui ... e.doc.html and http://java.sun.com/javase/6/docs/techn ... e.doc.html

SAP tries to make sure that the SAP GUI for the Java Environment runs on other combinations as well. But please note that the solution of problems caused by the Java Runtime depends on the support of the Java vendor.


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-05-13 12:07 
论坛管理员

注册: 2005-03-27 0:06
帖子: 10116
系统: Ubuntu 12.04
送出感谢: 7
接收感谢: 128
wiki上有如何安装java环境的帖子。
http://wiki.ubuntu.org.cn/index.php?tit ... E.E7.BD.AE


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-05-13 12:36 

注册: 2007-06-08 13:22
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
java6 的安装和中文设置

sudo apt-get install openjdk-6-jdk openjdk-6-doc openjdk-6-jre openjdk-6-jre-headless openjdk-6-jre-lib
sudo apt-get remove ttf-kochi-gothic ttf-kochi-mincho ttf-unfonts ttf-unfonts-core
sudo mkdir -p /usr/lib/jvm/java-6-openjdk/jre/lib/fonts/fallback
sudo ln -s /usr/share/fonts/truetype/arphic/uming.ttc /usr/lib/jvm/java-6-openjdk/jre/lib/fonts/fallback


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-05-13 12:46 

注册: 2006-06-03 15:41
帖子: 138
送出感谢: 0 次
接收感谢: 0 次
java安装后,用java-configure一下就可以了,然后运行sap gui的安装程序,然后就ok了


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-05-13 14:04 

注册: 2007-06-08 13:22
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
已成功

我的操作步骤如下

(1)java6 的安装和中文设置

sudo apt-get install openjdk-6-jdk openjdk-6-doc openjdk-6-jre openjdk-6-jre-headless openjdk-6-jre-lib
sudo apt-get remove ttf-kochi-gothic ttf-kochi-mincho ttf-unfonts ttf-unfonts-core
sudo mkdir -p /usr/lib/jvm/java-6-openjdk/jre/lib/fonts/fallback
sudo ln -s /usr/share/fonts/truetype/arphic/uming.ttc /usr/lib/jvm/java-6-openjdk/jre/lib/fonts/fallback

(2)在PlatinGUI-Linux-710r3.jar上点右键,选"Open with Sun Java Runtime"开始安装。

(3)完成后在\home\用户名\下多了两个目录SAPGUI和SAPGUI7.10rev3,SAPGUI\bin\下的guilogon就是快捷方式,点击后选"run"就OK了。

我的方法可能有点菜了,不过还是贴出来抛砖引玉一下。

P.S.刚发现Applications下多了一个“其它“,里面是"SAPGUI 7.10 rev 3"直接点击就运行了。


页首
 用户资料  
 
7 楼 
 文章标题 : 配置好Java环境后,运行安装sapgui7r6的时候,无响应。。。请指教!
帖子发表于 : 2008-09-08 22:26 

注册: 2008-09-08 22:22
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
完全按照楼主所述配只好了Java环境,在终端输入安装命令后,弹出SAPGUI的安装界面,点击确认后,进程就不动了,何解???请各位兄弟不吝赐教!!!
linux小白是也


页首
 用户资料  
 
8 楼 
 文章标题 : Re: SAPGUI for linux怎么安装啊,JAVA版的
帖子发表于 : 2008-10-01 23:53 

注册: 2008-08-30 15:59
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
还不知道怎么装的,看看这个。
http://www.sapfans.cn/viewthread.php?ti ... a=page%3D1


页首
 用户资料  
 
9 楼 
 文章标题 : Re: SAPGUI for linux怎么安装啊,JAVA版的
帖子发表于 : 2008-10-22 17:45 
头像

注册: 2008-10-21 20:56
帖子: 71
送出感谢: 0 次
接收感谢: 0 次
安装好了,可是不知道怎么配登录信息。


页首
 用户资料  
 
10 楼 
 文章标题 : Re: SAPGUI for linux怎么安装啊,JAVA版的
帖子发表于 : 2008-10-22 19:34 
头像

注册: 2008-10-21 20:56
帖子: 71
送出感谢: 0 次
接收感谢: 0 次
conn=/H/10.1.11.6/S/3201
这几个参数我之知道一个IP地址,其他的是什么意思呢?


页首
 用户资料  
 
11 楼 
 文章标题 : Re: SAPGUI for linux怎么安装啊,JAVA版的
帖子发表于 : 2008-12-15 18:32 

注册: 2008-12-11 22:08
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
H好像是连接速度,你可以改M试一下,
3201是服务器端口
S是什么我也不知道,哈哈 :em03


页首
 用户资料  
 
12 楼 
 文章标题 : Re: SAPGUI for linux怎么安装啊,JAVA版的
帖子发表于 : 2008-12-17 16:19 

注册: 2008-12-17 16:15
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
我试过这个方法,还是有问题
我的问题是,我运行那个命令后,弹出sapgui的安装窗口,但是点击next之后窗口就消失了,命令行上也没有任何提示。。。。。T_T


页首
 用户资料  
 
13 楼 
 文章标题 : Re: SAPGUI for linux怎么安装啊,JAVA版的
帖子发表于 : 2008-12-25 10:16 

注册: 2008-12-25 10:13
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
我的SAPGUI710 FOR JAVA在ubuntu810上装好了,但只能在命令行输入guilogon运行,每次还要EXPORT platin参数。并且进入登录界面后密码不能直接输入,必须点了那回车按钮(而不是回车键)才能输入密码。很奇怪


页首
 用户资料  
 
14 楼 
 文章标题 : Re: SAPGUI for linux怎么安装啊,JAVA版的
帖子发表于 : 2009-04-17 9:25 

注册: 2007-03-25 14:04
帖子: 11
送出感谢: 0 次
接收感谢: 0 次
zelphar 写道:
我试过这个方法,还是有问题
我的问题是,我运行那个命令后,弹出sapgui的安装窗口,但是点击next之后窗口就消失了,命令行上也没有任何提示。。。。。T_T



我的也是出现了这个问题,java -jar PlatinGUI-Linux-710r8.jar 之后弹出对话框,点NEXT之后就什么也没有了,有谁知道是哪里出问题了?


页首
 用户资料  
 
15 楼 
 文章标题 : Re: SAPGUI for linux怎么安装啊,JAVA版的
帖子发表于 : 2009-05-05 10:32 

注册: 2008-06-19 9:34
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
z_htao 写道:
zelphar 写道:
我试过这个方法,还是有问题
我的问题是,我运行那个命令后,弹出sapgui的安装窗口,但是点击next之后窗口就消失了,命令行上也没有任何提示。。。。。T_T



我的也是出现了这个问题,java -jar PlatinGUI-Linux-710r8.jar 之后弹出对话框,点NEXT之后就什么也没有了,有谁知道是哪里出问题了?



装了这几个就可以了
sudo apt-get install sun-java6-jdk ttf-arphic-uming
sudo mkdir -p /usr/lib/jvm/java-6-sun/jre/lib/fonts/fallback
sudo ln -s /usr/share/fonts/truetype/arphic/uming.ttc /usr/lib/jvm/java-6-sun/jre/lib/fonts/fallback


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 19 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译