当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 安装交叉编译器出现的问题
帖子发表于 : 2008-12-09 16:04 

注册: 2008-12-09 13:55
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
本人按照以下步骤安装arm-linux-gcc 2.95.3

1.安装交叉编译器
sudo tar jxvf cross-2.95.3.tar.bz2
sudo mv 2.95.3/ /usr/local/arm

2.把交叉编译器的路径加入到PATH
sudo vim /etc/bash.bashrc
在后面加入如下代码:
if [ -d /usr/local/arm/2.95.3 ] ; then
PATH=/usr/local/arm/2.95.3/bin:"${PATH}"
fi

3.使新的环境变量生效
# source /etc/profile

4.检查是否将路径加入PATH的方法:
echo $PATH
显示的内容中有/usr/local/arm/2.95.3/bin

****出现以下问题,找不到arm-linux-gcc 文件 为什么?????????请求帮助!!!!!!!!!!!!
beard@beard-desktop:/usr/local/arm/2.95.3/bin$ ls
arm-linux-addr2line arm-linux-g++ arm-linux-ld arm-linux-ranlib arm-linux-unprotoize jv-scan
arm-linux-ar arm-linux-g77 arm-linux-nm arm-linux-readelf cpp
arm-linux-as arm-linux-gasp arm-linux-objcopy arm-linux-size gcjh
arm-linux-c++ arm-linux-gcc arm-linux-objdump arm-linux-strings gcov
arm-linux-c++filt arm-linux-gcj arm-linux-protoize arm-linux-strip jcf-dump

beard@beard-desktop:/usr/local/arm/2.95.3/bin$ echo $PATH
/usr/local/arm/2.95.3/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games

beard@beard-desktop:/usr/local/arm/2.95.3/bin$ arm-linux-gcc -V
bash: /usr/local/arm/2.95.3/bin/arm-linux-gcc: 没有该文件或目录
我已经试过修改etc/environment 或者 /etc/bash.bashrc 或者~/.bashrc文件里PATH 变量。
但还是这样


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 安装交叉编译器出现的问题
帖子发表于 : 2008-12-09 19:11 

注册: 2008-12-09 13:55
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
哪位大虾救救我吧!!


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 安装交叉编译器出现的问题
帖子发表于 : 2008-12-09 19:17 

注册: 2006-09-11 22:47
帖子: 2841
送出感谢: 0 次
接收感谢: 4
gcc 并没有 -V 这种参数,
试试
代码:
gcc --version


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 安装交叉编译器出现的问题
帖子发表于 : 2008-12-09 20:32 

注册: 2008-12-09 13:55
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
不可以,还是那样啊


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 安装交叉编译器出现的问题
帖子发表于 : 2009-05-22 23:34 

注册: 2008-11-20 12:37
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
这个问题,你解决了吗?我也郁闷着了!!要是你解决簕。告诉一声阿。谢谢


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 安装交叉编译器出现的问题
帖子发表于 : 2009-09-02 21:22 

注册: 2009-09-02 21:19
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
:em01 楼主您好!这个问题,你解决了吗?我也郁闷着了!!要是你解决簕。告诉一声阿。谢谢


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 安装交叉编译器出现的问题
帖子发表于 : 2009-09-03 9:05 

注册: 2009-09-02 21:19
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
我的这个问题解决了,原来是少装了软件,很抱歉!具体是那一个我也不清楚,我昨晚搜索与安装交叉编译环境相关的文章看,只要是上面提到需要安装的软件,能找到的我都装了。后来在我准备关机睡觉时,我习惯性的试了一下arm-linux-gcc -v 。居然显示了一大堆英文和版本号,天啊!可以用了,哈哈...功夫不负有心人呀。
希望遇到此问题的朋友们不仿也试试。


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 安装交叉编译器出现的问题
帖子发表于 : 2009-09-12 16:33 
头像

注册: 2008-11-16 11:11
帖子: 397
送出感谢: 0 次
接收感谢: 2
/etc/bash.bashrc是系统级别的,最好修改~/.bashrc

需要的包大约就是 gcc g++ libgcc1 libg++ make gdb这几个


_________________
等俺有钱了,俺把M$买来好好搓搓


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译