当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : Ubuntu9.10 正常运行 matlab R14
帖子发表于 : 2010-07-23 17:38 
头像

注册: 2008-08-14 11:08
帖子: 23
送出感谢: 0 次
接收感谢: 0 次
matlab版本:MatlabR14 3cd的那种
操作系统:Ubuntu9.10
系统自带的java不好用 为了让Matlab支持中文,要安装java6

代码:
sudo apt-get install sun-java6-bin sun-java6-jre


然后安装MatlabR14 具体安装方法不说了 网上到处都是

我安装到了/opt/matlab 所以这里就拿它来举例

安装完成以后修改matlab启动参数:

代码:
sudo gedit /opt/matlab/bin/matlab


在#! /bin/sh的下一行加上“export MATLAB_JAVA=/usr/lib/jvm/java-6-sun/jre“
引用:
#! /bin/sh
export MATLAB_JAVA=/usr/lib/jvm/java-6-sun/jre
#


这个时候中文是没有问题了 但是直接运行matlab会提示opengl错误
这时使用ldd来查看matlab与哪些共享库没有关联上:

代码:
ldd /opt/matlab/bin/glnx86/glren.so | grep “not found”


输出前几行会显示哪些共享库没有被找到,我的输出如下:

引用:
bin/glnx86/glren.so: /opt/matlab/bin/glnx86/../../sys/os/glnx86/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6)
bin/glnx86/glren.so: /opt/matlab/bin/glnx86/../../sys/os/glnx86/libgcc_s.so.1: version `GCC_3.3' not found (required by /usr/lib/libstdc++.so.6)


提示libgcc_s.so.1未找到 就拿系统的libgcc_s.so.1来替代matlab的libgcc_s.so.1:

代码:
 sudo cp /lib/libgcc_s.so.1 /opt/matlab/sys/os/glnx86/libgcc_s.so.1


不再提示错误 正常运行


页首
 用户资料  
 
2 楼 
 文章标题 : Re: Ubuntu9.10 正常运行 matlab R14
帖子发表于 : 2010-07-23 17:47 
头像

注册: 2008-12-13 15:03
帖子: 395
送出感谢: 0 次
接收感谢: 1
fallback字体,设置一个就可以了


_________________
一条狗的马甲!
对不起,我承认我是一只穿着马甲的狗!


页首
 用户资料  
 
3 楼 
 文章标题 : Re: Ubuntu9.10 正常运行 matlab R14
帖子发表于 : 2010-07-23 18:28 
头像

注册: 2008-01-25 12:13
帖子: 83
送出感谢: 0 次
接收感谢: 0 次
牛人,我以前装了,结果还找我要序列号

刚刚在网上碰到一个研究scilab的牛人


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译