当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 有谁装过ARToolkit库
帖子发表于 : 2010-11-28 22:53 
头像

注册: 2010-06-19 12:50
帖子: 193
系统: AIX、UBUNTU
送出感谢: 2
接收感谢: 5
我试了好久都没有成功.

我用的本的摄像头,选的LinuxV4选项Configure的,

由于UBUNTU的/dev/video为/dev/video0所以在Configure后要对include/AR里的两个config文件作更改.

这儿没有问题,ARtoolkit官网的解释也是如此.

然后make,再进bin运行例子程序,然后就报错.错误如下.

config文件中把Chanel选的1时提示chanel=# 错误
改0后仍然错误,变成chanel=0错误.

看ARToolkit网站的解决说是可能不支持这款摄像头.我不明白为什么我的摄像头可以用而它打不开呢.
我试了试同门的FLAToolkit,用AS3可以打开摄像头的,当然是ADOBE的功劳,但Linux下没FLASH啊.

请装过ARToolkit的同学指教.最近喜欢上了初音,想自己做做看.各位帮忙了.


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 有谁装过ARToolkit库
帖子发表于 : 2010-11-29 13:05 
头像

注册: 2010-06-19 12:50
帖子: 193
系统: AIX、UBUNTU
送出感谢: 2
接收感谢: 5
问题有了转机,我发现刚开始我下载的是老版本.下新版本后发现问题变得更严重了.

请装过的同学给个答案啊!


_________________


Keep it easy stupid !




I am Code Vampire .




I like Linux . I like open source .



页首
 用户资料  
 
3 楼 
 文章标题 : Re: 有谁装过ARToolkit库
帖子发表于 : 2010-11-29 17:51 
头像

注册: 2010-06-19 12:50
帖子: 193
系统: AIX、UBUNTU
送出感谢: 2
接收感谢: 5
我找到了ARToolkit的deb版本,安装一切顺利.但问题依然存在.

deb包地址:
http://ppa.launchpad.net/artoolkit-dev/ ... artoolkit/

安装完毕后运行/usr/share/artoolkit-dev/bin下的simpletest得到结果:


No video config string supplied, using defaults.
error: selecting channel 0

难道真的是不支持我的摄像头吗?

手头没有usb摄像头,哪位仁兄在自己的机子上试试?

谢谢了.我用的ubuntu10.04


_________________


Keep it easy stupid !




I am Code Vampire .




I like Linux . I like open source .



页首
 用户资料  
 
4 楼 
 文章标题 : Re: 有谁装过ARToolkit库
帖子发表于 : 2012-03-18 0:34 

注册: 2011-02-17 22:58
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
楼主的问题解决了吗?我也遇到这个问题,可否指点下?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译