ubuntu 10.04下安装nachos4.0的编译问题

其它类软件,非上述版软件
回复
domain_pro
帖子: 4
注册时间: 2011-01-14 12:36
送出感谢: 0
接收感谢: 0

ubuntu 10.04下安装nachos4.0的编译问题

#1

帖子 domain_pro » 2011-01-14 12:48

我在安装nachos4.0时出现了如下的编译错误:


/lib/cpp -P -I../userprog -I../threads -I../lib start.s > strt.s
as -o start.o strt.s
strt.s: Assembler messages:
strt.s:4: Error: unknown pseudo-op: `.ent'
strt.s:6: Error: suffix or operands invalid for `ja'
strt.s:7: Error: no such instruction: `move $4,$0'
strt.s:8: Error: suffix or operands invalid for `ja'
make: *** [start.o] 错误 1



gcc的版本是4.4.3,我认为是gcc的问题,可是我不会弄!有没有好心的高手指点我一下怎么解决阿?

顺便说一下,这个版本是高了还是低了?什么版本合适?麻烦给推荐一个
上次由 domain_pro 在 2011-01-16 17:15,总共编辑 1 次。
头像
ati9550128m
帖子: 47
注册时间: 2010-07-30 15:52
送出感谢: 0
接收感谢: 0

Re: ubuntu 10.04下安装nachos4.0的编译问题

#2

帖子 ati9550128m » 2011-01-14 13:52

那就是降低gcc的版本了嘛 先apt-get install gcc-4.x
然后改变/usr/bin里面gcc的链接
rm /usr/bin/gcc
ln /usr/bin/gcc-4.x /usr/bin/gcc

rm /usr/bin/g++
ln /usr/bin/g++-4.x /usr/bin/g++
再gcc -v查看当前版本号。

代码: 全选

[url]http://blog.sina.com.cn/1989wc[/url]
domain_pro
帖子: 4
注册时间: 2011-01-14 12:36
送出感谢: 0
接收感谢: 0

Re: ubuntu 10.04下安装nachos4.0的编译问题

#3

帖子 domain_pro » 2011-01-16 17:18

2楼说的好像不行啊!get install找不到低版本的gcc,我看网上说要2.95的,但我不会装啊!好像手动装容易出错。
回复

回到 “其它类软件”