当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 18 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : 怎样修复ubuntu损坏的软件包?
帖子发表于 : 2006-02-24 16:16 

注册: 2006-02-24 9:33
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
我的系统是ubuntu5.10,升级系统或安装软件包都无法进行,提示您的系统里有 1 个(依赖关系)毁损的软件包!请使用“Broken”过滤器定位它们。
无法升级系统!
请先修复(依赖关系)毁损的软件包
该怎样做阿,高手指教!


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-02-24 17:03 

注册: 2006-02-24 9:33
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
安装时一些提示如下:

root@ubuntu:~# apt-get install xmame
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
xmame 已经是最新的版本了。
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
xmame-sdl: 依赖: xmame-common (= 0.86-1) 但是它将不会被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。

root@ubuntu:~# apt-get -f install
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
正在更正依赖关系... 完成
将会安装下列的额外的软件包:
xmame-common
建议安装的软件包:
xmame-tools
下列【新】软件包将被安装:
xmame-common
共升级了 0 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
有 1 个软件包没有被完全安装或卸载。
需要下载 0B/238kB 的软件包。
解压缩后会消耗掉 545kB 的额外空间。
您希望继续执行吗?[Y/n]y

正在预设定软件包 ...
(正在读取数据库 ... 系统当前总共安装有 67808 个文件和目录。)
正在解压缩 xmame-common (从 .../xmame-common_0.86-1_all.deb) ...
dpkg:处理 /var/cache/apt/archives/xmame-common_0.86-1_all.deb (--unpack)时出错 :
正试图覆盖“/usr/share/man/man6/xmame.6.gz”,它属于软件包 xmame
在处理时有错误发生:
/var/cache/apt/archives/xmame-common_0.86-1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
高手帮忙阿!在线等~~~~~~~~~```


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-02-24 17:22 
头像

注册: 2005-06-21 20:24
帖子: 715
地址: 甘肃
送出感谢: 0 次
接收感谢: 0 次
代码:
sudo apt-get remove xmame
sudo rm /usr/share/man/man6/xmame.6.gz
sudo apt-get install xmame-common xmame

试试 不保证可行


_________________
ubuntu 6.06
我是初学者 大家多多关照


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-02-24 17:58 

注册: 2006-02-24 9:33
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
不行阿!~~
root@ubuntu:~/racer# apt-get remove xmame
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
xmame-sdl: 依赖: xmame-common (= 0.86-1) 但是它将不会被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-02-24 19:36 

注册: 2006-02-24 9:33
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
难道就没人能解决吗?没有人遇到过类似的问题!
真的要绝望了~~~~~~~~~`


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-02-25 0:14 
头像

注册: 2006-02-06 11:16
帖子: 30
送出感谢: 0 次
接收感谢: 0 次
用这个试试吧,我今天碰到过类似的问题,
apt-get -f install xmame


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-02-25 0:50 

注册: 2006-01-07 19:39
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
用synaptic修复试试,我上次就是这么弄好的


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2006-02-25 8:45 

注册: 2006-02-14 21:05
帖子: 190
送出感谢: 0 次
接收感谢: 0 次
apt-get install -f xmame


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2006-02-25 12:03 

注册: 2006-02-24 9:33
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
让我试试再说,先谢谢各位了!


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2006-02-25 12:12 

注册: 2006-02-24 9:33
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
用apt-get install -f xmame命令不行阿,用synaptic修复,具体怎样做阿,说详细一点,用ubuntu时间很短!


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2006-02-25 12:34 

注册: 2006-02-24 9:33
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
运行synaptic出现:[img]file:///root/Desktop/Screenshot.png
[/img]


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2006-02-25 12:40 

注册: 2006-02-24 9:33
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
运行出现


附件:
Screenshot.png
Screenshot.png [ 101.56 KiB | 被浏览 1226 次 ]

页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2006-02-25 12:42 
论坛管理员

注册: 2005-03-27 0:06
帖子: 10116
系统: Ubuntu 12.04
送出感谢: 7
接收感谢: 128
在新立得找到破损的包,然后删除就好了。


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2006-02-25 14:42 

注册: 2006-02-24 9:33
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
怎么找阿,打开新立得包管理器-编辑-修正(依赖关系)损坏的软件包(apt-get -f install),显示已成功修复软件包依赖关系。但实施变更时出现:


附件:
Screenshot-1.png
Screenshot-1.png [ 99.59 KiB | 被浏览 1195 次 ]

页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2006-02-25 17:33 

注册: 2006-02-24 9:33
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
解决了,谢谢楼上的兄弟!
但现在不会弹出自动升级的那个提示了?
不过大问题解决了,很高兴不用重装ubuntu了!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 18 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译