当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 从7.10升级到8.04时出错
帖子发表于 : 2008-01-27 10:48 

注册: 2006-06-09 9:37
帖子: 99
送出感谢: 0 次
接收感谢: 0 次
升级的时候显示这样的问题

代码:
cyrus@ubuntu:~$ sudo apt-get upgrade
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
有 8 个软件包没有被完全安装或卸载。
After this operation, 0B of additional disk space will be used.
您希望继续执行吗?[Y/n]Y
正在设置 policykit (0.7-2ubuntu2) ...
chown: 无法访问“/var/run/PolicyKit”: No such file or directory
dpkg:处理 policykit (--configure)时出错:
 子进程 post-installation script 返回了错误号 1
dpkg:依赖关系问题使得 hal 的配置工作不能继续:
 hal 依赖于 policykit (>= 0.7);然而:
  软件包 policykit 还没有被配置。
dpkg:处理 hal (--configure)时出错:
 依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 hwdb-client-common 的配置工作不能继续:
 hwdb-client-common 依赖于 hal;然而:
  软件包 hal 还没有被配置。
dpkg:处理 hwdb-client-common (--configure)时出错:
 依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 hwdb-client-kde 的配置工作不能继续:
 hwdb-client-kde 依赖于 hwdb-client-common;然而:
  软件包 hwdb-client-common 还没有被配置。
dpkg:处理 hwdb-client-kde (--configure)时出错:
 依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 kde-guidance-powermanager 的配置工作不能继续:
 kde-guidance-powermanager 依赖于 hal;然而:
  软件包 hal 还没有被配置。
dpkg:处理 kde-guidance-powermanager (--configure)时出错:
 依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 kubuntu-desktop 的配置工作不能继续:
 kubuntu-desktop 依赖于 hal;然而:
  软件包 hal 还没有被配置。
 kubuntu-desktop 依赖于 hwdb-client-kde;然而:
  软件包 hwdb-client-kde 还没有被配置。
dpkg:处理 kubuntu-desktop (--configure)时出错:
 依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 network-manager 的配置工作不能继续:
 network-manager 依赖于 hal (>= 0.5.7.1);然而:
  软件包 hal 还没有被配置。
dpkg:处理 network-manager (--configure)时出错:
 依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 network-manager-kde 的配置工作不能继续:
 network-manager-kde 依赖于 network-manager (>= 0.6.2);然而:
  软件包 network-manager 还没有被配置。
dpkg:处理 network-manager-kde (--configure)时出错:
 依赖关系问题 - 仍未被配置
在处理时有错误发生:
 policykit
 hal
 hwdb-client-common
 hwdb-client-kde
 kde-guidance-powermanager
 kubuntu-desktop
 network-manager
 network-manager-kde
E: Sub-process /usr/bin/dpkg returned an error code (1)
cyrus@ubuntu:~$

请教一下怎么回事阿,我用的源是欧洲那个官方的源,把gusty改成hardy直接用的。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-01-27 11:05 

注册: 2006-06-05 17:53
帖子: 199
地址: 四川德阳
送出感谢: 0 次
接收感谢: 0 次
上一次我也是这个问题,害得我重装7.10


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-01-27 14:02 
头像

注册: 2006-01-25 22:29
帖子: 1322
地址: 上海
送出感谢: 0 次
接收感谢: 0 次
应该使用这个命令
sudo apt-get dist-upgrade

不可以直接修改源


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-01-27 14:05 
头像

注册: 2007-02-02 18:14
帖子: 30702
系统: debian sid
送出感谢: 1
接收感谢: 34
jimhu 写道:
应该使用这个命令
sudo apt-get dist-upgrade

不可以直接修改源


应该可以直接改源吧?
不过命令是不能用那个,应该用
代码:
sudo apt-get dist-upgrade


_________________
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-01-28 18:32 

注册: 2006-06-09 9:37
帖子: 99
送出感谢: 0 次
接收感谢: 0 次
用了
代码:
sudo apt-get dist-upgrade

还是同样的问题


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译