[问题]求助!!不能安装下载下来的deb包。

重复贴和参考价值不大的帖子,版主维护
回复
linyjfei
帖子: 127
注册时间: 2007-06-05 0:05
送出感谢: 0
接收感谢: 0

[问题]求助!!不能安装下载下来的deb包。

#1

帖子 linyjfei » 2008-02-02 13:32

7.04系统,今天下了mldonkey的DEB包,双击安装提示"Error:Dependency is not satisfiable:libc6" 然后用dpkg命令安装,提示这样的:
fenggu@fenggu:~/Desktop$ sudo dpkg -i mldonkey-server_2.9.2-2_i386.deb
选中了曾被取消选择的软件包 mldonkey-server。
(正在读取数据库 ... 系统当前总共安装有 136310 个文件和目录。)
正在解压缩 mldonkey-server (从 mldonkey-server_2.9.2-2_i386.deb) ...
dpkg:依赖关系问题使得 mldonkey-server 的配置工作不能继续:
mldonkey-server 依赖于 libc6 (>= 2.6.1-1);然而:
系统中 libc6 的版本为 2.5-0ubuntu14。
mldonkey-server 依赖于 libfreetype6 (>= 2.3.5);然而:
系统中 libfreetype6 的版本为 2.2.1-5ubuntu1.1。
mldonkey-server 依赖于 libgcc1 (>= 1:4.2.1);然而:
系统中 libgcc1 的版本为 1:4.1.2-0ubuntu4。
mldonkey-server 依赖于 libgd2-noxpm (>= 2.0.34) | libgd2-xpm (>= 2.0.34);然而:
未曾安装软件包“libgd2-noxpm”。
未曾安装软件包“libgd2-xpm”。
mldonkey-server 依赖于 libstdc++6 (>= 4.2.1);然而:
系统中 libstdc++6 的版本为 4.1.2-0ubuntu4。
mldonkey-server 依赖于 zlib1g (>= 1:1.2.3.3.dfsg-1);然而:
系统中 zlib1g 的版本为 1:1.2.3-13ubuntu4。
dpkg:处理 mldonkey-server (--install)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
mldonkey-server

试看过libc6等包在源里已经是最新的了,用的源是cn99的和cn.archive的源,是不是源里的版本太低了。晕哦,难不成还要一个一个包的去找...
还下了一个eva的DEB包,也是一样,但用编译可以搞得定。
这是咋回事呢?难道要从此走向编译这条道啦... ...
头像
yaska
帖子: 1169
注册时间: 2007-10-28 21:35
送出感谢: 0
接收感谢: 2 次
联系:

#2

帖子 yaska » 2008-02-02 13:33

试试

sudo aptitude install ...
头像
yaoms
帖子: 4953
注册时间: 2007-10-19 14:51
来自: 深圳
送出感谢: 0
接收感谢: 2 次

#3

帖子 yaoms » 2008-02-02 13:34

你下的deb太新了,呵呵
Nothing 有事请发邮件到 yms541 AT gmail.com
alias 爱慕颇雷尔='mplayer'
头像
fortruth
帖子: 1795
注册时间: 2005-11-06 1:51
来自: 七彩云世界
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 fortruth » 2008-02-02 13:37

yaoms 写了:你下的deb太新了,呵呵
太新!
佛出寺,求索真世界 For_Truth:Free_Open_Share
OPEN GPG KEY:03D18D95
回复

回到 “归档贴”