当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]安装编译软件问题??
帖子发表于 : 2008-02-10 21:05 

注册: 2007-09-10 12:58
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
yan@yan-desktop:~$ sudo apt-get install build-essential
Password:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
build-essential: 依赖: libc6-dev 但是它将不会被安装 或
libc-dev
依赖: gcc (>= 4:4.0) 但是它将不会被安装
依赖: g++ (>= 4:4.0) 但是它将不会被安装
依赖: make 但是它将不会被安装
依赖: dpkg-dev (>= 1.13.5) 但是它将不会被安装
multiget: 依赖: libwxgtk2.6-0 (>= 2.6.1.2ubuntu2) 但是它将不会被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。
请问这是什么原因,请指点谢谢!!!


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-02-10 21:21 
头像

注册: 2007-09-07 20:07
帖子: 191
地址: 江苏 苏州
送出感谢: 0 次
接收感谢: 0 次
你运行apt-get -f install修复一下就好了。。。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-02-10 21:27 

注册: 2007-09-10 12:58
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
谢谢楼上大哥,我试了,可是不行。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-02-10 21:30 
头像

注册: 2007-07-11 20:59
帖子: 3922
送出感谢: 0 次
接收感谢: 0 次
代码:
build-essential: 依赖: libc6-dev 但是它将不会被安装 或
libc-dev


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译