当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 加载windows下创建的TrueCrypt文件后,中文乱码
帖子发表于 : 2008-02-20 11:34 

注册: 2007-01-11 16:41
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
在windows下用TrueCrypt 4.2a创建了个加密文件,放了一些中文文件名的东西进去
在ubuntu 7.10下同样用TrueCrypt 4.2a加载该文件,打开后,里面的中文文件全是问号,看不到中文名
试过修改fstab,也不成,请问有无解决办法?谢谢


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-02-20 13:13 
头像

注册: 2007-03-13 17:26
帖子: 2254
送出感谢: 0 次
接收感谢: 1
用NTFS好像不会。。。win下回的中文名,LIN下打开正常


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-02-20 14:04 

注册: 2007-01-11 16:41
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
windwiny 写道:
用NTFS好像不会。。。win下回的中文名,LIN下打开正常

NTFS磁盘上的文件名都是正常的,只是TrueCrypt创建的加密卷中的中文文件名无法正常显示


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-02-21 15:20 
头像

注册: 2007-01-22 23:23
帖子: 453
地址: 42 39'18.85"N,94 10'00.80"E
送出感谢: 1
接收感谢: 0 次
在ubuntu 7.10下如何加载truecrypt加密的文件?


页首
 用户资料  
 
5 楼 
 文章标题 : Re:
帖子发表于 : 2009-03-20 12:40 

注册: 2007-07-07 11:58
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
xki 写道:
windwiny 写道:
用NTFS好像不会。。。win下回的中文名,LIN下打开正常

NTFS磁盘上的文件名都是正常的,只是TrueCrypt创建的加密卷中的中文文件名无法正常显示


网上找到的,直接贴在这吧:

啟動TrueCrypt Settings>Preferences>Mount Options 在底下的Mount Options裡的指令列裡輸入 utf8 後按下確定存檔離開,下次掛載的映像檔,中文的檔名就再也不會出現亂碼了。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译