关于apt-get

重复贴和参考价值不大的帖子,版主维护
回复
areslp
帖子: 141
注册时间: 2007-05-07 23:55
送出感谢: 0
接收感谢: 1 次

关于apt-get

#1

帖子 areslp » 2008-02-22 22:43

用sudo apt-get check
出现以下:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
您也许需要运行“apt-get -f install”来纠正上面的错误。
下列的软件包有不能满足的依赖关系:
mldonkey-server: 依赖: libc6 (>= 2.7-1) 但是 2.6.1-1ubuntu10 已经安装了
依赖: libgd2-noxpm (>= 2.0.35.dfsg) 但是它还没有被安装 或
libgd2-xpm (>= 2.0.35.dfsg) 但是它还没有被安装
E: 不能满足依赖关系。不妨试一下 -f 选项。

不知道怎么清除这个东西了,现在每次apt-get install的时候上面那段错误都要跳出来
头像
zmcbb30
帖子: 2717
注册时间: 2006-09-30 0:32
来自: 巴拉特星系第四行星──海尼森
送出感谢: 0
接收感谢: 0
联系:

Re: 关于apt-get

#2

帖子 zmcbb30 » 2008-02-22 22:50

areslp 写了:用sudo apt-get check
出现以下:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
您也许需要运行“apt-get -f install”来纠正上面的错误。
下列的软件包有不能满足的依赖关系:
mldonkey-server: 依赖: libc6 (>= 2.7-1) 但是 2.6.1-1ubuntu10 已经安装了
依赖: libgd2-noxpm (>= 2.0.35.dfsg) 但是它还没有被安装 或
libgd2-xpm (>= 2.0.35.dfsg) 但是它还没有被安装
E: 不能满足依赖关系。不妨试一下 -f 选项。

不知道怎么清除这个东西了,现在每次apt-get install的时候上面那段错误都要跳出来
头可断,血可流,靓女不可不追求
相艾唔好口,够姜就只抽

BARTON 2500+/1536MDDR400
EP8RDA3G/MX4000 128M64bit 8X
DiamondPlus9-6Y080L0-ATA133
Samsung743DF
HiweedDesktop-1.0
头像
wavydoom
帖子: 1081
注册时间: 2008-02-15 0:08
送出感谢: 0
接收感谢: 0

#3

帖子 wavydoom » 2008-02-22 23:10

缺少依赖的包阿。你就运行 apt-get -f install 阿。把依赖关系满足了就可以了。
areslp
帖子: 141
注册时间: 2007-05-07 23:55
送出感谢: 0
接收感谢: 1 次

#4

帖子 areslp » 2008-02-23 8:17

这个依赖错误是我apt装mldonkey-server的时候出现的,但是我现在不想装它了,我用apt装别的东西的时候它还是跳出来啊,去不掉了

apt-get -f install的话它还是在装mldonkey-server啊
头像
yaoms
帖子: 4953
注册时间: 2007-10-19 14:51
来自: 深圳
送出感谢: 0
接收感谢: 2 次

#5

帖子 yaoms » 2008-02-23 9:07

装完再卸掉
Nothing 有事请发邮件到 yms541 AT gmail.com
alias 爱慕颇雷尔='mplayer'
areslp
帖子: 141
注册时间: 2007-05-07 23:55
送出感谢: 0
接收感谢: 1 次

#6

帖子 areslp » 2008-03-03 11:17

恩。。谢谢楼上的,我最后就是这么搞的。。米办法
回复

回到 “归档贴”