当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]一些程序不能运行
帖子发表于 : 2008-03-02 10:05 

注册: 2006-10-29 18:34
帖子: 25
送出感谢: 0 次
接收感谢: 0 次
小弟的系统出现了个严重问题,表现如下,能进入系统,但是点击applications里面的程序时基本上都不能运行,可以看到要运行的程序在状态栏里面出现,但是过了一会就没了,也就是说系统有运行过程序,但是好像是出了问题,所以最后又自己结束了程序的运行。不管是firefox,openoffice 还是terminal都不能正确运行。但是我用另一个用户登录的话,就没任何问题,程序能正确运行。不知道第一个用户的什么配置出了问题。请教大牛,要怎么解决这个问题。谢谢。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-03-02 10:15 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
开个X终端运行那个程序, 看输出什么信息


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-03-02 10:32 

注册: 2006-10-29 18:34
帖子: 25
送出感谢: 0 次
接收感谢: 0 次
BigSnake.NET 写道:
开个X终端运行那个程序, 看输出什么信息



I run firefox in X terminal and I got the error message saying: (firefox-bin:11569): Gtk-WARNING **: cannot open display:

thank you.


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-03-02 10:42 

注册: 2006-10-29 18:34
帖子: 25
送出感谢: 0 次
接收感谢: 0 次
我用用户B登录,然后su成为A用户,然后在terminal 下运行firefox和evolution得到下面的错误信息:Xlib: connection to ":0.0" refused by server

Xlib: No protocol specified



(firefox-bin:11805): Gtk-WARNING **: cannot open display:

Xlib: connection to ":0.0" refused by server

Xlib: No protocol specified


cannot open display:
Run 'evolution --help' to see a full list of available command line options.


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-03-02 11:48 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
jiangguobme 写道:
我用用户B登录,然后su成为A用户,然后在terminal 下运行firefox和evolution得到下面的错误信息:Xlib: connection to ":0.0" refused by server

Xlib: No protocol specified



(firefox-bin:11805): Gtk-WARNING **: cannot open display:

Xlib: connection to ":0.0" refused by server

Xlib: No protocol specified


cannot open display:
Run 'evolution --help' to see a full list of available command line options.


不要这样su

用A登录, 用A运行


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-03-03 0:40 

注册: 2006-10-29 18:34
帖子: 25
送出感谢: 0 次
接收感谢: 0 次
用A的话,等登录进xwindow,但是连terminal都打不开,所以没办法用A运行程序然后看有什么错误信息输出。查了google,好像是我的A用户不能用得到x server的服务。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译