安装软件出现“不能满足的依赖关系”怎么解决

重复贴和参考价值不大的帖子,版主维护
回复
safeiluos
帖子: 26
注册时间: 2007-05-08 16:40
送出感谢: 0
接收感谢: 0

安装软件出现“不能满足的依赖关系”怎么解决

#1

帖子 safeiluos » 2008-03-11 9:50

我试着使用了beryl,但设置里面的效果总只有那一点,现在还有没有办法更新设置里的效果,还有,我beryl似乎没有开启窗口装饰器,要怎么才能开启,我试着运行sudo apt-get install beryl beryl-manager emerald,但出现如下提示
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
beryl 已经是最新的版本了。
beryl-manager 已经是最新的版本了。
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
emerald: 依赖: libc6 (>= 2.6-1) 但是 2.5-0ubuntu14 正要被安装
依赖: libemeraldengine0 但是它将不会被安装
依赖: libglib2.0-0 (>= 2.14.0) 但是 2.12.11-0ubuntu1 正要被安装
依赖: libgtk2.0-0 (>= 2.12.0) 但是 2.10.11-0ubuntu3 正要被安装
依赖: libpango1.0-0 (>= 1.18.3) 但是 1.16.2-0ubuntu1 正要被安装
依赖: libwnck22 (>= 2.19.5) 但却无法安装它
依赖: libxdamage1 (>= 1:1.1) 但是 1:1.0.3-3 正要被安装
E: 无法安装的软件包
该怎么解决,我本来想装cf的,但安装cf是出现向上面类似的提示
头像
yaoms
帖子: 4953
注册时间: 2007-10-19 14:51
来自: 深圳
送出感谢: 0
接收感谢: 2 次

#2

帖子 yaoms » 2008-03-11 9:54

用 aptitude 代替 apt-get 试试 。

另外不要发重复的主题。
Nothing 有事请发邮件到 yms541 AT gmail.com
alias 爱慕颇雷尔='mplayer'
头像
.
帖子: 418
注册时间: 2006-08-27 11:50
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 . » 2008-03-11 10:09

aptitude
--------------
我的博客:
http://leez.org
QQ群:65101372
safeiluos
帖子: 26
注册时间: 2007-05-08 16:40
送出感谢: 0
接收感谢: 0

#4

帖子 safeiluos » 2008-03-11 10:17

都试过了,没用
头像
yaoms
帖子: 4953
注册时间: 2007-10-19 14:51
来自: 深圳
送出感谢: 0
接收感谢: 2 次

#5

帖子 yaoms » 2008-03-11 10:23

可能是你的源的问题,按照 WIKI里的快速设置指南(我的签名有连接)重新设置一下。

注意你的系统版本,不要搞混
Nothing 有事请发邮件到 yms541 AT gmail.com
alias 爱慕颇雷尔='mplayer'
回复

回到 “归档贴”