7.10 安装 build-essential和g++遇到的问题(已解决)

重复贴和参考价值不大的帖子,版主维护
回复
raokaishiwo
帖子: 12
注册时间: 2007-04-10 16:08
送出感谢: 0
接收感谢: 0

7.10 安装 build-essential和g++遇到的问题(已解决)

#1

帖子 raokaishiwo » 2008-03-13 13:29

raokai@raokai-laptop:~/桌面$ sudo apt-get install build-essential
[sudo] password for raokai:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
build-essential: 依赖: libc6-dev 但是它将不会被安装 或
libc-dev
依赖: g++ (>= 4:4.1.1) 但是它将不会被安装
dpkg: Breaks: dpkg-dev (< 1.14.0) 但是 1.13.24ubuntu6 正要被安装
E: 无法安装的软件包

raokai@raokai-laptop:~/桌面$ sudo apt-get install g++
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
g++: 依赖: g++-4.1 (>= 4.1.2) 但是它将不会被安装
E: 无法安装的软件包

如何解决?求教达人
上次由 raokaishiwo 在 2008-03-13 13:41,总共编辑 1 次。
头像
yaoms
帖子: 4953
注册时间: 2007-10-19 14:51
来自: 深圳
送出感谢: 0
接收感谢: 2 次

#2

帖子 yaoms » 2008-03-13 13:30

源对不对阿?你什么版本的系统,把源列表贴出来看看
Nothing 有事请发邮件到 yms541 AT gmail.com
alias 爱慕颇雷尔='mplayer'
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#3

帖子 BigSnake.NET » 2008-03-13 13:30

先确认你的源版本是对的
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
raokaishiwo
帖子: 12
注册时间: 2007-04-10 16:08
送出感谢: 0
接收感谢: 0

#4

帖子 raokaishiwo » 2008-03-13 13:32

应该不是源的问题,以前一直用这个
deb http://debian.ustc.edu.cn/ubuntu/ feisty main restricted universe multiverse
deb http://debian.ustc.edu.cn/ubuntu/ feisty-backports restricted universe multiverse
deb http://debian.ustc.edu.cn/ubuntu/ feisty-proposed main restricted universe multiverse
deb http://debian.ustc.edu.cn/ubuntu/ feisty-security main restricted universe multiverse
deb http://debian.ustc.edu.cn/ubuntu/ feisty-updates main restricted universe multiverse
deb-src http://debian.ustc.edu.cn/ubuntu/ feisty main restricted universe multiverse
deb-src http://debian.ustc.edu.cn/ubuntu/ feisty-backports main restricted universe multiverse
deb-src http://debian.ustc.edu.cn/ubuntu/ feisty-proposed main restricted universe multiverse
deb-src http://debian.ustc.edu.cn/ubuntu/ feisty-security main restricted universe multiverse
deb-src http://debian.ustc.edu.cn/ubuntu/ feisty-updates main restricted universe multiverse
raokaishiwo
帖子: 12
注册时间: 2007-04-10 16:08
送出感谢: 0
接收感谢: 0

#5

帖子 raokaishiwo » 2008-03-13 13:32

换成 cn99的也一样出问题
头像
yaoms
帖子: 4953
注册时间: 2007-10-19 14:51
来自: 深圳
送出感谢: 0
接收感谢: 2 次

#6

帖子 yaoms » 2008-03-13 13:33

系统什么版本?
Nothing 有事请发邮件到 yms541 AT gmail.com
alias 爱慕颇雷尔='mplayer'
raokaishiwo
帖子: 12
注册时间: 2007-04-10 16:08
送出感谢: 0
接收感谢: 0

#7

帖子 raokaishiwo » 2008-03-13 13:35

yaoms 写了:源对不对阿?你什么版本的系统,把源列表贴出来看看

版本说过了,7.10的。
貌似7.10问题多多,firefox经常莫名崩溃- -
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#8

帖子 BigSnake.NET » 2008-03-13 13:36

raokaishiwo 写了:应该不是源的问题,以前一直用这个
deb http://debian.ustc.edu.cn/ubuntu/ feisty main restricted universe multiverse
deb http://debian.ustc.edu.cn/ubuntu/ feisty-backports restricted universe multiverse
deb http://debian.ustc.edu.cn/ubuntu/ feisty-proposed main restricted universe multiverse
deb http://debian.ustc.edu.cn/ubuntu/ feisty-security main restricted universe multiverse
deb http://debian.ustc.edu.cn/ubuntu/ feisty-updates main restricted universe multiverse
deb-src http://debian.ustc.edu.cn/ubuntu/ feisty main restricted universe multiverse
deb-src http://debian.ustc.edu.cn/ubuntu/ feisty-backports main restricted universe multiverse
deb-src http://debian.ustc.edu.cn/ubuntu/ feisty-proposed main restricted universe multiverse
deb-src http://debian.ustc.edu.cn/ubuntu/ feisty-security main restricted universe multiverse
deb-src http://debian.ustc.edu.cn/ubuntu/ feisty-updates main restricted universe multiverse


系统升级了源也要升级
源要跟系统版本对应, 例如 7.10 就应该用 gutsy 的
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
头像
yaoms
帖子: 4953
注册时间: 2007-10-19 14:51
来自: 深圳
送出感谢: 0
接收感谢: 2 次

#9

帖子 yaoms » 2008-03-13 13:36

7.10的系统,你用7.04的源怎么行??换源阿!!!
Nothing 有事请发邮件到 yms541 AT gmail.com
alias 爱慕颇雷尔='mplayer'
raokaishiwo
帖子: 12
注册时间: 2007-04-10 16:08
送出感谢: 0
接收感谢: 0

#10

帖子 raokaishiwo » 2008-03-13 13:36

BigSnake.NET 写了:
raokaishiwo 写了:应该不是源的问题,以前一直用这个
deb http://debian.ustc.edu.cn/ubuntu/ feisty main restricted universe multiverse
deb http://debian.ustc.edu.cn/ubuntu/ feisty-backports restricted universe multiverse
deb http://debian.ustc.edu.cn/ubuntu/ feisty-proposed main restricted universe multiverse
deb http://debian.ustc.edu.cn/ubuntu/ feisty-security main restricted universe multiverse
deb http://debian.ustc.edu.cn/ubuntu/ feisty-updates main restricted universe multiverse
deb-src http://debian.ustc.edu.cn/ubuntu/ feisty main restricted universe multiverse
deb-src http://debian.ustc.edu.cn/ubuntu/ feisty-backports main restricted universe multiverse
deb-src http://debian.ustc.edu.cn/ubuntu/ feisty-proposed main restricted universe multiverse
deb-src http://debian.ustc.edu.cn/ubuntu/ feisty-security main restricted universe multiverse
deb-src http://debian.ustc.edu.cn/ubuntu/ feisty-updates main restricted universe multiverse


系统升级了源也要升级
源要跟系统版本对应, 例如 7.10 就应该用 gutsy 的


噢,多谢 ,呵呵,我试试看去
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#11

帖子 BigSnake.NET » 2008-03-13 13:37

raokaishiwo 写了:
yaoms 写了:源对不对阿?你什么版本的系统,把源列表贴出来看看

版本说过了,7.10的。
貌似7.10问题多多,firefox经常莫名崩溃- -


果然如此, 你的源版本不对
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
头像
yaoms
帖子: 4953
注册时间: 2007-10-19 14:51
来自: 深圳
送出感谢: 0
接收感谢: 2 次

#12

帖子 yaoms » 2008-03-13 13:39

7。10已经很稳定了。。。
Nothing 有事请发邮件到 yms541 AT gmail.com
alias 爱慕颇雷尔='mplayer'
raokaishiwo
帖子: 12
注册时间: 2007-04-10 16:08
送出感谢: 0
接收感谢: 0

#13

帖子 raokaishiwo » 2008-03-13 13:39

呵呵,问题解决了。
不好意思,以前一直不知道源要跟着换,多谢指教~
回复

回到 “归档贴”