当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 求助:mplayer无法显示字幕
帖子发表于 : 2008-03-19 14:19 

注册: 2008-03-16 0:04
帖子: 44
送出感谢: 0 次
接收感谢: 0 次
ssa和srt的字幕都不显示 右键加载也不行 怎么半?


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-03-19 16:00 

注册: 2008-03-16 0:04
帖子: 44
送出感谢: 0 次
接收感谢: 0 次
up


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-03-19 17:41 
头像

注册: 2007-06-13 15:57
帖子: 12564
地址: 在他乡
送出感谢: 50
接收感谢: 86
安装个smplayer,很容易的


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-03-19 17:49 
头像

注册: 2008-02-15 0:08
帖子: 1081
送出感谢: 0 次
接收感谢: 0 次
sudo apt-get install smplayer

mplayer作后端,今后就不要碰了,呵呵


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-03-19 19:20 

注册: 2008-03-16 0:04
帖子: 44
送出感谢: 0 次
接收感谢: 0 次
wavydoom 写道:
sudo apt-get install smplayer

mplayer作后端,今后就不要碰了,呵呵


用smplayer可以显示srt的字幕了 但ssa的还是无法显示(加载ssa字幕后 无法显示 字幕-sub选择只有“无”一个选项) 请问该怎么办?


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-03-19 20:39 
头像

注册: 2007-10-06 18:40
帖子: 4313
送出感谢: 0 次
接收感谢: 5
代码:
sudo aptitude install ttf-arphic-ukai



把config改了
引用:
david@austria:~/.mplayer$ cat config
# Write your default config options here!
zoom = "no"
sub-fuzziness=1
#ao=alsa #音频驱动选择
#vo=x11 #视频驱动选择
stop-xscreensaver=yes #是否允许播放视频时出现屏保
#monitoraspect=1024:768 #识别桌面分辨率为1280×800
subcp=cp936 #字幕字符集编码
#subfont-autoscale=1 #设置按什么方法来进行自动缩放字幕,0-不自动缩放,1-按电影高度缩放,2-按电影宽度缩放,3-按电影对角线缩放(默认值)
subfont-text-scale=3.6 #设置字幕文本的自动缩放系数(屏幕尺寸的百分比),值范围为0~100,默认值为5。
#subfont-osd-scale=8 #OSD字幕的自动缩放系统(屏幕尺寸的百分比),值范围为0~100,默认值为6。
font=/usr/share/fonts/truetype/arphic/ukai.ttf #选择字幕用的字体
#overlapsub=1 #支持多语言字幕。
#sub-fuzziness=1 #设定字幕自动加载的识别,播放时可以通过j键切换。
cache = 8192 #此选项指定用多少内存(以 kBytes 为单位)作为播放文件或 URL 的预缓冲。
dvd-device=/home/david/star


改 gui.conf
代码:
david@austria:~/.mplayer$ cat gui.conf
enable_audio_equ = "yes"
vo_driver = "xv"
vo_panscan = "0.000000"
vo_doublebuffering = "yes"
vo_direct_render = "yes"
vo_dxr3_device = "/dev/em8300-0"
v_framedrop = "1"
v_flip = "0"
v_ni = "no"
v_idx = "-1"
vf_pp = "no"
vf_autoq = "0"
vf_lavc = "no"
ao_driver = "alsa"
ao_volnorm = "no"
softvol = "yes"
ao_surround = "no"
ao_extra_stereo = "no"
ao_extra_stereo_coefficient = "1.000000"
dvd_device = "/home/david/star"
cdrom_device = "/dev/cdrom"
osd_level = "1"
sub_auto_load = "yes"
sub_unicode = "no"
ass_enabled = "no"
ass_use_margins = "no"
ass_top_margin = "0"
ass_bottom_margin = "0"
sub_pos = "100"
sub_overlap = "no"
sub_cp = "cp936"
font_factor = "0.750000"
font_name = "/usr/share/fonts/truetype/arphic/ukai.ttf"
font_encoding = "unicode"
font_text_scale = "3.790000"
font_osd_scale = "6.000000"
font_blur = "2.000000"
font_outline = "2.000000"
font_autoscale = "3"
cache = "yes"
cache_size = "8192"
playbar = "no"
load_fullscreen = "no"
show_videowin = "yes"
stopxscreensaver = "no"
autosync = "no"
autosync_size = "0"
gui_skin = "default"
gui_save_pos = "yes"
gui_main_pos_x = "3"
gui_main_pos_y = "388"
gui_video_out_pos_x = "517"
gui_video_out_pos_y = "169"
equ_channel_1 = "Front Right"
equ_channel_2 = "Front Left"
equ_channel_3 = "Rear Right"
equ_channel_4 = "Rear Left"
equ_channel_5 = "Center"
equ_channel_6 = "Bass"


最后把字幕和视频的文件名改成一样的
如AAA.avi AAA.srt


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-03-19 23:47 

注册: 2008-03-16 0:04
帖子: 44
送出感谢: 0 次
接收感谢: 0 次
syrano 写道:
代码:
sudo aptitude install ttf-arphic-ukai



把config改了
引用:
david@austria:~/.mplayer$ cat config
# Write your default config options here!
zoom = "no"
sub-fuzziness=1
#ao=alsa #音频驱动选择
#vo=x11 #视频驱动选择
stop-xscreensaver=yes #是否允许播放视频时出现屏保
#monitoraspect=1024:768 #识别桌面分辨率为1280×800
subcp=cp936 #字幕字符集编码
#subfont-autoscale=1 #设置按什么方法来进行自动缩放字幕,0-不自动缩放,1-按电影高度缩放,2-按电影宽度缩放,3-按电影对角线缩放(默认值)
subfont-text-scale=3.6 #设置字幕文本的自动缩放系数(屏幕尺寸的百分比),值范围为0~100,默认值为5。
#subfont-osd-scale=8 #OSD字幕的自动缩放系统(屏幕尺寸的百分比),值范围为0~100,默认值为6。
font=/usr/share/fonts/truetype/arphic/ukai.ttf #选择字幕用的字体
#overlapsub=1 #支持多语言字幕。
#sub-fuzziness=1 #设定字幕自动加载的识别,播放时可以通过j键切换。
cache = 8192 #此选项指定用多少内存(以 kBytes 为单位)作为播放文件或 URL 的预缓冲。
dvd-device=/home/david/star


改 gui.conf
代码:
david@austria:~/.mplayer$ cat gui.conf
enable_audio_equ = "yes"
vo_driver = "xv"
vo_panscan = "0.000000"
vo_doublebuffering = "yes"
vo_direct_render = "yes"
vo_dxr3_device = "/dev/em8300-0"
v_framedrop = "1"
v_flip = "0"
v_ni = "no"
v_idx = "-1"
vf_pp = "no"
vf_autoq = "0"
vf_lavc = "no"
ao_driver = "alsa"
ao_volnorm = "no"
softvol = "yes"
ao_surround = "no"
ao_extra_stereo = "no"
ao_extra_stereo_coefficient = "1.000000"
dvd_device = "/home/david/star"
cdrom_device = "/dev/cdrom"
osd_level = "1"
sub_auto_load = "yes"
sub_unicode = "no"
ass_enabled = "no"
ass_use_margins = "no"
ass_top_margin = "0"
ass_bottom_margin = "0"
sub_pos = "100"
sub_overlap = "no"
sub_cp = "cp936"
font_factor = "0.750000"
font_name = "/usr/share/fonts/truetype/arphic/ukai.ttf"
font_encoding = "unicode"
font_text_scale = "3.790000"
font_osd_scale = "6.000000"
font_blur = "2.000000"
font_outline = "2.000000"
font_autoscale = "3"
cache = "yes"
cache_size = "8192"
playbar = "no"
load_fullscreen = "no"
show_videowin = "yes"
stopxscreensaver = "no"
autosync = "no"
autosync_size = "0"
gui_skin = "default"
gui_save_pos = "yes"
gui_main_pos_x = "3"
gui_main_pos_y = "388"
gui_video_out_pos_x = "517"
gui_video_out_pos_y = "169"
equ_channel_1 = "Front Right"
equ_channel_2 = "Front Left"
equ_channel_3 = "Rear Right"
equ_channel_4 = "Rear Left"
equ_channel_5 = "Center"
equ_channel_6 = "Bass"


最后把字幕和视频的文件名改成一样的
如AAA.avi AAA.srt

这个没用阿 改完后连srt中文字幕都变乱码了阿 ssa还是没法显示


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译