当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 27 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : 帮忙 看 下 ,在 线等,哦想用U学c但 遇到 这个 问题
帖子发表于 : 2008-03-21 19:55 

注册: 2008-01-22 13:30
帖子: 75
送出感谢: 0 次
接收感谢: 0 次
在安装的时候,出现
[i]max@max-laptop:~$ sudo apt-get install build-essential
正在读取软件包列表... 完成
[u]正在分析软件包的依赖关系树
Reading state information... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
build-essential: 依赖: libc6-dev 但是它将不会被安装 或
libc-dev
依赖: g++ (>= 4:4.1.1) 但是它将不会被安装
E: 无法安装的软件包


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-03-21 19:59 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
源版本不对应系统版本


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-03-21 20:04 

注册: 2008-01-22 13:30
帖子: 75
送出感谢: 0 次
接收感谢: 0 次
那应该怎么 解决呢


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-03-21 20:06 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
http://wiki.ubuntu.org.cn/index.php?tit ... iant=zh-cn

认真看


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-03-21 20:15 

注册: 2008-01-22 13:30
帖子: 75
送出感谢: 0 次
接收感谢: 0 次
谢谢,在试


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-03-21 20:24 
头像

注册: 2008-02-27 14:14
帖子: 409
地址: Hangzhou
送出感谢: 0 次
接收感谢: 0 次
换源了看看吧


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-03-21 20:47 

注册: 2008-01-22 13:30
帖子: 75
送出感谢: 0 次
接收感谢: 0 次
还是 不行,我从新更新了源 添加了官方但还是不行


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-03-21 20:48 

注册: 2008-01-22 13:30
帖子: 75
送出感谢: 0 次
接收感谢: 0 次
麻烦讲仔细点,


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-03-21 20:59 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
http://wiki.ubuntu.org.cn/index.php?title=如何使用我们推荐的源


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-03-21 21:08 
头像

注册: 2006-01-18 12:55
帖子: 1347
地址: 也许真的没有人理解
送出感谢: 0 次
接收感谢: 1
kingcool0072000 写道:
还是 不行,我从新更新了源 添加了官方但还是不行

不是让你换别的地址的源,而是让你换正确的版本。
比如你使用7.10版本,那么你应该使用gutsy的源,而不是hardy的源。


_________________
MacBook Pro 15" User
Cocoa Programmer


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2008-03-21 21:20 

注册: 2008-01-22 13:30
帖子: 75
送出感谢: 0 次
接收感谢: 0 次
我自信没有用hardy的源 我删了其他只加了官方及99的,但还是不行


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2008-03-21 21:22 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
把你的源列表贴出来吧
还有你用什么版本的系统


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2008-03-21 21:32 

注册: 2008-01-22 13:30
帖子: 75
送出感谢: 0 次
接收感谢: 0 次
deb http://ubuntu.cn99.com/ubuntu/ gutsy main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ gutsy-security main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ gutsy-updates main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ gutsy-proposed main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ gutsy-backports main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ gutsy main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ gutsy-security main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ gutsy-updates main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ gutsy-proposed main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ gutsy-backports main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu-cn/ gutsy main restricted universe multiverse

deb http://archive.ubuntu.com/ubuntu/ gutsy main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ gutsy-security main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ gutsy-updates main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ gutsy-proposed main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ gutsy-backports main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ gutsy main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ gutsy-security main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ gutsy-updates main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ gutsy-proposed main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ gutsy-backports main restricted universe multiverse


Linux version 2.6.22-14-generic (buildd@terranova) (gcc version 4.1.3 20070929 (prerelease) (Ubuntu 4.1.2-16ubuntu2)) #1 SMP Tue Feb 12 07:42:25 UTC 2008
Linux max-laptop 2.6.22-14-generic #1 SMP Tue Feb 12 07:42:25 UTC 2008 i686 GNU/Linux

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 7.10
Release: 7.10
Codename: gutsy


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2008-03-21 21:48 

注册: 2008-01-22 13:30
帖子: 75
送出感谢: 0 次
接收感谢: 0 次
我的源列表和版本阿,谁 帮我看看


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2008-03-21 21:48 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
apt-get update


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 27 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译