当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [已解决]linux分区丢了
帖子发表于 : 2008-03-29 22:57 

注册: 2007-09-17 0:03
帖子: 56
送出感谢: 0 次
接收感谢: 0 次
今天突然整了个在XP下查看linux分区的软件Ext2Fsd,在挂载linux盘后系统要求重启,结果重启的时候,grub坏了,呜,两个系统都启不来,我会修复XP启动,就用xp盘启动,进修复控制台fixboot fixmbr修复了XP的启动,可是按照网上的方法用liveCD启动,进入终端修复grub却总出错,fdisk -i查看,吃惊的发现linux分区没有了,其他XP的分区还有swap分区都有的,这是为什么啊??
ps:进入修复后的XP,已经能看到经过Ext2Fsd挂载的linux分区了,而且里面的文件都在的.
怎么ubuntu自己认不得自己的分区了??高手指教下,有些乱,但应该可以看懂的

ubuntu@ubuntu:~$ sudo fdisk -l

Disk /dev/sda: 60.0 GB, 60022480896 bytes
255 heads, 63 sectors/track, 7297 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xf0b1ebb0

Device Boot Start End Blocks Id System
/dev/sda1 * 1 1216 9767488+ 7 HPFS/NTFS
/dev/sda2 1217 7297 48845632+ f W95 Ext'd (LBA)
/dev/sda5 1217 3648 19535008+ b W95 FAT32
/dev/sda6 3649 5472 14651248+ b W95 FAT32
/dev/sda7 5473 6689 9775521 b W95 FAT32
/dev/sda8 6690 7297 4883728+ b W95 FAT32
omitting empty partition (10)
omitting empty partition (10)

Disk /dev/sdb: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x03012450

Device Boot Start End Blocks Id System
/dev/sdb1 2 9729 78140160 f W95 Ext'd (LBA)
/dev/sdb5 2 3782 30370851 b W95 FAT32
/dev/sdb6 3783 6298 20209738+ b W95 FAT32
/dev/sdb7 6299 7295 8008371 b W95 FAT32
/dev/sdb8 7296 7652 2867571 b W95 FAT32
/dev/sdb9 7653 7963 2498076 82 Linux swap / Solaris



There is not linux partition??It must be sdb10,after the linux swap!!
What happend??


最后由 jlwoo 编辑于 2008-03-31 15:23,总共编辑了 2 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-03-30 1:36 
头像

注册: 2007-11-25 13:29
帖子: 6798
地址: 新疆博乐
系统: Ubuntu 12.04/14.04
送出感谢: 32
接收感谢: 84
没用过Ext2Fsd,

可以试试找到/boot/grub里的menu.lst,复制到XP的C:盘里,
然后也下载一个grldr放在在XP的C:盘里,
修改XP的boot.ini,加一句c:\grldr=Ubuntu,修改时间time=3(没有就加一句)

重启动,在显示菜单处,按方向键选择Ubuntu


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-03-30 4:08 
头像

注册: 2007-11-07 14:41
帖子: 296
地址: 佳木斯
送出感谢: 0 次
接收感谢: 0 次
把/和/boot分开来是明智的选择


_________________
Dell 1520
------------------------
Intel Core T7500
1G*2
120G
Nvidia 8600 GT
My BLOG


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-03-31 13:52 

注册: 2007-09-17 0:03
帖子: 56
送出感谢: 0 次
接收感谢: 0 次
linux分区找到了,原来Ext2Fsd把它设置成EXT2了,设置回来就认得了
不过重新root,setup成功后,开机的启动画面还是没有grub啊,还是直接进入XP了???????
怎么回事呢


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-03-31 15:01 
头像

注册: 2007-04-16 15:34
帖子: 120
送出感谢: 0 次
接收感谢: 0 次
bios 改一下硬盘启动


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-03-31 15:21 

注册: 2007-09-17 0:03
帖子: 56
送出感谢: 0 次
接收感谢: 0 次
问题解决了,因为我是双硬盘,活动分区在第一块硬盘,而ubuntu装在第二块硬盘,只要setup (hd0)就行了,而不是hd1,这样就搞定了
Ext2Fsd这东西真是不能乱用啊


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译