[问题] 下了pidgin2.4三个文件 不会安装 谁教我阿

重复贴和参考价值不大的帖子,版主维护
回复
头像
sydaint
帖子: 42
注册时间: 2008-03-27 21:07
送出感谢: 0
接收感谢: 0
联系:

[问题] 下了pidgin2.4三个文件 不会安装 谁教我阿

#1

帖子 sydaint » 2008-03-30 19:14

libpurple0_2.4.0-1~getdeb1_i386.deb
pidgin_2.4.0-1~getdeb1_i386.deb
pidgin-data_2.4.0-1~getdeb1_all.deb
直接安装不行要代码
谁给我个 谢谢 我垃圾
头像
sydaint
帖子: 42
注册时间: 2008-03-27 21:07
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 sydaint » 2008-03-30 19:15

直接安装是没有权限打开另外一个文件
先安装data文件 提示没有权限打开pidgin文件

救我阿 我想上QQ
头像
sydaint
帖子: 42
注册时间: 2008-03-27 21:07
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 sydaint » 2008-03-30 19:31

:oops: :oops:
头像
qiang_liu8183
论坛版主
帖子: 10670
注册时间: 2006-09-10 22:36
来自: 北京
送出感谢: 1 次
接收感谢: 6 次

#4

帖子 qiang_liu8183 » 2008-03-31 0:30

Google
看破、放下、自在、随缘、念佛
真诚、清净、平等、正觉、慈悲
头像
wenroy2001
帖子: 15
注册时间: 2008-03-31 0:27
送出感谢: 0
接收感谢: 0

#5

帖子 wenroy2001 » 2008-03-31 1:12

一、 http://downloads.sourceforge.net/pidgin ... .0.tar.bz2 ※ 先下載 pidgin source code

二、 $tar jvzf pidgin-2.4.0.tar.bz2 ※ 解 tar

三、 $ ./configure –prefix=/usr

※ 若有錯誤訊息,那可能是有什麼必須的函式庫沒有安裝...(最下面有需要的函式庫)
有時這個地方會出錯,如:GMSGFMT 沒有定義好,所以要去修改 po/Makefile 檔案,
在 GMSGFMT 定義的地方改成:GMSGFMT = msgfmt

四、 $ make

五、 $ sudo make install


build-essential ※ 會安裝 make、gcc 等編譯原始碼常用的軟體
libgtk2.0-dev ※ 因為 Pidgin 是以 GTK+ 開發的,所以需要 GTK+ 的函式庫
libxml2-dev ※ 會需要的...
libgnutls-dev ※ 為了讓 Pidgin 支援 MSN
gettext ※ 這樣才會有 msgfmt

# 本文轉錄 http://blog.ericsk.org/archives/613 國二學生認真打雜的 blog...
头像
carbont
帖子: 3406
注册时间: 2007-11-22 10:20
来自: 北京
送出感谢: 0
接收感谢: 1 次

#6

帖子 carbont » 2008-03-31 4:18

好像我就是直接用源安装的,不太麻烦的样子。
lenovo Thinkpad R60i 0657 LHC
windowsXP……准备换回ubuntu了。

Twitter: @carbont
头像
qiang_liu8183
论坛版主
帖子: 10670
注册时间: 2006-09-10 22:36
来自: 北京
送出感谢: 1 次
接收感谢: 6 次

#7

帖子 qiang_liu8183 » 2008-03-31 5:10

carbont 写了:好像我就是直接用源安装的,不太麻烦的样子。
因为你是怪物:D
看破、放下、自在、随缘、念佛
真诚、清净、平等、正觉、慈悲
头像
carbont
帖子: 3406
注册时间: 2007-11-22 10:20
来自: 北京
送出感谢: 0
接收感谢: 1 次

#8

帖子 carbont » 2008-03-31 5:16

qiang_liu8183 写了:
carbont 写了:好像我就是直接用源安装的,不太麻烦的样子。
因为你是怪物:D
why??
没有明白是啥意思……
lenovo Thinkpad R60i 0657 LHC
windowsXP……准备换回ubuntu了。

Twitter: @carbont
头像
wenroy2001
帖子: 15
注册时间: 2008-03-31 0:27
送出感谢: 0
接收感谢: 0

#9

帖子 wenroy2001 » 2008-03-31 11:26

carbont 写了:好像我就是直接用源安装的,不太麻烦的样子。
你說用源安裝應該是 2.1 的版本吧,上面那個是 2.4 用 source code 去 compiler 的...
头像
patrickhe
帖子: 681
注册时间: 2005-07-21 19:13
来自: Peking, China
送出感谢: 0
接收感谢: 0
联系:

Re: [问题] 下了pidgin2.4三个文件 不会安装 谁教我阿

#10

帖子 patrickhe » 2008-03-31 11:47

sydaint 写了:libpurple0_2.4.0-1~getdeb1_i386.deb
pidgin_2.4.0-1~getdeb1_i386.deb
pidgin-data_2.4.0-1~getdeb1_all.deb
直接安装不行要代码
谁给我个 谢谢 我垃圾

代码: 全选

sudo dpkg -i libpurple0_2.4.0-1~getdeb1_i386.deb pidgin_2.4.0-1~getdeb1_i386.deb pidgin-data_2.4.0-1~getdeb1_all.deb
头像
sydaint
帖子: 42
注册时间: 2008-03-27 21:07
送出感谢: 0
接收感谢: 0
联系:

#11

帖子 sydaint » 2008-04-12 9:29

谢谢大家 太热心了~
头像
carbont
帖子: 3406
注册时间: 2007-11-22 10:20
来自: 北京
送出感谢: 0
接收感谢: 1 次

#12

帖子 carbont » 2008-04-12 9:35

wenroy2001 写了:
carbont 写了:好像我就是直接用源安装的,不太麻烦的样子。
你說用源安裝應該是 2.1 的版本吧,上面那個是 2.4 用 source code 去 compiler 的...
8.04就是直接源安装的……
2.4.1的版本,欧洲官方源。
lenovo Thinkpad R60i 0657 LHC
windowsXP……准备换回ubuntu了。

Twitter: @carbont
回复

回到 “归档贴”