[问题]一直被这个库的问题所累

重复贴和参考价值不大的帖子,版主维护
回复
mengzhaizhuren
帖子: 28
注册时间: 2007-12-12 9:06
来自: 湖北武汉华中农业大学
送出感谢: 0
接收感谢: 0
联系:

[问题]一直被这个库的问题所累

#1

帖子 mengzhaizhuren » 2008-04-02 22:00

装multiget也是,xchm是,skype也是,请看:

代码: 全选

godson@godson-desktop:~$ sudo apt-get install xchm
[sudo] password for godson:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
Reading state information... 完成     
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
  xchm: 依赖: libwxgtk2.6-0 (>= 2.6.1.2ubuntu2) 但是它将不会被安装

于是乎找libwxgtk2.6-0 ,下面又出问题拉:

代码: 全选

godson@godson-desktop:~$ sudo apt-get install  libwxgtk2.6-0 
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
Reading state information... 完成     
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
  libwxgtk2.6-0: 依赖: libgtk2.0-0 (>= 2.8.0) 但是它将不会被安装

系统是ubuntu8.04。处理器:amd64
希望能得到指点!!!!
这种依赖的关系让很多的软件用不了,想找到一个比较清晰的解决思路!!!
谢谢大家!!!!
web3.0,heros born now!!这就是游戏,就看你怎么玩~~
http://g-android.5d6d.com/bbs.php
Android中文第一社区
头像
leeaman
帖子: 30702
注册时间: 2007-02-02 18:14
系统: debian sid
送出感谢: 1 次
接收感谢: 23 次

#2

帖子 leeaman » 2008-04-02 22:10

1. 确定你的源跟UBuntu的版本是对应的
2. sudo apt-get update 了吗?
3. 尝试使用 aptitude install
4. 等待源更新

盗版 :D
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)
头像
ubuntuing
帖子: 192
注册时间: 2008-03-22 9:02
送出感谢: 0
接收感谢: 0

#3

帖子 ubuntuing » 2008-04-03 13:02

言之有理,有理、有理、、、
我以前(7.04)也出现过类似上述的情况,是在自己更改源后。
之后就趁还是刚装的系统、就重装了。用了盘里面的源后再无此况。
从此以后我就坚定一个理儿:没有很大很大必要的话,打死也不乱换源了。
(貌似某人说过:老换源容易引起系统不稳定)
回复

回到 “归档贴”