当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 10 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 不能安装编译环境
帖子发表于 : 2008-04-04 15:37 

注册: 2008-03-30 22:12
帖子: 30
送出感谢: 0 次
接收感谢: 0 次
求救:
执行安装命令事显示如下:~$ sudo apt-get install build-essential
E: 无法获得锁 /var/lib/dpkg/lock - open (11 Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?
谁帮帮我阿。先谢过了。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 不能安装编译环境
帖子发表于 : 2008-04-04 15:41 

注册: 2006-03-10 15:10
帖子: 3182
地址: xi'an China
送出感谢: 0 次
接收感谢: 2
引用:
求救:
执行安装命令事显示如下:~$ sudo apt-get install build-essential
E: 无法获得锁 /var/lib/dpkg/lock - open (11 Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?
谁帮帮我阿。先谢过了。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-04-04 15:46 

注册: 2008-03-30 22:12
帖子: 30
送出感谢: 0 次
接收感谢: 0 次
上面的 问题已解决,又出现了新问题,郁闷阿!!!!!!
sudo apt-get install build-essential
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
build-essential: 依赖: libc6-dev 但是它将不会被安装 或
libc-dev
依赖: g++ (>= 4:4.1.1) 但是它将不会被安装
有谁知道如何解决阿!!!!!!!!!!谢谢。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-04-04 16:11 
头像

注册: 2007-02-02 18:14
帖子: 30702
系统: debian sid
送出感谢: 1
接收感谢: 34
引用:
1. 确定你的源跟UBuntu的版本是对应的
2. sudo apt-get update 了吗?
3. 尝试使用 aptitude install
4. 等待源更新
:D


_________________
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-04-04 16:16 

注册: 2006-03-10 15:10
帖子: 3182
地址: xi'an China
送出感谢: 0 次
接收感谢: 2
引用:
上面的 问题已解决,又出现了新问题,郁闷阿!!!!!!
sudo apt-get install build-essential
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
build-essential: 依赖: libc6-dev 但是它将不会被安装 或
libc-dev
依赖: g++ (>= 4:4.1.1) 但是它将不会被安装
有谁知道如何解决阿!!!!!!!!!!谢谢。


问问题前多搜索一下论坛和wiki好不好?
http://wiki.ubuntu.org.cn/%E5%A6%82%E4% ... 4%E6%BA%90

检查你的源设对了没??


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-04-04 20:45 

注册: 2008-03-30 22:12
帖子: 30
送出感谢: 0 次
接收感谢: 0 次
我装了两个源:台大和官网,版本对应阿!还是无法解决阿,急急急!!!!!!!!!!!!!!!!


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-04-04 20:50 
头像

注册: 2007-10-19 14:51
帖子: 4953
地址: 深圳
送出感谢: 0 次
接收感谢: 2
把源贴出来看看。


_________________
Nothing 有事请发邮件到 yms541 AT gmail.com
alias 爱慕颇雷尔='mplayer'


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-04-05 11:39 

注册: 2008-03-30 22:12
帖子: 30
送出感谢: 0 次
接收感谢: 0 次
已经弄好了,谢谢各位。


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-04-05 11:39 

注册: 2008-03-30 22:12
帖子: 30
送出感谢: 0 次
接收感谢: 0 次
已经弄好了,谢谢各位。


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-06-24 15:36 

注册: 2007-09-19 9:32
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
怎么弄好的,铁出来了!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 10 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译