当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 再来求助:安装NVIDIA显卡驱动出错?!
帖子发表于 : 2008-04-04 17:13 
头像

注册: 2008-03-22 9:02
帖子: 192
送出感谢: 0 次
接收感谢: 0 次
本打算按照wiki上装的,如下:
sudo apt-get install nvidia-glx
sudo apt-get install nvidia-settings
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf_backup
sudo nvidia-glx-config enable
sudo gedit /usr/share/applications/NVIDIA-Settings.desktop
可是装到此时(如下)出现--
zhouguofeng@zhouguofeng-desktop:~$ sudo nvidia-glx-config enable
sudo: nvidia-glx-config: command not found
请问为何出现此况?该怎么办?


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-04-04 17:21 
头像

注册: 2007-10-13 9:41
帖子: 60
地址: o(^_^)o
送出感谢: 0 次
接收感谢: 0 次
sudo nvidia-xconfig

试试

* 单击 Search 搜索按钮并搜索 "linux-restricted-modules"。您必须要启用 restricted 软件库(参见上节)
* 找到与您内核匹配的模块。例如,如果您安装了 linux-image-amd64-k8,那么您将
* 如果您的显卡为 TNT, TNT2, TNT Ultra, GeForce1, 或 GeForce2, 请安装 nvidia-glx-legacy, 否则,请安装 nvidia-glx 软件包.
* 如果您准备编译3D应用程序,请安装 nvidia-glx-dev 软件包.
* 如果您的系统为 Hoary Hedgehog 或 Breezy Badger, 请安装 nvidia-settings 和 nvidia-xconfig 软件包. 在 Ubuntu 6.06 LTS中 不要 安装其他软件包因为其会删除 nvidia-glx 软件包.
* 单击 Search 搜索 按钮并搜索 "linux-restricted-modules". 您必须确保在Ubuntu软件仓库中选择了 restricted 模块 (见上方说明).
* 选择适合您内核的相关模块.例如如果您安装了 linux-image-amd64-k8 内核,您应该安装 linux-restricted-modules-amd64-k8软件包.
* 单击 Apply 应用 按钮来安装新的(已标记的)软件包.
* 一旦新立得软件包管理程序完成变更,将其关闭.
* 选择屏幕上方的 Applications 应用程序菜单,然後选择 Accessories 附件, Terminal 终端.
* 在终端窗口中输入如下命令:

sudo nvidia-xconfig


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-04-04 18:44 

注册: 2007-09-17 22:36
帖子: 45
送出感谢: 0 次
接收感谢: 0 次
直接在受限驱动里面不就解决了!
呵呵
一般都可以的!


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-04-04 20:01 
头像

注册: 2008-03-22 9:02
帖子: 192
送出感谢: 0 次
接收感谢: 0 次
受限驱动正如其名--效果也很受限。
同志们:我想说的是,我弄好了!期间还不知道那儿出错了重启后说是xserver出错!吓怀我了。
用旁边的本本儿google了一下,最终用下面的方法搞定
开机时候选第二中模式 进去后 sudo dpkg-reconfigure xserver-xorg
一般的就直接点击知道要选你的分辨率及驱动,根据自己的情况选。之后startx,就进入图形界面了,再重启便可回来了!

回来后我继续安装NVIDIA,是按照下面的做的
代码:
sudo apt-get install nvidia-glx
sudo nvidia-glx-config enable
nvidia-settings
nvidia-xconfig
能进行到这里就好多了

/etc/X11/xorg.conf是X服务器的主要配置文件,修改它即可改变分辨率和刷新频率
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf_backup

开始修了
sudo gedit /etc/X11/xorg.conf

(里面就所今天配置了)
Section "Monitor"更改刷新频率

Option "DPMS"
HorizSync 31-83
VertRefresh 56-76
EndSection
找到Section "Screen"段 更改分辨率
5按住 Ctrl +Alt + Backspace 重启 X


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-04-04 20:29 

注册: 2008-04-04 20:22
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
jeffreyxiii@jeffreyxiii-desktop:~$ sudo dpkg -i /home/jeffreyxiii/wqy-zenhei-0.5.23-0.deb
[sudo] password for jeffreyxiii:
(正在读取数据库 ... 系统当前总共安装有 95771 个文件和目录。)
正预备替换 wqy-zenhei 0.4.23-1 (使用 .../wqy-zenhei-0.5.23-0.deb) ...
正在解压缩将用于更替的包文件 wqy-zenhei ...
/usr/share/fonts/truetype/arphic: failed to write cache
dpkg:警告 - 原先的 post-removal 脚本 退出时返回了错误号 1
dpkg - 现转而试用新软件包所带的脚本...
/usr/share/fonts/truetype/arphic: failed to write cache
dpkg:处理 /home/jeffreyxiii/wqy-zenhei-0.5.23-0.deb (--install)时出错:
子进程 新的 post-removal 脚本 返回了错误号 1
/usr/share/fonts/truetype/arphic: failed to write cache
dpkg: 作下列清理工作时发生错误:
子进程 post-removal script 返回了错误号 1
在处理时有错误发生:
/home/jeffreyxiii/wqy-zenhei-0.5.23-0.deb


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-04-04 20:34 

注册: 2008-04-04 20:22
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
发错不好意思。。


NVIDIA驱动我觉得还是手动安装好

NVIDIA官方驱动程序配置:
由于市面上同显示核心的显卡的PCB版本千差万别,特别是像同德一类的非公版显卡很可能出现一些非常奇怪的无法安装驱动的问题如我的宏硕版的 Geforce FX 5200 128M就遇上这样的问题,这时就不得不使用最为麻烦的NVIDIA官方驱动,在下载页中找到*.run结尾的下载链接。
下载后将文件CP到/Home/username/目录下,接下来的工作将在Ubuntu的终端里完成:sudo apt-get install build-essential pkg-config xserver-xorg-dev linux-headers-'uname -r' libc6-dev(强烈推荐以上软件在新得立里找)

sudo cp /etc/default/linux-restricted-modules-common /etc/default/linux-restricted-modules-common.backup

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup

修改/etc/default/linux-restricted-modules-common:
sudo gedit /etc/default/linux-restricted-modules-common
将<DISABLED_MOUDULES=" ">改成<DISABLED_MOUDULES="nv( nvidia_new)">

关闭Xwindow:sudo /etc/init.d/gdm(kdm KDE的好像是) stop

登录用户

sudo sh NVIDIA-Linux-x86-169.04-pkg1.run(目前是beta版)

安装程序会提示是否接受协议,选accept,接着问是否成网上下载预编译模块,选NO,其他的就选OK或YES

最后执行sudo /etc/init.d/gdm(kdm KDE的好像是) start即可

这是我在网上找的


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-04-05 2:11 

注册: 2007-02-09 11:22
帖子: 47
送出感谢: 0 次
接收感谢: 0 次
直接点受限驱动还不是一样......


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译