当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 13 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : Ubuntu下有何好的编程工具?
帖子发表于 : 2008-04-08 9:40 

注册: 2007-12-26 15:56
帖子: 70
地址: MIT
送出感谢: 0 次
接收感谢: 0 次
本人菜鸟,请问Ubuntu下有何好用的编程工具,主要用于C语言编写,除Vim。请问各位高手用的都是何种?
{对于大型软件编写有益的}


最后由 Daniel23 编辑于 2008-04-08 9:49,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-04-08 9:41 
头像

注册: 2007-10-19 14:51
帖子: 4953
地址: 深圳
送出感谢: 0 次
接收感谢: 2
gedit emacs.....

为什么要把vim除外?


_________________
Nothing 有事请发邮件到 yms541 AT gmail.com
alias 爱慕颇雷尔='mplayer'


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-04-08 9:44 

注册: 2006-08-26 14:39
帖子: 271
地址: nj
送出感谢: 0 次
接收感谢: 0 次
就是啊,vi不是很好么.


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-04-08 9:50 
头像

注册: 2006-10-25 18:10
帖子: 2677
地址: 长沙
送出感谢: 0 次
接收感谢: 0 次
楼主可以查一下 CodeLite,开源的 C/C++ IDE。


_________________
你是自由的。别人也是。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-04-08 10:02 

注册: 2007-12-26 15:56
帖子: 70
地址: MIT
送出感谢: 0 次
接收感谢: 0 次
yiding_he 写道:
楼主可以查一下 CodeLite,开源的 C/C++ IDE。

这个看上去不错!现在在下载中...


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-04-08 13:08 

注册: 2007-12-26 15:56
帖子: 70
地址: MIT
送出感谢: 0 次
接收感谢: 0 次
yiding_he 写道:
楼主可以查一下 CodeLite,开源的 C/C++ IDE。

下的deb包,安装完成后无法运行,从终端启动提示CodeLite: /usr/lib/libwx_baseu-2.8.so.0: version `WXU_2.8.5' not found (required by CodeLite)
请问如何解决?


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-04-08 13:14 

注册: 2007-02-22 8:41
帖子: 39
送出感谢: 0 次
接收感谢: 0 次
eclipse netbeans


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-04-08 20:10 
头像

注册: 2008-02-18 0:25
帖子: 424
送出感谢: 0 次
接收感谢: 0 次
Daniel23 写道:
下的deb包, 安装完成后无法运行, 从终端启动提示CodeLite: /usr/lib/libwx_baseu-2.8.so.0: version `WXU_2.8.5' not found (required by CodeLite)
请问如何解决?

代码:
sudo apt-get install libwxbase2.8-0

IDE is evil.


_________________
图片


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-04-08 20:19 

注册: 2008-04-06 21:50
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
除了大家常用的之外,还有2种,一种是开发嵌入式系统用得最多的,叫啥我忘了,还有一种C开头的,号称最严格的检查最接近标准的C/C++实现,我另一台电脑上有,在书房,呃,这么远,不想过去看。


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-04-09 9:59 

注册: 2007-12-26 15:56
帖子: 70
地址: MIT
送出感谢: 0 次
接收感谢: 0 次
异域追梦者 写道:
Daniel23 写道:
下的deb包, 安装完成后无法运行, 从终端启动提示CodeLite: /usr/lib/libwx_baseu-2.8.so.0: version `WXU_2.8.5' not found (required by CodeLite)
请问如何解决?

代码:
sudo apt-get install libwxbase2.8-0

IDE is evil.

没有用啊!提示已经装过了,但是运行CodeLite时仍然会出现上面的错误信息。


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2008-04-09 10:00 

注册: 2007-12-26 15:56
帖子: 70
地址: MIT
送出感谢: 0 次
接收感谢: 0 次
polarisshine 写道:
除了大家常用的之外,还有2种,一种是开发嵌入式系统用得最多的,叫啥我忘了,还有一种C开头的,号称最严格的检查最接近标准的C/C++实现,我另一台电脑上有,在书房,呃,这么远,不想过去看。

拜托大侠今天告诉我吧!谢谢啦!


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2008-04-09 10:34 
头像

注册: 2007-05-08 16:26
帖子: 2058
地址: 火星内核某分子内某原子核内
系统: arch
送出感谢: 20
接收感谢: 6
[分享] Linux下用Anjuta写个Hello World 的C++程序竟如此简单 http://forum.ubuntu.org.cn/viewtopic.php?t=79137 ; http://forum.ubuntu.org.cn/commend.php?f=70


_________________
笔记本 :
F208S : gentoo
A460P i3G D6 : UBUNTU + WIN7
UN43D1 : UBUNTU + WIN7
1000人超级QQ群 LINUX + WIN : 31465544 或 18210387


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2008-04-09 10:36 
头像

注册: 2007-10-19 14:51
帖子: 4953
地址: 深圳
送出感谢: 0 次
接收感谢: 2
sevk 写道:
[分享] Linux下用Anjuta写个Hello World 的C++程序竟如此简单 http://forum.ubuntu.org.cn/viewtopic.php?t=79137 ; http://forum.ubuntu.org.cn/commend.php?f=70
helloworld用vim写,恐怕只会更简单。。


_________________
Nothing 有事请发邮件到 yms541 AT gmail.com
alias 爱慕颇雷尔='mplayer'


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 13 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译