当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 1 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 想在我的迈拓MSS网络硬盘盒上安装 Apache+PHP+MySQL 出现问题,求助
帖子发表于 : 2008-04-11 12:17 

注册: 2008-04-11 12:12
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
看到以下这篇文章
http://discuz.orz101.com/viewthread.php ... ht=bcm4780
想在我的迈拓MSS网络硬盘盒上安装 Apache+PHP+MySQL 出现问题,求助
我是新手,想在我的迈拓MSS网络硬盘盒上安装 Apache+PHP+MySQL 出现问题,求助
我的/etc/apt/sources.list的内容如下
代码:
deb ftp://debian.linux.org.tw/debian/ testing main
deb-src ftp://debian.linux.org.tw/debian/ testing main

deb ftp://opensource.nchc.org.tw/debian/ testing main
deb-src ftp://opensource.nchc.org.tw/debian/ testing main

deb http://security.debian.org/ testing/updates main


安装apache,输入
(none):/# apt-get install apache2
Reading package lists... Done
Building dependency tree... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
apache2: Depends: apache2-mpm-worker (>= 2.2.8-3) but it is not going to be installed or
apache2-mpm-prefork (>= 2.2.8-3) but 2.2.3-4+etch4 is to be installed or
apache2-mpm-event (>= 2.2.8-3) but it is not going to be installed
locales: Depends: glibc-2.7-1
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
(none):/#
请问怎么办?
我用dselect更新时出现以下提示
代码:
The following packages will be upgraded:
adduser apache2 apache2-mpm-prefork apache2-utils apache2.2-common apt
apt-utils aptitude at base-files base-passwd bash bc bin86 bind9-host
binutils bison bsdmainutils bsdutils ca-certificates console-common
console-data coreutils cpio cron dc debconf debconf-i18n
debian-archive-keyring debianutils dhcp3-common dialog dictionaries-common
diff dnsutils doc-linux-text dpkg dpkg-dev dselect e2fslibs e2fsprogs ed
exim4 exim4-base exim4-config exim4-daemon-light file findutils finger flex
ftp gcc-4.1-base gdb gettext gettext-base gnupg gpgv grep groff-base gzip
hostname iamerican ibritish info initscripts iptables iputils-ping ispell
klogd laptop-detect less libacl1 libapache2-mod-php5 libapr1 libaprutil1
libattr1 libblkid1 libbz2-1.0 libc6 libcomerr2 libcurl3 libcurl3-gnutls
libcurses-perl libcurses-ui-perl libdb4.2 libdb4.3 libdb4.4 libedit2
libevent1 libexpat1 libfreetype6 libgc1c2 libgcc1 libgcrypt11 libgd2-noxpm
libgnutls13 libgpg-error0 libgpmg1 libidn11 libidn11-dev libjpeg62 libkadm55
libkrb53 libldap2 liblocale-gettext-perl liblockfile1 libmagic1
libmysqlclient15off libncurses5 libncursesw5 libnewt0.52 libnfsidmap2
libnss-db libpam-modules libpam-runtime libpam0g libpcap0.7 libpcap0.8
libpcre3 libperl5.8 libpng12-0 libreadline5 librpcsecgss3 libsasl2-2
libselinux1 libsemanage1 libsepol1 libsigc++-2.0-0c2a libslang2 libsqlite3-0
libss2 libssl0.9.8 libstdc++6 libtasn1-3 libtext-charwidth-perl
libtext-iconv-perl libtext-wrapi18n-perl libtextwrap1 libusb-0.1-4 libuuid1
libwrap0 libxml2 login lsb-base lsof m4 mailx make makedev man-db manpages
manpages-dev mawk mime-support mktemp mldonkey-server module-init-tools
mount mpack mtools mtr-tiny mutt mysql-common nano ncurses-base ncurses-bin
ncurses-term net-tools netbase netcat nfs-common nmap nvi ocaml-base-nox
openssh-client openssh-server openssl passwd pciutils perl perl-base
perl-modules php5 php5-common pidentd pkg-config policycoreutils portmap ppp
pppconfig pppoe procps psmisc python python-central python-minimal
python-newt python-selinux python-semanage python-support python2.4
python2.4-minimal rcconf readline-common reportbug rtorrent screen sed
selinux-policy-refpolicy-targeted sharutils ssh strace sysklogd sysv-rc
sysv-rc-conf sysvinit sysvinit-utils tar tasksel tasksel-data tcpd telnet
texinfo traceroute ucf update-inetd util-linux vim-common vim-tiny w3m
wamerican wget whiptail whois zlib1g
235 upgraded, 32 newly installed, 3 to remove and 0 not upgraded.
2 not fully installed or removed.
Need to get 980kB/109MB of archives.
After unpacking 35.3MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 ftp://debian.linux.org.tw testing/main groff-base 1.18.1.1-20 [980kB]
Fetched 980kB in 2m42s (6033B/s)
Extracting templates from packages: 100%
Preconfiguring packages ...
hostname: Unknown host
(Reading database ... 24835 files and directories currently installed.)
Preparing to replace libc6 2.3.6.ds1-13etch5 (using .../libc6_2.7-10_mipsel.de ...
Checking for services that may need to be restarted...
Checking init scripts...
WARNING: POSIX threads library NPTL requires kernel version
2.6.8 or later. If you use a kernel 2.4, please upgrade it
before installing glibc.

The installation of a 2.6 kernel _could_ ask you to install a new libc
first, this is NOT a bug, and should *NOT* be reported. In that case,
please add etch sources to your /etc/apt/sources.list and run:
apt-get install -t etch linux-image-2.6
Then reboot into this new kernel, and proceed with your upgrade
dpkg: error processing /var/cache/apt/archives/libc6_2.7-10_mipsel.deb (--unpa):
subprocess pre-installation script returned error exit status 1
Errors were encountered while processing:
/var/cache/apt/archives/libc6_2.7-10_mipsel.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Some errors occurred while unpacking. I'm going to configure the
packages that were installed. This may result in duplicate errors
or errors caused by missing dependencies. This is OK, only the errors
above this message are important. Please fix them and run [i]nstall again
Press enter to continue.
意思好像是2.6 kernel 要安装新的libc,要我追加新的etch到sources.list,再运行apt-get install -t etch linux-image-2.6,是不是我原来的mirror中没有这个文件,请问如何添加呢?在哪找的这些呢?
我试图安装apt-spy 寻找最快的debian源sources.list ,但出现以下结果
(none):/# apt-get install apt-spy
Reading package lists... Done
Building dependency tree... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
apt-spy: Depends: libc6 (>= 2.7-1) but 2.3.6.ds1-13etch5 is to be installed
Depends: libcurl3 (>= 7.16.2-1) but 7.15.5-1etch1 is to be installed
locales: Depends: glibc-2.7-1
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
(none):/#
请问是否还是mirror中没有这个文件的问题?如何解决呢?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 1 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译