[问题]关于字幕乱码的。。。(个别行)

重复贴和参考价值不大的帖子,版主维护
回复
头像
zszzd
帖子: 156
注册时间: 2007-12-12 22:54
送出感谢: 0
接收感谢: 0

[问题]关于字幕乱码的。。。(个别行)

#1

帖子 zszzd » 2008-04-19 20:05

用mplayer,ASS字幕筹码,找论坛基本解决,但是出现一个奇怪的问题,有些字幕出现某些字时会导致整行字乱码,比如:“终”这个字,一出现就乱。。。不知如何解决?

又仔细看了下,在有乱码的地方把每个字中间加上空格,就不乱码了,是不是因为某些字和某些字排在一起就有问题?
囧了,这种事。。。。
上次由 zszzd 在 2008-04-21 11:40,总共编辑 2 次。
头像
bones7456
论坛版主
帖子: 8495
注册时间: 2006-04-12 20:05
来自: 杭州
送出感谢: 0
接收感谢: 8 次
联系:

#2

帖子 bones7456 » 2008-04-19 20:33

你用的啥字体?这么常见的字都会有问题?
关注我的blog: ε==3
linyjfei
帖子: 127
注册时间: 2007-06-05 0:05
送出感谢: 0
接收感谢: 0

#3

帖子 linyjfei » 2008-04-20 1:33

换个字体试试?我是把win下的字体拷出来用,没碰到过LZ的问题。
头像
zszzd
帖子: 156
注册时间: 2007-12-12 22:54
送出感谢: 0
接收感谢: 0

#4

帖子 zszzd » 2008-04-20 20:04

我就是用的WIN下的simhei.ttf
不知为何。。
头像
zszzd
帖子: 156
注册时间: 2007-12-12 22:54
送出感谢: 0
接收感谢: 0

#5

帖子 zszzd » 2008-04-21 11:38

在有乱码的行里 加空格就不乱了,为何?
头像
jarlyyn
论坛版主
帖子: 4671
注册时间: 2006-04-12 18:54
送出感谢: 0
接收感谢: 6 次
联系:

#6

帖子 jarlyyn » 2008-04-21 11:45

或许是自动识别编码出的问题?

指定字幕编码了吗?

当年windows下 曹操不是经常识别成了巨变吗?
头像
zszzd
帖子: 156
注册时间: 2007-12-12 22:54
送出感谢: 0
接收感谢: 0

#7

帖子 zszzd » 2008-04-21 11:50

在哪指定?
头像
ttand
帖子: 1743
注册时间: 2005-08-22 14:05
来自: 离开北京
送出感谢: 1 次
接收感谢: 3 次

#8

帖子 ttand » 2008-04-21 12:04

用GBK可能好点
简繁都有
错过好多好贴,没占到广告位后悔啊
头像
zszzd
帖子: 156
注册时间: 2007-12-12 22:54
送出感谢: 0
接收感谢: 0

#9

帖子 zszzd » 2008-04-21 16:19

ttand 写了:用GBK可能好点
简繁都有
在MPLAYER里只看到有CP936和繁体,没见有GBK
头像
syrano
帖子: 4313
注册时间: 2007-10-06 18:40
送出感谢: 0
接收感谢: 5 次

#10

帖子 syrano » 2008-04-21 18:41

zszzd 写了:
ttand 写了:用GBK可能好点
简繁都有
在MPLAYER里只看到有CP936和繁体,没见有GBK
选cp936
下面是我的配置

代码: 全选

david@david-desktop:~$ cat .mplayer/config
# Write your default config options here!
zoom = "no"
sub-fuzziness=1
#ao=alsa #音频驱动选择 
#vo=x11 #视频驱动选择 
stop-xscreensaver=no #是否允许播放视频时出现屏保 
#monitoraspect=1024:768 #识别桌面分辨率为1280×800
subcp=cp936 #字幕字符集编码 
#subfont-autoscale=1 #设置按什么方法来进行自动缩放字幕,0-不自动缩放,1-按电影高度缩放,2-按电影宽度缩放,3-按电影对角线缩放(默认值) 
subfont-text-scale=3.6 #设置字幕文本的自动缩放系数(屏幕尺寸的百分比),值范围为0~100,默认值为5。 
#subfont-osd-scale=8 #OSD字幕的自动缩放系统(屏幕尺寸的百分比),值范围为0~100,默认值为6。 
font=/usr/share/fonts/truetype/arphic/ukai.ttf #选择字幕用的字体 
#overlapsub=1 #支持多语言字幕。 
#sub-fuzziness=1 #设定字幕自动加载的识别,播放时可以通过j键切换。 
cache = 8192 #此选项指定用多少内存(以 kBytes 为单位)作为播放文件或 URL 的预缓冲。
dvd-device=/home/david/star
david@david-desktop:~$ cat .mplayer/gui.conf
enable_audio_equ = "yes"
vo_driver = "xv"
vo_panscan = "0.000000"
vo_doublebuffering = "yes"
vo_direct_render = "yes"
vo_dxr3_device = "/dev/em8300-0"
v_framedrop = "1"
v_flip = "0"
v_ni = "no"
v_idx = "-1"
vf_pp = "no"
vf_autoq = "0"
vf_lavc = "no"
ao_driver = "alsa"
ao_volnorm = "no"
softvol = "yes"
ao_surround = "no"
ao_extra_stereo = "no"
ao_extra_stereo_coefficient = "1.000000"
dvd_device = "/home/david/star"
cdrom_device = "/dev/cdrom"
osd_level = "1"
sub_auto_load = "yes"
sub_unicode = "no"
ass_enabled = "no"
ass_use_margins = "no"
ass_top_margin = "0"
ass_bottom_margin = "0"
sub_pos = "100"
sub_overlap = "no"
sub_cp = "cp936"
font_factor = "0.750000"
font_name = "/usr/share/fonts/truetype/arphic/ukai.ttf"
font_encoding = "unicode"
font_text_scale = "3.790000"
font_osd_scale = "6.000000"
font_blur = "2.000000"
font_outline = "2.000000"
font_autoscale = "3"
cache = "yes"
cache_size = "8192"
playbar = "no"
load_fullscreen = "no"
show_videowin = "yes"
stopxscreensaver = "no"
autosync = "no"
autosync_size = "0"
gui_skin = "default"
gui_save_pos = "yes"
gui_main_pos_x = "369"
gui_main_pos_y = "452"
gui_video_out_pos_x = "114"
gui_video_out_pos_y = "189"
equ_channel_1 = "Front Right"
equ_channel_2 = "Front Left"
equ_channel_3 = "Rear Right"
equ_channel_4 = "Rear Left"
equ_channel_5 = "Center"
equ_channel_6 = "Bass"
头像
ttand
帖子: 1743
注册时间: 2005-08-22 14:05
来自: 离开北京
送出感谢: 1 次
接收感谢: 3 次

#11

帖子 ttand » 2008-04-21 23:51

写/etc/mplayer/mplayer.conf

我用的微软雅黑
font=/usr/share/fonts/msyh.ttf
subcp=GBK
subfont-text-scale=3.0

一直没有出现乱码 当然 我用 没有gtk gui的mplayer。
然后有gmplayer就不用设置了
错过好多好贴,没占到广告位后悔啊
回复

回到 “归档贴”