当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : ubuntu8.10的声音问题
帖子发表于 : 2008-09-30 10:58 

注册: 2007-04-22 12:17
帖子: 62
送出感谢: 0 次
接收感谢: 0 次
声音服务器总是会出现这样的问题:

选择Pulseaudio
audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink: Failed to connect stream: Invalid argument

选择ALSA
audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink: 无法从资源获得设置或在资源上设定设置。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: ubuntu8.10的声音问题
帖子发表于 : 2008-09-30 19:02 
头像

注册: 2008-03-28 10:18
帖子: 578
地址: 淮安and徐州
送出感谢: 1
接收感谢: 3
声音里选择oss
不过我的不知怎么的alsa又能用了


页首
 用户资料  
 
3 楼 
 文章标题 : Re: ubuntu8.10的声音问题
帖子发表于 : 2008-09-30 19:11 
头像

注册: 2006-11-18 18:52
帖子: 450
送出感谢: 0 次
接收感谢: 0 次
代码:
killall pulseaudio
pulseaudio &


页首
 用户资料  
 
4 楼 
 文章标题 : Re: ubuntu8.10的声音问题
帖子发表于 : 2008-10-01 22:48 
头像

注册: 2007-12-03 9:54
帖子: 943
送出感谢: 0 次
接收感谢: 0 次
nsnl 写道:
代码:
killall pulseaudio
pulseaudio &

这样就能用了,谢谢啊


页首
 用户资料  
 
5 楼 
 文章标题 : Re: ubuntu8.10的声音问题
帖子发表于 : 2008-12-25 17:27 

注册: 2008-09-28 0:43
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
谢谢,可以用了,但是我菜鸟不明白,大虾可否解释一下?


页首
 用户资料  
 
6 楼 
 文章标题 : Re: ubuntu8.10的声音问题
帖子发表于 : 2009-01-03 20:13 
头像

注册: 2008-09-23 22:23
帖子: 48
送出感谢: 0 次
接收感谢: 0 次
用了那两个命令以后声音就可以用了,但我重启后又出现那个错误,怎么回事?


页首
 用户资料  
 
7 楼 
 文章标题 : Re: ubuntu8.10的声音问题
帖子发表于 : 2009-01-03 20:23 
头像

注册: 2008-07-21 9:44
帖子: 2371
地址: 深圳
送出感谢: 0 次
接收感谢: 0 次
hellowangmin 写道:
谢谢,可以用了,但是我菜鸟不明白,大虾可否解释一下?


代码:
killall pulseaudio
pulseaudio &


貌似是先关闭pulseaudio,然后又开启pulseaudio(后台运行),相当于重启pulseaudio吧。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译