当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 10 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 升级8.10后出现的问题。大侠帮帮忙吧!该怎么解决?
帖子发表于 : 2008-10-03 22:21 

注册: 2005-08-30 22:58
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
sudo apt-get upgrade
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
下列软件包将被【卸载】:
linux-ubuntu-modules-2.6.24-16-generic
下列的软件包的版本将保持不变:
gstreamer0.10-plugins-ugly-multiverse mplayer
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 1 个软件包,有 2 个软件未被升级。
有 1 个软件包没有被完全安装或卸载。
解压缩后将会空出 15.8MB 的空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前总共安装有 111487 个文件和目录。)
正在删除 linux-ubuntu-modules-2.6.24-16-generic ...
FATAL: Could not open '/boot/System.map-2.6.24-16-generic': No such file or directory
update-initramfs: Generating /boot/initrd.img-2.6.24-16-generic
Cannot find /lib/modules/2.6.24-16-generic
update-initramfs: failed for /boot/initrd.img-2.6.24-16-generic
dpkg:处理 linux-ubuntu-modules-2.6.24-16-generic (--remove)时出错:
子进程 post-removal script 返回了错误号 1
在处理时有错误发生:
linux-ubuntu-modules-2.6.24-16-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 升级8.10后出现的问题。大侠帮帮忙吧!该怎么解决?
帖子发表于 : 2008-10-03 22:33 

注册: 2005-08-30 22:58
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
:em20 现在是什么软件也装不上了。
sudo apt-get -f install和用新立得也解决不了。也删除不掉这个内核。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 升级8.10后出现的问题。大侠帮帮忙吧!该怎么解决?
帖子发表于 : 2008-10-04 0:01 

注册: 2006-01-18 18:11
帖子: 254
送出感谢: 0 次
接收感谢: 0 次
直接用dpkg试试。
sudo dpkg -r --force-all 软件包名


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 升级8.10后出现的问题。大侠帮帮忙吧!该怎么解决?
帖子发表于 : 2008-10-04 9:06 

注册: 2005-08-30 22:58
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
还是不行

sudo dpkg -r --force-all linux-ubuntu-modules-2.6.24-16-generic

(正在读取数据库 ... 系统当前总共安装有 111487 个文件和目录。)
正在删除 linux-ubuntu-modules-2.6.24-16-generic ...
FATAL: Could not open '/boot/System.map-2.6.24-16-generic': No such file or directory
update-initramfs: Generating /boot/initrd.img-2.6.24-16-generic
Cannot find /lib/modules/2.6.24-16-generic
update-initramfs: failed for /boot/initrd.img-2.6.24-16-generic
dpkg:处理 linux-ubuntu-modules-2.6.24-16-generic (--remove)时出错:
子进程 post-removal script 返回了错误号 1
在处理时有错误发生:
linux-ubuntu-modules-2.6.24-16-generic


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 升级8.10后出现的问题。大侠帮帮忙吧!该怎么解决?
帖子发表于 : 2008-10-09 15:04 

注册: 2006-10-15 12:59
帖子: 140
送出感谢: 0 次
接收感谢: 0 次
用 locate 搜索内核版本,大概在 /var 下面有一个 文件,删掉就行了


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 升级8.10后出现的问题。大侠帮帮忙吧!该怎么解决?
帖子发表于 : 2008-10-14 0:18 
头像

注册: 2008-07-14 22:42
帖子: 8078
地址: Beijing
送出感谢: 0 次
接收感谢: 0 次
今天升级好像已经没有这个问题了 :em04


_________________
Ubuntu User


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 升级8.10后出现的问题。大侠帮帮忙吧!该怎么解决?
帖子发表于 : 2008-11-04 9:43 

注册: 2008-11-04 9:40
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
今天升级的时候也出现同样的问题,查了一下,发现下面的方法可行。

http://www.uluga.ubuntuforums.org/showt ... p?t=818397

引用:
You can work around this problem by removing the postrm scripts that
fail and prevent apt from removing these packags. If you're really not
going to use 2.6.24-16 and 2.6.24-17 kernels on this system (without
completely reinstalling them), that should be safe to do:

sudo rm /var/lib/dpkg/info/linux-backports-modules-2.6.24-16-generic.postrm
sudo rm /var/lib/dpkg/info/linux-backports-modules-2.6.24-17-generic.postrm
sudo rm /var/lib/dpkg/info/linux-ubuntu-modules-2.6.24-16-generic.postrm
sudo rm /var/lib/dpkg/info/linux-ubuntu-modules-2.6.24-17-generic.postrm
sudo apt-get remove linux-ubuntu-modules-2.6.24-16-generic \
linux-ubuntu-modules-2.6.24-17-generic \
linux-backports-modules-2.6.24-16-generic \
linux-backports-modules-2.6.24-17-generic


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 升级8.10后出现的问题。大侠帮帮忙吧!该怎么解决?
帖子发表于 : 2008-11-08 12:17 
头像

注册: 2007-12-16 0:45
帖子: 25
送出感谢: 0 次
接收感谢: 0 次
支持7楼,我也是参考这个方法解决804升级810后新立得无法更新的问题(虽然不太明白是什么意思)。


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 升级8.10后出现的问题。大侠帮帮忙吧!该怎么解决?
帖子发表于 : 2008-11-23 9:54 

注册: 2008-11-15 16:14
帖子: 39
送出感谢: 0 次
接收感谢: 0 次
我也照7楼那么解决的@谢谢搂住了!哈哈~~~


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 升级8.10后出现的问题。大侠帮帮忙吧!该怎么解决?
帖子发表于 : 2009-03-25 15:26 
头像

注册: 2009-03-19 9:19
帖子: 1423
地址: 江苏
送出感谢: 0 次
接收感谢: 2
我也是这样,安7楼的也去研究下看看,还是没搞定,郁闷哦。。。


_________________


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 10 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译