8.04->8.10升级出现如下错误,该如何解决。

重复贴和参考价值不大的帖子,版主维护
回复
头像
xuwu125
帖子: 204
注册时间: 2007-11-26 19:10
来自: 浙江省
送出感谢: 0
接收感谢: 0
联系:

8.04->8.10升级出现如下错误,该如何解决。

#1

帖子 xuwu125 » 2008-10-25 17:33

代码: 全选

... 前面的都一切顺利


正在解压缩将用于更替的包文件 ttf-sil-gentium ...
正预备替换 ttf-gentium 1.02+dfsg-4 (使用 .../ttf-gentium_1.02+dfsg1-5_all.deb) ...
正在解压缩将用于更替的包文件 ttf-gentium ...
正预备替换 ttf-indic-fonts-core 1:0.5.0-0ubuntu1 (使用 .../ttf-indic-fonts-core_1%3a0.5.4ubuntu2_all.deb) ...
正在解压缩将用于更替的包文件 ttf-indic-fonts-core ...
正预备替换 ttf-malayalam-fonts 1:0.5.0-0ubuntu1 (使用 .../ttf-malayalam-fonts_1%3a0.5.4ubuntu2_all.deb) ...
正在解压缩将用于更替的包文件 ttf-malayalam-fonts ...
正预备替换 x-ttcidfont-conf 27 (使用 .../x-ttcidfont-conf_29_all.deb) ...
Cleaning up font configuration of x-ttcidfont-conf...
Cleaning up category cmap..
Cleaning up category cid..
Cleaning up category truetype..
Can't exec "/usr/bin/mkcfm": 没有该文件或目录 at /var/lib/defoma/scripts/x-ttcidfont-conf.defoma line 791.
正在解压缩将用于更替的包文件 x-ttcidfont-conf ...
正预备替换 ttf-thai-tlwg 1:0.4.8-1 (使用 .../ttf-thai-tlwg_1%3a0.4.10-2_all.deb) ...
正在解压缩将用于更替的包文件 ttf-thai-tlwg ...
正预备替换 ttf-unfonts-core 1.0.1-6ubuntu1 (使用 .../ttf-unfonts-core_1.0.1-7ubuntu1_all.deb) ...
正在解压缩将用于更替的包文件 ttf-unfonts-core ...
正预备替换 tuxtype-data 1.5.6.dfsg1-3ubuntu4 (使用 .../tuxtype-data_1.5.17.dfsg1-3ubuntu1_all.deb) ...
正在解压缩将用于更替的包文件 tuxtype-data ...
正预备替换 ubufox 0.4~beta1-0ubuntu6 (使用 .../ubufox_0.6-0ubuntu1_all.deb) ...
正在解压缩将用于更替的包文件 ubufox ...
dpkg:警告 - 无法删除原有的目录“/usr/lib/firefox/extensions/ubufox@ubuntu.com/defaults/preferences”:目录不为空
dpkg:警告 - 无法删除原有的目录“/usr/lib/firefox/extensions/ubufox@ubuntu.com/defaults”:目录不为空
在处理时有错误发生:
 /var/cache/apt/archives/gnome-accessibility-themes_2.24.1-0ubuntu1_all.deb
 /var/cache/apt/archives/gnome-games-extra-data_2.24.0-0ubuntu1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

到这里就停止结束了。。。 请问该如何解决,或者说要不要解决。

代码: 全选

# sudo apt-get --help
# .....
# remove 删除
# install 安装
# 本 APT 具有超级牛力。
# sudo apt-get remove window* && sudo apt-get install ubuntu && sudo init 1
# ......
# 正在为您配置NB的系统...
# 系统正在为您关机.....
Linux水吧
kaiman
帖子: 127
注册时间: 2007-03-20 14:19
送出感谢: 0
接收感谢: 0

Re: 8.04->8.10升级出现如下错误,该如何解决。

#2

帖子 kaiman » 2008-10-25 20:26

sudo apt-get clean
然后重试升级。
头像
windwiny
帖子: 2254
注册时间: 2007-03-13 17:26
送出感谢: 0
接收感谢: 1 次

Re: 8.04->8.10升级出现如下错误,该如何解决。

#3

帖子 windwiny » 2008-10-25 21:03

/var/cache/apt/archives/gnome-accessibility-themes_2.24.1-0ubuntu1_all.deb
/var/cache/apt/archives/gnome-games-extra-data_2.24.0-0ubuntu1_all.deb
两个包出错

编辑 /var/lib/dpkg/info/包名.*inst 文件

这两个文件退出不为0,就安装不成功
回复

回到 “归档贴”