求助,高手帮我看看这是怎么回事阿?我安装或者升级好多程序都是提示这个。。。。

重复贴和参考价值不大的帖子,版主维护
回复
夜幕下大魅影
帖子: 4
注册时间: 2008-11-04 9:37
送出感谢: 0
接收感谢: 0

求助,高手帮我看看这是怎么回事阿?我安装或者升级好多程序都是提示这个。。。。

#1

帖子 夜幕下大魅影 » 2008-11-04 9:42

E: Couldn't configure pre-depend libc6 for findutils, probably a dependency cycle.
夜幕下大魅影
帖子: 4
注册时间: 2008-11-04 9:37
送出感谢: 0
接收感谢: 0

Re: 求助,高手帮我看看这是怎么回事阿?我安装或者升级好多程序都是提示这个。。。。

#2

帖子 夜幕下大魅影 » 2008-11-04 9:48

另外 安装eva时还有这个错误 E: Internal Error, Could not perform immediate configuration (2) on libc6
高手帮忙看看怎么解决吧。。。
夜幕下大魅影
帖子: 4
注册时间: 2008-11-04 9:37
送出感谢: 0
接收感谢: 0

Re: 求助,高手帮我看看这是怎么回事阿?我安装或者升级好多程序都是提示这个。。。。

#3

帖子 夜幕下大魅影 » 2008-11-04 10:12

hanjian@hanjian:~$ sudo apt-get install make gcc g++
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
将会安装下列额外的软件包:
cpp cpp-4.3 findutils g++-4.3 gcc-4.3 gcc-4.3-base libc6 libc6-dev
libc6-i686 libgcc1 libgmp3c2 libgomp1 libmpfr1ldbl libncurses5 libselinux1
libstdc++6 libstdc++6-4.3-dev linux-libc-dev tzdata util-linux
util-linux-locales
建议安装的软件包:
cpp-doc gcc-4.3-locales g++-multilib g++-4.3-multilib gcc-4.3-doc
libstdc++6-4.3-dbg gcc-multilib manpages-dev autoconf automake1.9 libtool
flex bison gcc-doc gcc-4.3-multilib libmudflap0-4.3-dev libgcc1-dbg
libgomp1-dbg libmudflap0-dbg glibc-doc libstdc++6-4.3-doc make-doc
下列【新】软件包将被安装:
cpp-4.3 g++ g++-4.3 gcc-4.3 gcc-4.3-base libc6-dev libgmp3c2 libgomp1
libmpfr1ldbl libstdc++6-4.3-dev linux-libc-dev
下列的软件包将被升级:
cpp findutils gcc libc6 libc6-i686 libgcc1 libncurses5 libselinux1
libstdc++6 make tzdata util-linux util-linux-locales
共升级了 13 个软件包,新安装了 11 个软件包,要卸载 0 个软件包,有 917 个软件未被升级。
需要下载 0B/24.3MB 的软件包。
解压缩后会消耗掉 52.3MB 的额外空间。
您希望继续执行吗?[Y/n]y
E: Couldn't configure pre-depend libc6 for findutils, probably a dependency cycle.
hanjian@hanjian:~$

这事怎么回呢??
头像
majia
帖子: 649
注册时间: 2008-08-25 10:40
送出感谢: 0
接收感谢: 0

Re: 求助,高手帮我看看这是怎么回事阿?我安装或者升级好多程序都是提示这个。。。。

#4

帖子 majia » 2008-11-04 11:31

命令里面没有“make”的吧 :em27
灌水专用
夜幕下大魅影
帖子: 4
注册时间: 2008-11-04 9:37
送出感谢: 0
接收感谢: 0

Re: 求助,高手帮我看看这是怎么回事阿?我安装或者升级好多程序都是提示这个。。。。

#5

帖子 夜幕下大魅影 » 2008-11-04 13:43

sudo apt-get install build-essential autoconf automake1.9 cvs subversion
这个命令把问题结局了。。
回复

回到 “归档贴”